当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求教安装mplayer时出错如何解决,谢谢
帖子发表于 : 2009-05-08 17:38 

注册: 2009-05-07 22:38
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
安装时提示Error: X11 support required for GUI compilation
我打算安装libgtk2.0-dev
但无法安装并提示:
libgtk2.0-dev: 依赖: libatk1.0-dev (>= 1.6.1-2) 但是它将不会被安装
依赖: libcairo2-dev 但是它将不会被安装
依赖: libglib2.0-dev (>= 2.12.0) 但是它将不会被安装
依赖: libgtk2.0-0 (= 2.12.9-3ubuntu5) 但是 2.16.1-0ubuntu2 正要被安装
依赖: libpango1.0-dev (>= 1.10.0-2) 但是它将不会被安装
依赖: libx11-dev (>= 2:1.0.0-6) 但是它将不会被安装
依赖: libxcomposite-dev 但是它将不会被安装
依赖: libxcursor-dev 但是它将不会被安装
依赖: libxdamage-dev 但是它将不会被安装
依赖: libxext-dev 但是它将不会被安装
依赖: libxfixes-dev 但是它将不会被安装
依赖: libxi-dev 但是它将不会被安装
依赖: libxinerama-dev 但是它将不会被安装
依赖: libxrandr-dev 但是它将不会被安装
E: 无法安装的软件包
请问这是什么原因,如何解决?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求教安装mplayer时出错如何解决,谢谢
帖子发表于 : 2009-05-09 15:53 
头像

注册: 2006-01-30 23:20
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
问题在这里:
引用:
依赖: libgtk2.0-0 (= 2.12.9-3ubuntu5) 但是 2.16.1-0ubuntu2 正要被安装

先升级系统到最新完好状态。然后再安装你说的那个包。
代码:
sudo apt-get update
sudo aptitude safe-upgrade

之后
代码:
sudo aptitude install libgtk2.0-dev


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求教安装mplayer时出错如何解决,谢谢
帖子发表于 : 2009-05-11 22:51 

注册: 2009-05-07 22:38
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
不行阿,提示:open: 6700; closed: 4982; defer: 0; conflict: 10
在限定的时间内没能找到解决方案。加把劲再试试?[Y/n]


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求教安装mplayer时出错如何解决,谢谢
帖子发表于 : 2009-05-15 12:24 
头像

注册: 2006-01-30 23:20
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
请贴出完整输出。
那个提示是哪条命令给出的?


_________________
--
我设了不接受论坛短信,需要PM请使用E-mail。
我的邮箱: sylecn 圈 yahoo 点 com 点 cn


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求教安装mplayer时出错如何解决,谢谢
帖子发表于 : 2009-10-05 9:58 

注册: 2009-01-22 13:51
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
sylecn 写道:
问题在这里:
引用:
依赖: libgtk2.0-0 (= 2.12.9-3ubuntu5) 但是 2.16.1-0ubuntu2 正要被安装

先升级系统到最新完好状态。然后再安装你说的那个包。
代码:
sudo apt-get update
sudo aptitude safe-upgrade

之后
代码:
sudo aptitude install libgtk2.0-dev


请问sudo aptitude safe-upgrade这个是什么意思?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译