当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : mplayer and gcc problem
帖子发表于 : 2006-08-11 17:03 

注册: 2006-08-11 16:59
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
root@deepass-desktop:/home/deepass/Desktop/MPlayer-1.0pre7try2# ./configure
Detected operating system: Linux
Detected host architecture: i386
Checking for cc version ... not found
Checking for gcc version ... not found
Checking for gcc-3.4 version ... not found
Checking for gcc-3.3 version ... not found
Checking for gcc-3.2 version ... not found
Checking for gcc-3.1 version ... not found
Checking for gcc3 version ... not found
Checking for gcc-3.0 version ... not found
Checking for cc version ... not found

*** Please downgrade/upgrade C compiler to version gcc-2.95.x or gcc-3.x! ***

You are not using a supported compiler. We do not have the time to make sure
everything works with compilers other than the ones we use. Use either the
same compiler as we do, or use --disable-gcc-checking but DO *NOT* REPORT BUGS
unless you can reproduce them after recompiling with a 2.95.x or 3.x version!

Note for gcc 2.96 users: Some versions of this compiler are known to miscompile
mplayer and lame (which is used for mencoder). If you get compile errors,
first upgrade to the latest 2.96 release (minimum 2.96-85) and try again.
If the problem still exists, try with gcc 3.x (or 2.95.x) *BEFORE* reporting
bugs!

GCC 2.96 IS NOT AND WILL NOT BE SUPPORTED BY US !

*** For details please read DOCS/HTML/en/users-vs-dev.html ***


Error: Bad gcc version

Check "configure.log" if you do not understand why it failed.

I have donwloaded the source,but I can't configure and the gcc command can't be used
I also donwloaded the source, but it can't be configure,why?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-11 17:16 

注册: 2005-11-18 20:52
帖子: 201
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install build-essential


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-22 21:35 

注册: 2006-08-19 21:37
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我也遇到这样的问题了。
用gcc -v 检查gcc的版本,显示是4.0.3。安装mplayer的时候出错,显示gcc版本是2.96, 要我用2.95或3.X版的gcc才能装mplayer.

楼上的命令我打进去了,结果还是一样。我的出错信息也是和lz一样。现在应该是降级呢还是升级gcc呢?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-22 22:26 

注册: 2005-10-28 17:40
帖子: 172
送出感谢: 0 次
接收感谢: 0 次
现在MPlayer已经有1.0pre8了,那个可以用gcc4.0编译。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译