当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 音频编辑软件audacity安装全过程
帖子发表于 : 2009-08-26 9:18 

注册: 2009-06-08 10:58
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
make 报错


vamp-sdk/PluginAdapter.cpp: In member function ‘const VampPluginDescriptor* Vamp::PluginAdapterBase::Impl::getDescriptor()’:
vamp-sdk/PluginAdapter.cpp:175: 错误: ‘strdup’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:184: 错误: ‘malloc’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In destructor ‘Vamp::PluginAdapterBase::Impl::~Impl()’:
vamp-sdk/PluginAdapter.cpp:264: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In static member function ‘static void Vamp::PluginAdapterBase::Impl::vampReleaseOutputDescriptor(VampOutputDescriptor*)’:
vamp-sdk/PluginAdapter.cpp:523: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:524: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:525: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:526: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:530: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:534: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:535: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In member function ‘void Vamp::PluginAdapterBase::Impl::cleanup(Vamp::Plugin*)’:
vamp-sdk/PluginAdapter.cpp:586: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:589: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:592: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In member function ‘VampOutputDescriptor* Vamp::PluginAdapterBase::Impl::getOutputDescriptor(Vamp::Plugin*, unsigned int)’:
vamp-sdk/PluginAdapter.cpp:643: 错误: ‘malloc’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:645: 错误: ‘strdup’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In member function ‘VampFeatureList* Vamp::PluginAdapterBase::Impl::convertFeatures(Vamp::Plugin*, const std::map<int, std::vector<Vamp::Plugin::Feature, std::allocator<Vamp::Plugin::Feature> >, std::less<int>, std::allocator<std::pair<const int, std::vector<Vamp::Plugin::Feature, std::allocator<Vamp::Plugin::Feature> > > > >&)’:
vamp-sdk/PluginAdapter.cpp:753: 错误: ‘free’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp:758: 错误: ‘strdup’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In member function ‘void Vamp::PluginAdapterBase::Impl::resizeFS(Vamp::Plugin*, int)’:
vamp-sdk/PluginAdapter.cpp:796: 错误: ‘realloc’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In member function ‘void Vamp::PluginAdapterBase::Impl::resizeFL(Vamp::Plugin*, int, size_t)’:
vamp-sdk/PluginAdapter.cpp:819: 错误: ‘realloc’在此作用域中尚未声明
vamp-sdk/PluginAdapter.cpp: In member function ‘void Vamp::PluginAdapterBase::Impl::resizeFV(Vamp::Plugin*, int, int, size_t)’:
vamp-sdk/PluginAdapter.cpp:842: 错误: ‘realloc’在此作用域中尚未声明
make[2]: *** [vamp-sdk/PluginAdapter.o] 错误 1


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 音频编辑软件audacity安装全过程
帖子发表于 : 2009-08-26 12:28 
头像

注册: 2007-10-21 18:36
帖子: 3235
地址: 汕头/广东/中国
送出感谢: 2
接收感谢: 3
sudo apt-get install audacity :em06


_________________
老子的哲学是“”,庄子的哲学是“
人有一技在身,则逍遥游而无不为


页首
 用户资料  
 
3 楼 
 文章标题 : post from IRC #ubuntu-cn
帖子发表于 : 2010-03-04 14:59 

注册: 2010-02-27 16:48
帖子: 375
送出感谢: 0 次
接收感谢: 0 次
不懂就别来   <-----来自IRC聊天室#ubuntu-cn的网友expexp的回帖。欢迎访问 Ubuntu 中文官方支持频道http://webchat.freenode.net。频道填#ubuntu-cn,用户名随意。疑难问题大牛现场解答


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 音频编辑软件audacity安装全过程
帖子发表于 : 2010-04-28 17:43 
头像

注册: 2007-09-11 23:33
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
看来是没有正常加载头文件,应该是 cstring 和 cstdlib 两个头文件,在出问题的 vamp-sdk/PluginAdapter.cpp 的文件里加上如下内容试试看:
代码:
#include <cstring>
#include <cstdlib>


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译