当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : esd没了。重新安装了一次相关的包。可以了。
帖子发表于 : 2006-08-21 19:11 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
代码:
$ dpkg -l *esd*|grep ^ii
ii  gstreamer0.10-esd   0.10.3-0ubuntu4  GStreamer plugin for ESD
ii  libesd-alsa0        0.2.36-3ubuntu3  Enlightened Sound Daemon (ALSA) - Shared lib
ii  libesd0-dev         0.2.36-3ubuntu3  Enlightened Sound Daemon - Development files
ii  libsdl1.2debian-esd 1.2.9-0.0ubuntu2 Simple DirectMedia Layer (with X11 and esoun
ii  mpg123-esd          0.59r-21         MPEG layer 1/2/3 audio player with Esound su
$ dpkg -l *esound*|grep ^ii
ii  esound         0.2.36-3ubuntu3 Enlightened Sound Daemon - Support binaries
ii  esound-clients 0.2.36-3ubuntu3 Enlightened Sound Daemon - clients
ii  esound-common  0.2.36-3ubuntu3 Enlightened Sound Daemon - Common files


音频那里esd不能连接到Esound Daemon了。
发现Enlightened Sound Daemon - clients 包确实卸载了。真奇怪。


_________________
● 鸣学


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-22 1:52 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
我的集成声卡坏了,添了一块创新的声卡,mplay播放音乐时总出错,alsa-control:mixer attach default error:No such file or directory (换声卡后才装的mplayer所以不知道以前会不会)
配置gstreamer的时候还出现 找不到I82801DBICH4设备之类的错误 (I82801DBICH4集成了声卡)
可能是集成声卡配置没有被清除
alsaconf命令没了,现在怎么配置声卡


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-22 8:43 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
glade 写道:
我的集成声卡坏了,添了一块创新的声卡,mplay播放音乐时总出错,alsa-control:mixer attach default error:No such file or directory (换声卡后才装的mplayer所以不知道以前会不会)
配置gstreamer的时候还出现 找不到I82801DBICH4设备之类的错误 (I82801DBICH4集成了声卡)
可能是集成声卡配置没有被清除
alsaconf命令没了,现在怎么配置声卡

有个gstreamer-register命令,很早以前用过这个,是换了机器的系统这样作的
wiki记得有个udev -r的命令,是重新自动识别硬件。
或者dpkg-reconfigure all都试试。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-22 14:56 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
不行,找不到命令

声卡能用了,我的问题不在硬件识别,而是更新声卡的配置文件
用多媒体系统选择器时,如果选择ALSA输出,测试的时候就会提示找不到设备
用Auto dectect才有声音
输入也必须选OSS,不然录音没声音


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-08-22 14:57 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
我在网上找了个alsaconf执行了一遍,上面的问题还存在


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-08-22 15:02 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
代码:
$ dpkg -l alsa*|grep ^ii
ii  alsa-base            1.0.10-4ubuntu4  ALSA driver configuration files
ii  alsa-utils           1.0.10-1ubuntu14 ALSA utilities
ii  alsaplayer-common    0.99.76-7ubuntu2 PCM player designed for ALSA (common files)
ii  alsaplayer-esd       0.99.76-7ubuntu2 PCM player designed for ALSA (EsounD output
ii  alsaplayer-gtk       0.99.76-7ubuntu2 PCM player designed for ALSA (GTK version)

看样子是完全没有alsa了。这些模块有吗。

ls /etc/rc?.d/*alsa*看有什么。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-08-22 15:41 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
ls /etc/rc?.d/*alsa*

/etc/rc0.d/K50alsa-utils /etc/rc6.d/K50alsa-utils


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-08-22 15:42 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
dpkg -l alsa*|grep ^ii
没有找到与 alsaconf 相匹配的软件包。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-08-22 20:45 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
alsa-base alsa-utils 这2个安装


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-08-22 23:32 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install alsa-base alsa-utils
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
alsa-base 已经是最新的版本了。
alsa-utils 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。

dpkg -l alsa*|grep ^ii
没有找到与 alsaconf 相匹配的软件包。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-08-23 11:31 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
gstreamer0.10-alsa不知道你有没。


_________________
● 鸣学


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-08-23 12:12 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
这个包有的,新立得已经安装了


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-08-24 18:20 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
删除了我的家目录里的.asoundrc.asoundconf重启动就正常


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-08-24 18:24 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
?这么奇怪
有备份没,比较一下。给我也长点经验


_________________
● 鸣学


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-08-24 19:13 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
重启动后家目录没找到这个文件,说明它没什么用处吧


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译