当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : I want to install ppstream, hope for help
帖子发表于 : 2009-10-07 12:26 

注册: 2009-10-07 12:09
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
I want to install ppstream,and i have download four .dev files .when I want to install it, it need the password,I don,t know how to get it ,hope for help...


页首
 用户资料  
 
2 楼 
 文章标题 : Re: I want to install ppstream, hope for help
帖子发表于 : 2009-10-07 14:25 
头像

注册: 2009-05-18 13:51
帖子: 378
送出感谢: 1
接收感谢: 2
cat650 写道:
引用:
在karmic下编译发布,jaunty上也可安装。支持64位与32位。欢迎测试。

karmic下插件失效的问题已经被sunmoon解决了。打过补丁的libtotem-pl-parser已经上传到ppa了,原本karmic下无法播放的更新一下这个包就可以。

deb http://ppa.launchpad.net/portis25/ppa/ubuntu karmic main
deb-src http://ppa.launchpad.net/portis25/ppa/ubuntu karmic main


加入源后只需
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 27F5B2C1B3EAC8D9
sudo apt-get update
sudo apt-get install totem-pps

即可。依赖关系会自动将libpps, libppswrapper, gst-plugins-pps等包装上。
我打的libpps包版本是根据库版本0.1.826的,而论坛上有同学打的包版本是2.6.86-8896, 但是里面的库文件其实是0.1.779版本的。已经安装过libpps包的同学,最好先卸载老的libpps包再安装。
64位Karmic系统下测试没有问题。

具体版本:
libpps: 0.1.826
libppswrapper: 0.0.17.9
gst-plugins-pps: 0.0.17.15
totem-pps: 0.0.17.13

这个ppa里还包含以下软件: (Karmic下没有问题, Jaunty等其他版本可能存在依赖问题)
gst-plugins-sopcast: 0.0.4
totem-sopcast: 0.0.3
sopcast: 命令行的网络电视, karmic里已经没有libstdc++5库了, 需要自行安装该库。
lib32stdc++5: 32位的libstdc++5库,64位karmic系统需要安装, 不然sopcast无法运行, 为了照顾jaunty系统去掉了sopcast对lib32stdc++5的依赖,因此需要自行安装。
sopcast-player: 一个python写的GUI前端


flashplugin-nonfree: 这个主要针对64位系统,安装原生64位flash插件
gmlive:
ibus-qt4: ibus的qt4支持
jde: emacs的java支持包,修正了一个错误
lib32ibus: 我自己打的64位系统上的支持32位程序的ibus库,包含gtk和qt4支持。有了它,64位系统上qq, googleearth, skype等32位程序也可以用ibus输入法了。
linuxqq: 主要针对64位系统
monkeys-audio: ape无损格式编解码器
reciteword*: 好像叫黑客背单词?


最后由 portis21 编辑于 2009-09-27 6:15,总共编辑了 29 次
目前测试还可以,不知道是否有毒
其缓冲文件默认在 /tmp/pps 中,约预先占有1G空间。
配置文件 位于 /etc/ppscdn_config.ini 是否可以改就不知道了。

这里在使用前推荐使用(由于每次开机初始状态,pps文件夹是没有的,所以我们得重建)
代码:
cd /tmp
mkdir pps
sudo mount tmpfs /tmp/pps -t tmpfs
把缓冲文件放到内存中去,保护硬盘。重启后(或者卸载后)消失。麻烦的是每次开pps前都要记得输入命令。
内存不够就卸载就行,或者进去彻底删文件。这个映射会自动调整大小,
代码:
firefox的链接协议增加:
当你点击“在客户端播放”,firefox提示:“没有关于PPS的……”
这时你就需要添加协议了
在地址栏输入:about:config
在空白处使用鼠标右键击出菜单,选择“新建”-->“字符串”,
名称填“network.protocol-handler.app.pps”
值为:/usr/bin/totem
点击链接,此时出选项,如无法运行
“选择应用程序”
定位到/usr/bin/totem,即可播放。


_________________
kubuntu 14.04 64bit
AMD turion64 mk38 | Memory:4GB DDR2 800 | Graphic:nVidia Geforce 7000M/nforce 610M | M/B:ASUS F5N

Lubuntu 14.10 32bit
IBM T40 |INTEL centrino 1.3G| Memory:1GB DDR 533 |ATI Mobility RADEON 7500


页首
 用户资料  
 
3 楼 
 文章标题 : Re: I want to install ppstream, hope for help
帖子发表于 : 2009-10-07 14:27 
头像

注册: 2009-05-27 21:55
帖子: 1394
送出感谢: 1
接收感谢: 0 次
请楼主到影音区
自立自强


_________________


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译