MPlayer编译中的错误?大家帮忙看看

Totem,mplayer,sopcast,realplayer,bmp
回复
wlpsky
帖子: 55
注册时间: 2005-08-10 13:55
送出感谢: 0
接收感谢: 0
联系:

MPlayer编译中的错误?大家帮忙看看

#1

帖子 wlpsky » 2005-08-26 18:20

前面的configure全部通过,可是make的时候提示错误,后续无法进行了。。。


/usr/lib/libGL.a(glxcmds.o)(.text+0x2eea): In function `glXGetMscRateOML':
: undefined reference to `XF86VidModeQueryVersion'
/usr/lib/libGL.a(glxcmds.o)(.text+0x2f1a): In function `glXGetMscRateOML':
: undefined reference to `XF86VidModeGetModeLine'
collect2: ld returned 1 exit status
make: *** [mplayer] 错误 1
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#2

帖子 lyreopera » 2005-08-26 19:15

我也有这个错误,现在mplayer只有root能用。

http://forum.ubuntu.org.cn/viewtopic.php?t=2319
……
wlpsky
帖子: 55
注册时间: 2005-08-10 13:55
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 wlpsky » 2005-08-26 23:38

lyreopera 写了:我也有这个错误,现在mplayer只有root能用。

http://forum.ubuntu.org.cn/viewtopic.php?t=2319

难道说就不能编译gui的吗?
只能编译纯命令行模式的?

官方也没有解决的办法吗?

网上搜索了下,好险其他人也有这个问题
wlpsky
帖子: 55
注册时间: 2005-08-10 13:55
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 wlpsky » 2005-08-27 0:08

lyreopera 写了:我也有这个错误,现在mplayer只有root能用。

http://forum.ubuntu.org.cn/viewtopic.php?t=2319

我这里装个xxf86vm-dev包后编译成功
wlpsky
帖子: 55
注册时间: 2005-08-10 13:55
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wlpsky » 2005-08-27 0:33

wlpsky 写了:
lyreopera 写了:我也有这个错误,现在mplayer只有root能用。

http://forum.ubuntu.org.cn/viewtopic.php?t=2319

我这里装个xxf86vm-dev包后编译成功

可是为什么编译成功后无法使用呢?

wlpsky@ubuntu:~$ gmplayer
bash: gmplayer: command not found
wlpsky@ubuntu:~$ mplayer
bash: mplayer: command not found

使用root也没用。。。
但是/opt/mplayer/bin/下是有gmplayer和mplayer的

why?
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#6

帖子 lyreopera » 2005-08-27 0:39

只怕你根本没编译成功……
……
wlpsky
帖子: 55
注册时间: 2005-08-10 13:55
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 wlpsky » 2005-08-27 8:09

lyreopera 写了:只怕你根本没编译成功……

如何判断是否编译成功呢?

出了是否可以使用还有什么可以判断?
hszhsh
帖子: 36
注册时间: 2005-08-24 9:54
送出感谢: 0
接收感谢: 0

#8

帖子 hszhsh » 2005-08-28 12:50

我的编译成功,但gmplayer就是运行不了在root中也运行不了,只能用命令行模式。郁闷中~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
回复

回到 “影音多媒体”