当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-07 21:27 

注册: 2006-07-07 21:07
帖子: 451
送出感谢: 0 次
接收感谢: 0 次
不知道是习惯还是什么,就是不习惯totem,另外gstream那些解码器播放流畅度在我的机子上也没有win32codecs来的流畅。所以装好ub,第一件事就是干掉totme和一坨gstream库。
只是不知道ubuntu 9.10用的是哪个版本的mplayer(据说是svn库里面的),最近中文字幕老是搞不定,折腾了一个晚上终于解决了。

解决方法其实很简单:
方法一:修改LC_CTYPE,在/etc/environment文件中加入一行
LC_CTYPE=zh_CN.utf8

方法二:在mplayer的preference的subtitles & OSD中勾选上SSA/ASS subtitle rendering
这样也可以。

上述两种方法都可以解决中文字幕为横杠的问题,只是字体是系统的,不是你指定的。

方法三:哈哈,自己发现的,原来在mplayer的preferences的font页中,在选择字体的时候不能选择具体的字体文件,而是要输入字体名称。例如我用的是准圆字体,就不应该填写
~/.fonts/ZhunYuan.ttf
而应该填写 ZhunYuan

如此这般,mplayer又恢复常态了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-07 21:31 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <Derry> say: config中,cp936,记得登录环境export到zh_CN.UTF-8


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-07 21:31 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <gd510090> say: 试试能否通过机器人发帖


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-07 21:38 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <kilior> say: 1、确定字符编码,2、不要用那个该死的gmplayer,那是个垃圾


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-07 23:58 

注册: 2006-07-07 21:07
帖子: 451
送出感谢: 0 次
接收感谢: 0 次
sorry,其实我喜欢的就是那个gmplayer,哈哈


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-21 9:56 

注册: 2009-03-24 21:43
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
ok拉 谢谢楼主拉


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-21 13:35 
头像

注册: 2009-11-17 12:29
帖子: 883
送出感谢: 0 次
接收感谢: 0 次
= =
改了LC不就等于是中文环境了么
(只是缺少翻译文件罢了)

-ass -subcp enca:zh:cp936
搞定问题

如果是ASS/SSA字幕,字体应该是文件内指定的,你的~/.fonts目录下没有那当然是系统默认。。
有的话 自动会找到的


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-22 16:21 

注册: 2006-07-07 21:07
帖子: 451
送出感谢: 0 次
接收感谢: 0 次
zhu527812567 写道:
= =
改了LC不就等于是中文环境了么
(只是缺少翻译文件罢了)

-ass -subcp enca:zh:cp936
搞定问题

如果是ASS/SSA字幕,字体应该是文件内指定的,你的~/.fonts目录下没有那当然是系统默认。。
有的话 自动会找到的


-ass 就是那个ass选项。
我自己用的字体从来就是放在~/.fonts 目录的


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2009-11-26 16:51 

注册: 2009-03-24 21:43
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
tamsun 写道:
不知道是习惯还是什么,就是不习惯totem,另外gstream那些解码器播放流畅度在我的机子上也没有win32codecs来的流畅。所以装好ub,第一件事就是干掉totme和一坨gstream库。
只是不知道ubuntu 9.10用的是哪个版本的mplayer(据说是svn库里面的),最近中文字幕老是搞不定,折腾了一个晚上终于解决了。

解决方法其实很简单:
方法一:修改LC_CTYPE,在/etc/environment文件中加入一行
LC_CTYPE=zh_CN.utf8

方法二:在mplayer的preference的subtitles & OSD中勾选上SSA/ASS subtitle rendering
这样也可以。

上述两种方法都可以解决中文字幕为横杠的问题,只是字体是系统的,不是你指定的。

方法三:哈哈,自己发现的,原来在mplayer的preferences的font页中,在选择字体的时候不能选择具体的字体文件,而是要输入字体名称。例如我用的是准圆字体,就不应该填写
~/.fonts/ZhunYuan.ttf
而应该填写 ZhunYuan

如此这般,mplayer又恢复常态了。

以前还可以的 但是现在不知道为什么又不行拉 郁闷阿 哎


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 英文环境下9.10下mplayer中文字幕横线的解决
帖子发表于 : 2010-01-07 14:05 

注册: 2008-08-21 12:25
帖子: 64
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
谢谢 Preferences-->Font-->Encoding (Unicode)
Subtitles&OSD-->Encoding(CP936)
这是之前改的,无果。

再加用上1楼方法二 效果出现,很喜欢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译