当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]mplayer怎么配置初始音量
帖子发表于 : 2010-01-08 5:48 
头像

注册: 2007-10-22 17:40
帖子: 110
送出感谢: 0 次
接收感谢: 0 次
mplayer每次启动播放时音量都是100%,有时候把主音量调大后忘记调回来,开mplayer就会被雷到。请问如何调整mplayer的初始音量啊?谢谢。


最后由 dickfisch 编辑于 2010-01-08 21:10,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: mplayer怎么配置初始音量
帖子发表于 : 2010-01-08 8:35 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
建一个脚本,amixer设置好音量,再调用mp


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: mplayer怎么配置初始音量
帖子发表于 : 2010-01-08 16:38 
头像

注册: 2007-10-22 17:40
帖子: 110
送出感谢: 0 次
接收感谢: 0 次
惭愧,不会。我还是拨音量滚轮吧。谢谢啊。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: mplayer怎么配置初始音量
帖子发表于 : 2010-01-08 16:45 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
smplayer有,默认40%


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: mplayer怎么配置初始音量
帖子发表于 : 2010-01-08 21:09 
头像

注册: 2007-10-22 17:40
帖子: 110
送出感谢: 0 次
接收感谢: 0 次
在网上找到一个办法,只要带-af和-softvol -softvol-max这两个参数就可以了。

http://www.linuxdiyf.com/viewarticle.php?id=74861


页首
 用户资料  
 
6 楼 
 文章标题 : Re: mplayer怎么配置初始音量
帖子发表于 : 2010-01-08 23:07 
头像

注册: 2009-10-20 21:13
帖子: 2089
地址: Pacific Western University
送出感谢: 0 次
接收感谢: 7
让mplayer音量与alsa全局设置相同,可以加这个参数
代码:
-ao alsa


或修改mplayer config文件,
代码:
geidt ~/.mplayer/config


加入下面代码:

代码:
ao=alsa:device=plug=pcm

或者

代码:
ao=alsa:device=plug=default

或者
代码:
ao=alsa:device=pcm=default






可以看下你当前系统有多少alsa module可以选择

代码:
mplayer -ao help

参考文献:

http://www.linuxquestions.org/questions ... ax-773269/
http://www.thepenguin.org.uk/alsa/


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [已解决]mplayer怎么配置初始音量
帖子发表于 : 2010-01-09 16:58 
头像

注册: 2007-10-22 17:40
帖子: 110
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的同学,太棒了。 :em11


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [已解决]mplayer怎么配置初始音量
帖子发表于 : 2010-01-09 17:59 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
原来你们还在alsa哦。
:em04


_________________
● 鸣学


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [已解决]mplayer怎么配置初始音量
帖子发表于 : 2010-01-15 22:06 
头像

注册: 2009-10-20 21:13
帖子: 2089
地址: Pacific Western University
送出感谢: 0 次
接收感谢: 7
eexpress 写道:
原来你们还在alsa哦。
:em04


这位同学你用的是什么? oss?


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [已解决]mplayer怎么配置初始音量
帖子发表于 : 2010-01-15 22:10 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
神,原谅他吧 :em70


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [已解决]mplayer怎么配置初始音量
帖子发表于 : 2010-01-15 22:12 
头像

注册: 2006-02-28 3:11
帖子: 2470
送出感谢: 0 次
接收感谢: 0 次
hasee.wu 写道:
eexpress 写道:
原来你们还在alsa哦。
:em04


这位同学你用的是什么? oss?


同学??这样怎么可以, 要叫人家阿姨


_________________
一梦三年,
松风依旧,
萝月何曾老.


灵幽听微, 谁观玉颜?
灼灼春华, 绿叶含丹.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译