当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 播放高压缩avi的问题
帖子发表于 : 2010-02-06 11:43 

注册: 2010-02-06 11:41
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
从网上下的课件视频 就是那种2个多小时才70mb的avi
在windows下播放正常
在ubuntu 9.10下用自带的播放器只有声音 图像全是黑的
用mplayer播 fatal:could not initialize video filters(-vf) or video output (-vo)
求解


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:02 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
这个不知道什么压的,看看他的编码格式先啦,linux可能不支持的


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:10 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
不是解码器的问题,是vo问题


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:21 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
wmv的格式,mplayer都能模拟dx用dll解码器支持

所以没有理由mplayer不能播放


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:34 

注册: 2010-02-06 11:41
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
看了下是9kbps
视频编码是tscc 16位


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:37 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
解码器估计是错误了

代码:
mplayer -v -vo xv -ao pulse  文件


than paste it


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:45 

注册: 2010-02-06 11:41
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
如你所说 mplayer -v -vo xv -ao pulse '/media/doc/zAn'\''s doc/book/computer/C++DaNei/day01/c++ day01AM.avi'
结果神奇的是出来的是totem播放器 不是mplayer
问题依旧 有声音 图像全是黑的


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:48 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
zan727 写道:
如你所说 mplayer -v -vo xv -ao pulse '/media/doc/zAn'\''s doc/book/computer/C++DaNei/day01/c++ day01AM.avi'
结果神奇的是出来的是totem播放器 不是mplayer
问题依旧 有声音 图像全是黑的

unbelievable……


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-06 12:56 

注册: 2010-02-06 11:41
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
MPlayer SVN-r29237-4.4.1 (C) 2000-2009 MPlayer Team
CPU vendor name: GenuineIntel max cpuid level: 10
CPU: Intel(R) Core(TM)2 Duo CPU T5870 @ 2.00GHz (Family: 6, Model: 15, Stepping: 13)
extended cpuid-level: 8
extended cache-info: 134242368
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
Tests of OS support for SSE passed.
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled with runtime CPU detection.
get_path('codecs.conf') -> '/home/zan/.mplayer/codecs.conf'
Reading /home/zan/.mplayer/codecs.conf: Can't open '/home/zan/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration: --prefix=/usr --confdir=/etc/mplayer --datadir=/usr/share/mplayer --codecsdir=/usr/lib/codecs --enable-xvmc --enable-vdpau --enable-sdl --enable-ossaudio --enable-lirc --enable-freetype --enable-menu --enable-largefiles --extra-cflags=-I/build/buildd/mplayer-1.0~rc3+svn20090426/debian/include --disable-bitmap-font --disable-ggi --language=all --disable-xmms --disable-arts --disable-aa --disable-mad --disable-musepack --disable-libdv --disable-libavutil_a --disable-libavcodec_a --disable-libavformat_a --disable-libpostproc_a --disable-libswscale_a --enable-mp3lame --enable-faac-lavc --enable-x264-lavc --enable-mp3lame-lavc --enable-libdirac-lavc --enable-libschroedinger-lavc --target=i586-linux --enable-win32dll --enable-real --enable-xanim --enable-runtime-cpudetection --enable-vdpau --disable-libdvdcss-internal --enable-dvdread --enable-debug --enable-tv-v4l2 --enable-xmga --enable-mga --enable-3dfx --enable-tdfxfb --enable-fbdev --disable-gui
CommandLine: '-v' '-vo' 'xv' '-ao' 'pulse' '/media/doc/zAn's doc/book/computer/C++DaNei/day01/c++ day01AM.avi'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
get_path('fonts') -> '/home/zan/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/zan/.mplayer/input.conf'
Can't open input config file /home/zan/.mplayer/input.conf: No such file or directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 89 binds
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
get_path('c++ day01AM.avi.conf') -> '/home/zan/.mplayer/c++ day01AM.avi.conf'

Playing /media/doc/zAn's doc/book/computer/C++DaNei/day01/c++ day01AM.avi.
get_path('sub/') -> '/home/zan/.mplayer/sub/'
[file] File size is 75563214 bytes
STREAM: [file] /media/doc/zAn's doc/book/computer/C++DaNei/day01/c++ day01AM.avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: AVI format
AVI file format detected.
list_end=0xFC9C
======= AVI Header =======
us/frame: 200000 (fps=5.000)
max bytes/sec: 9562
padding: 1
MainAVIHeader.dwFlags: (2064) HAS_INDEX TRUST_CKTYPE
frames total: 39510 initial: 0
streams: 2
Suggested BufferSize: 538473
Size: 1020 x 734
==========================
list_end=0x7DF4
==> Found video stream: 0
[aviheader] Video stream found, -vid 0
====== STREAM Header =====
Type: vids FCC: tscc (63637374)
Flags: 0
Priority: 0 Language: 0
InitialFrames: 0
Rate: 10000000/2000000 = 5.000
Start: 0 Len: 39510
Suggested BufferSize: 538473
Quality 0
Sample size: 0
==========================
Found 'bih', 40 bytes of 40
======= VIDEO Format ======
biSize 40
biWidth 1020
biHeight 734
biPlanes 1
biBitCount 16
biCompression 1667462004='tscc'
biSizeImage 2994720
===========================
====== AVI Super Index Header ========
FCC (indx) dwSize (32024) wLongsPerEntry(4)
bIndexSubType (0) bIndexType (0)
nEntriesInUse (10) dwChunkId (00db)
dwReserved[0] (0) dwReserved[1] (0) dwReserved[2] (0)
===========================
ODML (00db): [0] 0x000000000000fca8 0x7d20 4000
ODML (00db): [1] 0x00000000006c9b0e 0x7d20 4000
ODML (00db): [2] 0x0000000000bcbdb6 0x7d20 4000
ODML (00db): [3] 0x00000000010e73c8 0x7d20 4000
ODML (00db): [4] 0x000000000163a936 0x7d20 4000
ODML (00db): [5] 0x0000000001b6e75a 0x7d20 4000
ODML (00db): [6] 0x0000000002636b78 0x7d20 4000
ODML (00db): [7] 0x0000000003003dc6 0x7d20 4000
ODML (00db): [8] 0x00000000039791e2 0x7d20 4000
ODML (00db): [9] 0x0000000003f9616c 0x7d20 3510
list_end=0xFB90
==> Found audio stream: 1
[aviheader] Audio stream found, -aid 1
====== STREAM Header =====
Type: auds FCC: (0)
Flags: 0
Priority: 0 Language: 0
InitialFrames: 0
Rate: 3000/1 = 3000.000
Start: 0 Len: 23706280
Suggested BufferSize: 3008
Quality 0
Sample size: 1
==========================
Found 'wf', 30 bytes of 18
======= WAVE Format =======
Format Tag: 85 (0x55)
Channels: 1
Samplerate: 11025
avg byte/sec: 3000
Block align: 1
bits/sample: 0
cbSize: 12
mp3.wID=1
mp3.fdwFlags=0x0
mp3.nBlockSize=1
mp3.nFramesPerBlock=1
mp3.nCodecDelay=0
==========================================================================
====== AVI Super Index Header ========
FCC (indx) dwSize (32024) wLongsPerEntry(4)
bIndexSubType (0) bIndexType (0)
nEntriesInUse (2) dwChunkId (01wb)
dwReserved[0] (0) dwReserved[1] (0) dwReserved[2] (0)
===========================
ODML (01wb): [0] 0x00000000000179c8 0x7d20 11999250
ODML (01wb): [1] 0x0000000001b66990 0x7d20 11707030
list_end=0xFC9C
AVI: dmlh found (size=248) (total_frames=39510)
list_end=0x4756D66
Found movie at 0xFCA8 - 0x4756D66
Reading INDEX block, 47414 chunks for 39510 frames (fpos=74804590).
AVI index offset: 0x0 (movi=0xFCA8 idx0=0xFCA8 idx1=0x1F6E8)
Auto-selected AVI audio ID = 1
Auto-selected AVI video ID = 0
AVI: Searching for audio stream (id:1)
AVI video size=50262103 (39510) audio size=23706280 (23706280)
VIDEO: [tscc] 1020x734 16bpp 5.000 fps 50.9 kbps ( 6.2 kbyte/s)
Auto-selected AVI audio ID = 1
[V] filefmt:3 fourcc:0x63637374 size:1020x734 fps:5.000 ftime:=0.2000
get_path('sub/') -> '/home/zan/.mplayer/sub/'
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1280x800 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Current fstype setting honours FULLSCREEN ABOVE BELOW X atoms
[VO_XV] Using Xv Adapter #0 (Radeon Textured Video)
[xv common] Drawing no colorkey.
[xv common] Maximum source image dimensions: 8192x8192
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat 10
INFO: libavcodec init OK!
Selected video codec: [ffcamtasia] vfm: ffmpeg (FFmpeg TechSmith Camtasia Screen Codec)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using SSE optimized decore!
MP3lib: init layer2&3 finished, tables done
MPEG 2.5, Layer III, 11025 Hz 24 kbit Single-Channel, BPF: 157
Channels: 1, copyright: No, original: No, CRC: No, emphasis: 0
AUDIO: 11025 Hz, 2 ch, s16le, 24.0 kbit/6.80% (ratio: 3000->44100)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Building audio filter chain for 11025Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 11025Hz/2ch/s16le
[dummy] Was reinitialized: 11025Hz/2ch/s16le
Trying preferred audio driver 'pulse', options '[none]'
[pulse] working around probably broken pause functionality,
see http://www.pulseaudio.org/ticket/440
AO: [pulse] 11025Hz 2ch s16le (2 bytes per sample)
AO: Description: PulseAudio audio output
AO: Author: Lennart Poettering
Building audio filter chain for 11025Hz/2ch/s16le -> 11025Hz/2ch/s16le...
[dummy] Was reinitialized: 11025Hz/2ch/s16le
[dummy] Was reinitialized: 11025Hz/2ch/s16le
Starting playback...
mpg123: Can't rewind stream by 530 bits!
Increasing filtered audio buffer size from 0 to 13056
Unsupported PixelFormat 10
[ffmpeg] aspect_ratio: 0.000000
Unsupported PixelFormat 10
VDec: vo config request - 1020 x 734 (preferred colorspace: Unknown 0x0000)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Unsupported PixelFormat 10
[ffmpeg] aspect_ratio: 0.000000
Unsupported PixelFormat 10
VDec: vo config request - 1020 x 734 (preferred colorspace: Unknown 0x0000)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.

FATAL: Could not initialize video filters (-vf) or video output (-vo).

Uninit audio filters...
[libaf] Removing filter dummy
Uninit audio: mp3lib
Uninit video: ffmpeg
vo: uninit ...

Exiting... (End of file)


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-09 9:57 
头像

注册: 2006-09-10 21:02
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
不止一个人在提问这个问题了,期待早点能有人解决


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 播放高压缩avi的问题
帖子发表于 : 2010-02-12 12:24 

注册: 2008-10-28 20:18
帖子: 3249
送出感谢: 0 次
接收感谢: 0 次
交通大学的网络课件吧?那个在Linux下没有解码器的...因为那个课件的解码器是交大自己开发的...以上


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译