[问题]MPlayer 字幕乱码,向前辈们求助,急!

Totem,mplayer,sopcast,realplayer,bmp
max.j.j.wong
帖子: 3
注册时间: 2006-10-06 12:34
送出感谢: 0
接收感谢: 0

[问题]MPlayer 字幕乱码,向前辈们求助,急!

#1

帖子 max.j.j.wong » 2006-10-07 0:18

各位前辈:

大家好!

我十月三号才刚刚彻底删掉 windows 操作系统,是个新手,请各位耐心帮助。

我现在用 MPlayer 播放器播放带 srt 字幕文件的电影,字幕显示为“___,____。”(下划线)。

不知道哪位前辈解决过类似的情况,帮忙解答一下。

下面是我之前的操作。

我按照 WiKi ubuntu 里的“安装 MPlayer“(http://wiki.ubuntu.org.cn/%E5%AE%89%E8%A3%85MPlayer)一步步设置,在最后“配置中文字幕显示(可选)”一项里发现有些不同:

如下是 WiKi ubuntu 教的设置:
配置中文字幕显示(可选)

cd ; mkdir .mplayer
ln -sf /usr/share/fonts/truetype/arphic/uming.ttf .mplayer/subfont.ttf
gedit .mplayer/gui.conf

sub_cp = "GBK"
font_text_scale = "4.000000"
font_osd_scale = "4.000000"
sub_fuzziness=2

当我操作完“gedit .mplayer/gui.conf ”后,gedit 显示如下:

enable_audio_equ = "no"
vo_driver = "xv"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "no"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "0"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
softvol = "no"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/dev/dvd"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
sub_pos = "100"
sub_overlap = "no"
sub_cp = "cp936"
font_factor = "0.750000"
font_encoding = "unicode"
font_text_scale = "4.000000"
font_osd_scale = "4.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "1"

cache = "no"
cache_size = "2048"
playbar = "no"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "337"
gui_main_pos_y = "605"
gui_video_out_pos_x = "200"
gui_video_out_pos_y = "208"
equ_channel_1 = "Front Right"
equ_channel_2 = "Front Left"
equ_channel_3 = "Rear Right"
equ_channel_4 = "Rear Left"
equ_channel_5 = "Center"
equ_channel_6 = "Bass"
equ_band_00 = "0.000000"
equ_band_01 = "0.000000"
equ_band_02 = "0.000000"
equ_band_03 = "0.000000"
equ_band_04 = "0.000000"
equ_band_05 = "0.000000"
equ_band_06 = "0.000000"
equ_band_07 = "0.000000"
equ_band_08 = "0.000000"
equ_band_09 = "0.000000"
equ_band_10 = "0.000000"
equ_band_11 = "0.000000"
equ_band_12 = "0.000000"
equ_band_13 = "0.000000"
equ_band_14 = "0.000000"
equ_band_15 = "0.000000"
equ_band_16 = "0.000000"
equ_band_17 = "0.000000"
equ_band_18 = "0.000000"
equ_band_19 = "0.000000"
equ_band_20 = "0.000000"
equ_band_21 = "0.000000"
equ_band_22 = "0.000000"
equ_band_23 = "0.000000"
equ_band_24 = "0.000000"
equ_band_25 = "0.000000"
equ_band_26 = "0.000000"
equ_band_27 = "0.000000"
equ_band_28 = "0.000000"
equ_band_29 = "0.000000"
equ_band_30 = "0.000000"
equ_band_31 = "0.000000"
equ_band_32 = "0.000000"
equ_band_33 = "0.000000"
equ_band_34 = "0.000000"
equ_band_35 = "0.000000"
equ_band_36 = "0.000000"
equ_band_37 = "0.000000"
equ_band_38 = "0.000000"
equ_band_39 = "0.000000"
equ_band_40 = "0.000000"
equ_band_41 = "0.000000"
equ_band_42 = "0.000000"
equ_band_43 = "0.000000"
equ_band_44 = "0.000000"
equ_band_45 = "0.000000"
equ_band_46 = "0.000000"
equ_band_47 = "0.000000"
equ_band_48 = "0.000000"
equ_band_49 = "0.000000"
equ_band_50 = "0.000000"
equ_band_51 = "0.000000"
equ_band_52 = "0.000000"
equ_band_53 = "0.000000"
equ_band_54 = "0.000000"
equ_band_55 = "0.000000"
equ_band_56 = "0.000000"
equ_band_57 = "0.000000"
equ_band_58 = "0.000000"
equ_band_59 = "0.000000"

其中红色字体部分找不到“sub_fuzziness=2”项,跟 WiKi ubuntu 上的不同。
另外,在 MPlayer ---- preferences ---- subtitle&OSD ----encoding 里没有 “GBK” 可供选择,“GBK”是不是需要另外下载啊?

上面操作完成后,字幕只显示下划线以及一些标点符号。

我还搜索过其他设置方法,都试过了,仍然不能解决字幕的问题,所以上来请教前辈们。

希望尽早得到前辈们的帮助,最近急需用能放字幕的播放器。

问题二:

idx 字幕文件可以在 Mplayer 里显示吗?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-10-07 1:44

这么复杂的设置????记得只要2句话的。天,现在的配置文件怎么这么多内容阿。
你可能需要指定一个带gbk字符集的字体。记得是ln -s一个字体到.mplayer下面。叫subfont什么的。
换了台机器,很久没用字幕了。老机器有配置,不想开而已 :lol:
● 鸣学
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 nobrain » 2006-10-07 10:32

有一些字幕是utf16的,

代码: 全选

iconv -f utf16 -t cp936 your_sub > your_sub_cp936
再重新load字幕试试
爱喝真猪奶茶的夜鸣猪
max.j.j.wong
帖子: 3
注册时间: 2006-10-06 12:34
送出感谢: 0
接收感谢: 0

还有问题。

#4

帖子 max.j.j.wong » 2006-10-07 13:28

感谢 nobrain 和 eexpress 的回复。

请问 nobrain ,怎么load 字幕?

谢谢!
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zhan » 2006-10-07 14:00

mplayer 是可以自动载入字幕的.右键不是还有菜单么
本版的置顶有多媒体指南的.照那个设置是没有问题的.去看看吧
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
websnail
帖子: 270
注册时间: 2006-06-01 12:42
送出感谢: 0
接收感谢: 0

#6

帖子 websnail » 2006-11-06 22:33

根本不复杂的,在mplayer的窗口点右键,选择Preference,然后设置Font,随便选一个,并设置字体的Code,比如用ubuntu自带的字体,就选unicode,然后把OSD/Sub编码选为字幕文件的编码,一般是Cp936。这样就OK了。
附件
Screenshot-Preferences-font.png
Screenshot-Preferences-1.png
xxxesxxx
帖子: 58
注册时间: 2007-06-29 21:34
送出感谢: 0
接收感谢: 0

#7

帖子 xxxesxxx » 2007-08-02 2:32

按六楼的方法搞定,感谢了
头像
email_liu
帖子: 21
注册时间: 2007-08-11 22:19
送出感谢: 0
接收感谢: 0

#8

帖子 email_liu » 2007-08-14 8:55

哈哈!我也搞定了!!!谢谢6楼!!!! :D
fadeout
帖子: 61
注册时间: 2007-04-20 10:14
送出感谢: 0
接收感谢: 0

#9

帖子 fadeout » 2007-10-08 1:02

谢谢,终于不受折磨了。
头像
qiufeng
帖子: 296
注册时间: 2007-09-04 13:51
来自: LC @ eastasia
送出感谢: 3 次
接收感谢: 1 次

#10

帖子 qiufeng » 2007-10-20 21:38

谢谢!没想到这么简单!
头像
vcan
帖子: 104
注册时间: 2007-04-14 20:08
送出感谢: 6 次
接收感谢: 0
联系:

#11

帖子 vcan » 2007-10-22 22:38

6楼实在太好了,感激不尽呀
mkii
帖子: 50
注册时间: 2007-10-24 12:49
送出感谢: 0
接收感谢: 0

#12

帖子 mkii » 2007-11-01 12:03

ass和ssa字幕加载不了怎么办?好象是utf-16的
转编码倒是可以看了,但偶尔会有一两句话变乱码,如何解决?
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

#13

帖子 haige » 2007-11-01 15:32

mplayer值得折腾,我在win上就用。
http://linuxtoy.org/archives/playing-ar ... layer.html
消除浮躁,静心学习,每天都在进步。
alanfly
帖子: 334
注册时间: 2007-12-19 16:15
送出感谢: 11 次
接收感谢: 13 次

我也弄好了,谢谢楼主

#14

帖子 alanfly » 2007-12-19 16:40

:D
头像
drvicar
帖子: 1285
注册时间: 2007-12-17 18:07
来自: 西安
送出感谢: 1 次
接收感谢: 1 次
联系:

#15

帖子 drvicar » 2007-12-19 18:08

:P 新手先谢过
回复

回到 “影音多媒体”