当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]编译mplayer中文显示乱码
帖子发表于 : 2006-10-08 10:51 

注册: 2006-10-05 8:16
帖子: 71
地址: 福建 厦门
送出感谢: 0 次
接收感谢: 0 次
以前在Debian上也遇到过同样的问题
我是用mplayer网站上下载的tarball编译的
发现如果configure的时候利用选项--language=zh_CN
安装后的gmplayer菜单就是乱码
如果不用那个选项,菜单就是英文的,而且,中文的文件和目录名就显示乱码
请问这到底是怎么回事?
前几天稀里糊涂地把中文菜单编译出来过
因为硬盘重新分区,就格了,现在无法显示中文了
求教~


_________________
上善若水


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-08 13:28 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
建议看看deb-src里的编译参数吧。在这个基础上改会比较省事


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-08 14:35 

注册: 2006-10-05 8:16
帖子: 71
地址: 福建 厦门
送出感谢: 0 次
接收感谢: 0 次
就是用apt-get 下载的源码包自己编译?
我试试看吧


_________________
上善若水


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-08 20:40 

注册: 2006-10-05 8:16
帖子: 71
地址: 福建 厦门
送出感谢: 0 次
接收感谢: 0 次
下载了mplayer-custo,发现还是没 什么收获(估计是我下错包了 )
最后一狠心,使用了如下明令:
make clean
apt-get build-dep mplayer
apt-get install mplayer
虽然菜单是英文的,但是好歹能 正常显示中文文件名了
只是依然困惑:我的configure参数都是从网上复制下来的
在FC5和SuSE 10.1上编译都没问题
为什么在Debian和Ubuntu上就有问题呢?

BTW:apt后,“影音”菜单里面没有“mplayer”这一项
请问如何添加?
谢谢了~~~

P.S. 我的congfigure参数:
./configure --enable-gui --enable-largefiles --enable-menu --prefix=/usr --with-codecsdir=/usr/lib/codecs/ --confdir=/etc/mplayer --cc=gcc-3.4 --language=zh_CN


_________________
上善若水


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-08 20:59 

注册: 2006-10-05 8:16
帖子: 71
地址: 福建 厦门
送出感谢: 0 次
接收感谢: 0 次
菜单的问题解决了
图形界面下编辑菜单就行了
中文的问题还请诸位大虾不吝赐教啊~~~


_________________
上善若水


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译