电视卡疑问:saa7130系列的(比如天敏电视大师2)tvtime有图像没有声音到底要怎么解决?

Totem,mplayer,sopcast,realplayer,bmp
回复
XMAN
帖子: 57
注册时间: 2006-10-21 4:30
送出感谢: 0
接收感谢: 0

电视卡疑问:saa7130系列的(比如天敏电视大师2)tvtime有图像没有声音到底要怎么解决?

#1

帖子 XMAN » 2006-10-25 2:20

我的电视卡是天敏电视大师2,用的tvtime,有图像但没声音
在坛子里和google里面搜索了好久也没有找到一个切实可行的方法
但还是看到了一点点线索
比如
http://www.linux-ren.org/modules/newbb/ ... opic_id=88

----------------------------------------------------------------------------------------------------------------
2.6的内核上对电视卡的支持并不是很好,如果是bttv系列的电视卡,大部分是OK的,如果是saa7130系列的,可就没有那末幸运了,很多是有声音没有图像或者有图像没有声音,我曾仔细看过内核相关的文档和代码,找到了一些原因,由于时间关系,没有深入的再研究下去,对SAA713x 支持不好的原因在于modprobe的时候,系统不能自动对应电视卡的card 和tuner号,而导致的声音和图像的不能同步。经过一段时间的研究,我找出了一点规律,把tvtime重新打包,做了一些改进,从而方便用户使用电视卡,如果装上这个包,不需要其他的一些设置,就可以直接扫描频道,然后就可以收看电视了(仅仅支持赛维7130系列!!!)
------------------------------------------------------------------------------------------------------------------
但这个作者没有放出相关下载,也没有其它说明。。。

大家有用这个系列电视卡的完美解决声音和图象问题的吗?
请多多指教!
谢谢!
k_f
帖子: 93
注册时间: 2006-09-28 14:17
送出感谢: 0
接收感谢: 0

#2

帖子 k_f » 2006-10-25 2:51

viewtopic.php?t=11968

我照这个做的,搞定了
XMAN
帖子: 57
注册时间: 2006-10-21 4:30
送出感谢: 0
接收感谢: 0

#3

帖子 XMAN » 2006-10-25 3:13

make -C /home/jameszhou/v4l-dvb/v4l
make[1]: Entering directory `/home/jameszhou/v4l-dvb/v4l'
scripts/make_makefile.pl /lib/modules/2.6.15-26-686/build
File not found: /lib/modules/2.6.15-26-686/build/include/linux/autoconf.h at ./scripts/make_kconfig.pl line 29.
make[1]: *** 没有规则可以创建“config-compat.h”需要的目标“.myconfig”。 停止。
make[1]: Leaving directory `/home/jameszhou/v4l-dvb/v4l'
make: *** [all] 错误 2

我执行make后出现上面的提示,这说明什么问题?应该怎么办?

已经解决了,原因只要安装一下相应内核的header就可以编译了,谢谢楼主,现在看电视也有声音了。真是太爽了。
我也是出现这个问题啊,他说安装一下相应内核的header就可以,要怎么安装相应内核的heaer啊?
k_f
帖子: 93
注册时间: 2006-09-28 14:17
送出感谢: 0
接收感谢: 0

#4

帖子 k_f » 2006-10-25 15:35

你看缺少的是哪个库,到软件包管理器里面找到安装上就行了,注意要装带“-dev"的才是带header文件的
XMAN
帖子: 57
注册时间: 2006-10-21 4:30
送出感谢: 0
接收感谢: 0

#5

帖子 XMAN » 2006-10-25 22:20

Hi k_f
非常感谢你的帮助!
我已经下载了缺少的header文件,make成功,make install也已成功
并且重启了机器
但是,让人失望的是,tvtime依然没有声音。。。。
我把里面的InputXXX选项全部排列组合了一遍,依然不可以
我听MP3时声音却是可以的。。。

以下是我的设备信息

代码: 全选

dmesg

[17179591.484000] saa7130[0]: found at 0000:00:0c.0, rev: 1, irq: 193, latency: 32, mmio: 0xeb001000
[17179591.484000] saa7130[0]: subsystem: 1131:2001, board: 10MOONS PCI TV CAPTURE CARD [card=21,autodetected]
[17179591.484000] saa7130[0]: board init: gpio is 131ff
[17179591.620000] saa7130[0]: i2c eeprom 00: 31 11 01 20 08 20 1c 55 43 43 a9 1c 55 43 43 a9
[17179591.620000] saa7130[0]: i2c eeprom 10: ff ff 00 00 31 30 4d 4f 4f 4e 53 37 31 33 30 20
[17179591.620000] saa7130[0]: i2c eeprom 20: 54 04 48 53 ff ff ff ff ff ff ff ff ff ff ff ff
[17179591.620000] saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[17179591.620000] saa7130[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[17179591.620000] saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[17179591.620000] saa7130[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[17179591.620000] saa7130[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[17179591.640000] tuner 1-0060: All bytes are equal. It is not a TEA5767
[17179591.640000] tuner 1-0060: chip found @ 0xc0 (saa7130[0])
[17179591.640000] tuner 1-0060: type set to 37 (LG PAL (newer TAPC series))
[17179591.648000] tuner 1-0061: chip found @ 0xc2 (saa7130[0])
[17179591.648000] saa7130[0]: registered device video0 [v4l2]
[17179591.648000] saa7130[0]: registered device vbi0
[17179591.776000] input: PC Speaker as /class/input/input1
[17179591.792000] saa7134 ALSA driver for DMA sound loaded
[17179591.792000] saa7130[0]/alsa: saa7130[0] at 0xeb001000 irq 193 registered as card -1

代码: 全选

xman@xman-ubuntu:~$ dmesg | grep tuner
[17179591.640000] tuner 1-0060: All bytes are equal. It is not a TEA5767
[17179591.640000] tuner 1-0060: chip found @ 0xc0 (saa7130[0])
[17179591.640000] tuner 1-0060: type set to 37 (LG PAL (newer TAPC series))
[17179591.648000] tuner 1-0061: chip found @ 0xc2 (saa7130[0])
你可以帮忙看一下我的到底是什么问题吗?
十二万分感激!
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#6

帖子 catinsnow » 2006-10-25 22:37

[17179591.792000] saa7134 ALSA driver for DMA sound loaded
如果这个loaded的话,tvtime就会选这个设备放音,但电视大师2用的是7130芯片,是不支持DMA sound的,所以就没有声音。
方案一个是在不让这个模块加载,在/etc/modprobe.d/alsa-base这里里注释掉这里:

代码: 全选

install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }
就是前面加个"#"号:

代码: 全选

#install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }
然后重启.
另一个是更改声音设备。你在系统的”声音“管理程序里选一下默认声卡试试。
上次由 catinsnow 在 2006-10-26 2:09,总共编辑 1 次。
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2006-10-25 23:15

catinsnow像硬件工程师哦。那9100的一折卖给我吧。
● 鸣学
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#8

帖子 catinsnow » 2006-10-26 1:37

9100卖掉几个月了哦~
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
XMAN
帖子: 57
注册时间: 2006-10-21 4:30
送出感谢: 0
接收感谢: 0

#9

帖子 XMAN » 2006-10-26 9:58

赫赫,我是搂主
不管怎么样,先谢谢catinsnow同志的热心帮助
我晚上回去弄弄
billy19851
帖子: 46
注册时间: 2006-09-30 21:21
送出感谢: 0
接收感谢: 0

#10

帖子 billy19851 » 2006-10-28 10:06

我用的是天敏电视精灵3,芯片是cx23882的
好像没有驱动,我想找它的通用驱动,但是没找到,不知道哪儿有?
还有曾进看到有人说3rd party,这个3rd party是什么
k_f
帖子: 93
注册时间: 2006-09-28 14:17
送出感谢: 0
接收感谢: 0

#11

帖子 k_f » 2006-10-28 12:19

3rd party=第三方,指既不是系统商也不是硬件商出的驱动
james743
帖子: 117
注册时间: 2005-05-03 9:51
送出感谢: 0
接收感谢: 0

#12

帖子 james743 » 2006-10-28 15:30

你可以到音量控制程序(双击那个喇叭)里打开"linein"或"抓取"这两个选项试试
ghost0
帖子: 364
注册时间: 2006-08-11 0:28
送出感谢: 0
接收感谢: 0

#13

帖子 ghost0 » 2006-10-28 16:07

我也是saa7130,tvtime正常

可能线路输入禁音了或者tvtime的音频标准设置不对吧
XMAN
帖子: 57
注册时间: 2006-10-21 4:30
送出感谢: 0
接收感谢: 0

#14

帖子 XMAN » 2006-10-29 18:01

大家好,我是楼主
我的问题终于解决了,我按照catinsnow的贴子修改驱动后还是不行,郁闷了好几天
但是,在刚才看到james743说的
你可以到音量控制程序(双击那个喇叭)里打开"linein"或"抓取"这两个选项试试
之后,问题解决了,哈哈哈

谢谢大家!
我以后准备把工作平台全部移植到Ubuntu了!!!
你们真都是好人,我好感动!!
XMAN
帖子: 57
注册时间: 2006-10-21 4:30
送出感谢: 0
接收感谢: 0

#15

帖子 XMAN » 2006-12-20 1:15

回复

回到 “影音多媒体”