当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-20 0:47 

注册: 2010-10-18 17:42
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
请问何解?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-20 9:18 
头像

注册: 2005-10-14 15:56
帖子: 1845
送出感谢: 0 次
接收感谢: 7
窃以为 osd-lyrics 这样的通用歌词外挂更好,换别的播放器也不必担心歌词问题。


_________________
yunio:又一个支持linux的云存储:链接 (非邀请链接)。
BCM4313驱动正常无法联网的解决:这里
plank:轻巧漂亮的dock 介绍在这里


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-20 16:12 

注册: 2010-10-18 17:42
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
这不是问题所在啊。。。我问的是在10.10中为啥软件包gnome-osd无法安装

代码:
darktemplar@Protoss:~$ sudo apt-get install gnome-osd
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
 gnome-osd : 依赖: python-pyorbit-omg 但是它将不会被安装
 osdlyrics : 依赖: libappindicator0 (>= 0.0.19) 但无法安装它
             依赖: libmpd1 但无法安装它
             依赖: libxmmsclient6 (>= 0.7DrNo) 但无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-20 16:33 
头像

注册: 2010-04-22 18:46
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
我的没问题
自己去down下这些包好了~然后拷到/var/apt/archives/


_________________
there‘s no way back


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-20 17:02 

注册: 2010-10-18 17:42
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
/var/apt/archives/ ? 没这个目录啊


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-27 14:13 

注册: 2010-10-24 11:50
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
libappindicator0 (>= 0.0.19)
像这些依赖条件 可以用10.04的源解决的,

方法: 在你的软件源中添加源:

sudo vim /etc/apt/source.list

添加:deb http://cz.archive.ubuntu.com/ubuntu lucid main

保存退出
sudo apt-get update

sudo apt-get install gnome-osd
就可以安装了。

我已经成功了!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-27 14:51 
头像

注册: 2005-10-14 15:56
帖子: 1845
送出感谢: 0 次
接收感谢: 7
你确定你的源没问题么,确实是10.10的源?
你的osdlyrics 是for 10.10的包么?


_________________
yunio:又一个支持linux的云存储:链接 (非邀请链接)。
BCM4313驱动正常无法联网的解决:这里
plank:轻巧漂亮的dock 介绍在这里


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-28 14:37 

注册: 2010-10-24 11:50
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
osdlyrics 暂时还没的10.10的包,

10.04的包是可以解决这个问题的,只是在安装的时候会提示

依赖: libappindicator0 (>= 0.0.19)

而这个依赖是可以用10.04的源解决的,这个我已经亲身试验了。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2010-10-28 18:01 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
歌词显示,何必局限于osd阿。
不是还有term和conky显示的嘛。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu 10.10 gnome-osd无法安装 这样就不能装鲁班歌词啊
帖子发表于 : 2011-02-05 14:25 

注册: 2011-02-02 20:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
照8楼兄弟的方法确实可以解决问题+1

也可重装10.04安上OSD LYRICS之后再升到10.10

在下比较推荐前者


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译