当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ppstream在64位ubuntu10.10上的安装问题。(已解决)(申请置顶)
帖子发表于 : 2010-11-06 10:12 

注册: 2006-09-21 15:26
帖子: 29
送出感谢: 1
接收感谢: 0 次
1、强制安装dpkg -i --force-all安装pps后运行不了,提示如下:
PPStream: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory
2、意思是找不到 libQtWebKit.so.4库文件。
3、查找pps在哪些目录下寻找库文件,LD_DEBUG=libs /opt/pps/bin/PPStream -v ,输出如下:
4508: find library=libemscore.so.0 [0]; searching
4508: search cache=/etc/ld.so.cache
4508: trying file=/usr/lib/libemscore.so.0
4508:
4508: find library=libz.so.1 [0]; searching
4508: search cache=/etc/ld.so.cache
4508: trying file=/usr/lib32/libz.so.1
4508:
4508: find library=libQtWebKit.so.4 [0]; searching
4508: search cache=/etc/ld.so.cache
4508: search path=/lib32/tls/i686/sse2/cmov:/lib32/tls/i686/sse2:/lib32/tls/i686/cmov:/lib32/tls/i686:/lib32/tls/sse2/cmov:/lib32/tls/sse2:/lib32/tls/cmov:/lib32/tls:/lib32/i686/sse2/cmov:/lib32/i686/sse2:/lib32/i686/cmov:/lib32/i686:/lib32/sse2/cmov:/lib32/sse2:/lib32/cmov:/lib32:/usr/lib32/tls/i686/sse2/cmov:/usr/lib32/tls/i686/sse2:/usr/lib32/tls/i686/cmov:/usr/lib32/tls/i686:/usr/lib32/tls/sse2/cmov:/usr/lib32/tls/sse2:/usr/lib32/tls/cmov:/usr/lib32/tls:/usr/lib32/i686/sse2/cmov:/usr/lib32/i686/sse2:/usr/lib32/i686/cmov:/usr/lib32/i686:/usr/lib32/sse2/cmov:/usr/lib32/sse2:/usr/lib32/cmov:/usr/lib32:/lib/i486-linux-gnu/tls/i686/sse2/cmov:/lib/i486-linux-gnu/tls/i686/sse2:/lib/i486-linux-gnu/tls/i686/cmov:/lib/i486-linux-gnu/tls/i686:/lib/i486-linux-gnu/tls/sse2/cmov:/lib/i486-linux-gnu/tls/sse2:/lib/i486-linux-gnu/tls/cmov:/lib/i486-linux-gnu/tls:/lib/i486-linux-gnu/i686/sse2/cmov:/lib/i486-linux-gnu/i686/sse2:/lib/i486-linux-gnu/i686/cmov:/lib/i486-linux-gnu/i686:/lib/i486-linux-gnu/sse2/cmov:/lib/i486-linux-gnu/sse2:/lib/i486-linux-gnu/cmov:/lib/i486-linux-gnu:/usr/lib/i486-linux-gnu/tls/i686/sse2/cmov:/usr/lib/i486-linux-gnu/tls/i686/sse2:/usr/lib/i486-linux-gnu/tls/i686/cmov:/usr/lib/i486-linux-gnu/tls/i686:/usr/lib/i486-linux-gnu/tls/sse2/cmov:/usr/lib/i486-linux-gnu/tls/sse2:/usr/lib/i486-linux-gnu/tls/cmov:/usr/lib/i486-linux-gnu/tls:/usr/lib/i486-linux-gnu/i686/sse2/cmov:/usr/lib/i486-linux-gnu/i686/sse2:/usr/lib/i486-linux-gnu/i686/cmov:/usr/lib/i486-linux-gnu/i686:/usr/lib/i486-linux-gnu/sse2/cmov:/usr/lib/i486-linux-gnu/sse2:/usr/lib/i486-linux-gnu/cmov:/usr/lib/i486-linux-gnu (system search path)
4508: trying file=/lib32/tls/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib32/tls/i686/sse2/libQtWebKit.so.4
4508: trying file=/lib32/tls/i686/cmov/libQtWebKit.so.4
4508: trying file=/lib32/tls/i686/libQtWebKit.so.4
4508: trying file=/lib32/tls/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib32/tls/sse2/libQtWebKit.so.4
4508: trying file=/lib32/tls/cmov/libQtWebKit.so.4
4508: trying file=/lib32/tls/libQtWebKit.so.4
4508: trying file=/lib32/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib32/i686/sse2/libQtWebKit.so.4
4508: trying file=/lib32/i686/cmov/libQtWebKit.so.4
4508: trying file=/lib32/i686/libQtWebKit.so.4
4508: trying file=/lib32/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib32/sse2/libQtWebKit.so.4
4508: trying file=/lib32/cmov/libQtWebKit.so.4
4508: trying file=/lib32/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/i686/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/i686/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/i686/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/tls/libQtWebKit.so.4
4508: trying file=/usr/lib32/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/i686/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib32/i686/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/i686/libQtWebKit.so.4
4508: trying file=/usr/lib32/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib32/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib32/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/i686/sse2/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/i686/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/i686/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/sse2/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/tls/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/i686/sse2/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/i686/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/i686/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/sse2/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/sse2/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/cmov/libQtWebKit.so.4
4508: trying file=/lib/i486-linux-gnu/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/i686/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/i686/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/i686/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/tls/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/i686/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/i686/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/i686/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/i686/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/sse2/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/sse2/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/cmov/libQtWebKit.so.4
4508: trying file=/usr/lib/i486-linux-gnu/libQtWebKit.so.4
4、用ldd /opt/pps/bin/PPStream | grep -i "not found"看一下少哪几个文件
libQtWebKit.so.4 => not found
5、从http://mirrors.sohu.com/ubuntu/pool/main/q/qtwebkit-source/下载libqtwebkit4_2.0.0-0ubuntu1_i386.deb
解压开,sudo cp libqtwebkit4_2.0.0-0ubuntu1_i386/usr/lib/libQtWebKit.so.4.7.0 /lib32/libQtWebKit.so.4
6、用ldd /opt/pps/bin/PPStream | grep -i "not found"
libphonon.so.4 => not found
7、再次从http://mirrors.sohu.com/ubuntu/pool/main/p/phonon/下载libphonon4_4.3.1-0ubuntu3_i386解压开,
sudo cp libphonon4_4.3.1-0ubuntu3_i386/usr/lib/libphonon.so.4.3.0 /lib32/libphonon.so.4
8、运行/opt/pps/bin/PPStream成功
顺便说一下,在fedora 14 x86_64上已安装成功。


最后由 Cainiao74 编辑于 2010-11-07 22:50,总共编辑了 4 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: pps在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-06 10:30 
头像

注册: 2007-11-12 14:27
帖子: 629
地址: 地球的角落
送出感谢: 0 次
接收感谢: 2
干嘛这么着急。 估计明后天就有64位的deb了出来。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-07 1:20 

注册: 2008-06-17 17:07
帖子: 193
地址: http://www.jiechic.com
送出感谢: 0 次
接收感谢: 1
呵呵,我看到水木清华网站的linuxer已经相出办法了,我现在还没64位,暂时没能测试,有空再弄弄。


_________________
欢迎光临我的博客
JieChic ‘ s Blog
I Want To Use Linux
http://www.jiechic.com


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-07 11:40 
头像

注册: 2007-11-12 14:27
帖子: 629
地址: 地球的角落
送出感谢: 0 次
接收感谢: 2
chamqion 写道:
呵呵,我看到水木清华网站的linuxer已经相出办法了,我现在还没64位,暂时没能测试,有空再弄弄。


有吗 我也在水木混, 没有看到


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-07 14:46 

注册: 2006-12-14 0:21
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
我已经安装,amd64的可以使用。但要先安装ia32-libs和getlibs后,再安装deb。网上已经有人给出解决方案。google一下。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-07 16:27 

注册: 2008-03-28 23:06
帖子: 131
送出感谢: 0 次
接收感谢: 0 次
运行 ldd /usr/bin/PPStream可以察看动态库的依赖情况。
对于列出的缺少的库,可以下载相应的32位deb包,用dpkg-deb -x命令解开,把对应的so文件考到/usr/lib32下即可。
一般来说,缺少的是32位libfuse库和32位libqtwebkit库。Google一下就能找到下载链接。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-07 19:20 

注册: 2006-09-21 15:26
帖子: 29
送出感谢: 1
接收感谢: 0 次
谢谢6楼的高手


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。求教高手
帖子发表于 : 2010-11-08 2:59 
头像

注册: 2007-11-12 14:27
帖子: 629
地址: 地球的角落
送出感谢: 0 次
接收感谢: 2
portis21 写道:
运行 ldd /usr/bin/PPStream可以察看动态库的依赖情况。
对于列出的缺少的库,可以下载相应的32位deb包,用dpkg-deb -x命令解开,把对应的so文件考到/usr/lib32下即可。
一般来说,缺少的是32位libfuse库和32位libqtwebkit库。Google一下就能找到下载链接。



多谢 portis21, 我这里也可以了。 运行流畅,界面简洁。 感觉比win下更好用。


附件:
Screenshot-正在播放阿凡达-高清英.png
Screenshot-正在播放阿凡达-高清英.png [ 496.14 KiB | 被浏览 5114 次 ]

页首
 用户资料  
 
9 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。(已解决)(申请置顶)
帖子发表于 : 2010-12-01 1:07 

注册: 2010-12-01 1:04
帖子: 2
送出感谢: 0 次
接收感谢: 1
64位Ubuntu安装PPStream
(引用自http://lveyo.info/install-pps-on-ubuntu-amd64.html

前不久PPStream发布了支持Ubuntu的版本,再也不用在Ubuntu下用Wine跑PPStream了。但是官网发布的是一个32位版本的DEB安装包,64位版本在launchpad.net上可以下载到。
安装步骤:

1. 按照官网安装说明,安装依赖的软件
view sourceprint?
1 sudo apt-get install libqt4-core libqt4-dbus libqt4-gui libqt4-network libqt4-webkit libqt4-xml libfuse2 mplayer
2. 下载并安装lib32qtwebkit4,下载地址:https://launchpad.net/~cnav/+archive/ppa/+build/2040892
view sourceprint?
1 dpkg -i lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
3. 下载并安装ppstream,下载地址:https://launchpad.net/~cnav/+archive/ppa/+build/2041643
view sourceprint?
1 dpkg -i ppstream_1.0.0-3_amd64.deb

安装之后就可以在Applications->Inernet->PPStream启动程序了。
顺利启动PPStream之后,有可能会有有影无声的现象,在“工具”->“选项”->“选择音频设备”中,将当前音频从oss改为alsa,重启PPStream就可以听到声音了。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。(已解决)(申请置顶)
帖子发表于 : 2010-12-26 9:10 

注册: 2010-12-26 9:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
Ubuntu 10.04 LTS amd64

在安装第二个文件lib32qtwebkit4时报错:
dpkg: error processing lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb (--install):
trying to overwrite '/usr/lib32/libQtWebKit.so.4', which is also in package ia32-libs 0:2.7ubuntu26
Errors were encountered while processing:
lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb

如跳过这步直接安装ppstream-1.0.0.3又会报错:
ppstream depends on ia32-libs (>= 20080808); however:
Version of ia32-libs on system is 2.7ubuntu26.
ppstream depends on lib32qtwebkit4; however:
Package lib32qtwebkit4 is not installed.

是什么问题呢?是ia32-libs的版本号变了吗?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。(已解决)(申请置顶)
帖子发表于 : 2011-05-03 18:29 

注册: 2011-04-30 1:52
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
楼上地说的神对,我找了两天网络google baidu啦 全部都是这一段文字! 可是就是安装不了,并没有任何新的信息出现。对于普通用户来说,就完全没有办法了吗? 对了那些错误的陈旧的信息 能不能 不让我们搜索到呢!? 完全是废物,干嘛还满网络乱飞!!?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ppstream在64位ubuntu10.10上的安装问题。(已解决)(申请置顶)
帖子发表于 : 2011-05-04 0:26 

注册: 2009-12-10 22:18
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我下载安装包安装后,视频正常,但是没有声音,请哪位大侠帮助解决一下。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译