求助!mplayer 异常退出 退出代码1

Totem,mplayer,sopcast,realplayer,bmp
回复
111111
帖子: 6
注册时间: 2009-05-16 16:24
送出感谢: 0
接收感谢: 0

求助!mplayer 异常退出 退出代码1

#1

帖子 111111 » 2010-11-07 3:20

在上周末更新ubuntu之后就出现这个问题,仅在播放AVI文件的时候出现(貌似)而且也不是全部AVI都出错 有很一小部分AVI播放没问题。
重新编译安装了最新版本mplayer和smplayer都没有用通过smplayer播放就会导致异常退出,但是,通过命令行调用mplayer播放却没有问题
通过反复试验发现:正常使用smplayer播放的时候 进程里是有2个mplayer进程的,而异常退出的时候只有1个mplayer进程,不知道这里面是不是有什么关联?
附上日志,没能看懂:

/usr/local/bin/mplayer -noquiet -nofs -nomouseinput -vc coreserve, -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 65012062 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/hp520/.config/smplayer/styles.ass -fontconfig -font AR PL UKai CN -subfont-autoscale 0 -subfont-osd-scale 10 -subfont-text-scale 10 -subcp enca:zh -vid 0 -aid 1 -subpos 100 -volume 96 -cache 20000 -osdlevel 0 -idx -vf-add screenshot -slices -channels 2 -af scaletempo -softvol -softvol-max 110 /home/hp520/movies/2012.avi

MPlayer SVN-r32577-4.4.5 (C) 2000-2010 MPlayer Team
Terminal type `unknown' is not defined.

Playing /home/hp520/movies/2012.avi

Cache fill: 0.00% (0 bytes)

AVI file format detected.
ID_VIDEO_ID=0
[aviheader] Video stream found, -vid 0
ID_AUDIO_ID=1
[aviheader] Audio stream found, -aid 1


MPlayer interrupted by signal 8 in module: demux_open
ID_SIGNAL=8
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
回复

回到 “影音多媒体”