敢不敢告诉我为什么我的10.10安装不了PPS(已解决)

Totem,mplayer,sopcast,realplayer,bmp
头像
枫叶饭团
论坛版主
帖子: 14684
注册时间: 2010-06-16 1:05
系统: Mac OS X
来自: Tencent
送出感谢: 1 次
接收感谢: 132 次
联系:

敢不敢告诉我为什么我的10.10安装不了PPS(已解决)

#1

帖子 枫叶饭团 » 2010-11-07 18:10

昨天才发现PPS有LINUX版了。
高高兴兴下下来就悲剧了。

代码: 全选

maple@maple-MS-7597:~/下载$ sudo dpkg -i ppstream_1.0.0-1_i386.deb
选中了曾被取消选择的软件包 ppstream。
(正在读取数据库 ... 系统当前共安装有 131966 个文件和目录。)
正在解压缩 ppstream (从 ppstream_1.0.0-1_i386.deb) ...
dpkg:依赖关系问题使得 ppstream 的配置工作不能继续:
 ppstream 依赖于 libqt4-core (>= 4.4.0);然而:
  未安装软件包“libqt4-core”。
 ppstream 依赖于 libqt4-gui (>= 4.4.0);然而:
  未安装软件包“libqt4-gui”。
dpkg:处理 ppstream (--install)时出错:
 依赖关系问题 - 仍未被配置
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 python-gmenu 的触发器...
Rebuilding /usr/share/applications/desktop.zh_CN.utf8.cache...
正在处理用于 python-support 的触发器...
在处理时有错误发生:
 ppstream
关于依赖libqt4-core,于是我安装libqt4-core出现了错误要依赖libqt4-test。于是我再安装libqt4-text,结果它居然依赖libqt4-core :em06 。这不是一个死循环吗?有人遇见过没?
是不是源的问题?我已经把163源,换成其它源。依然~

真的是libqtcore4和libqt4-core冲突了。。。。。因为我安装的smplayer依赖的是libqt4core,所以libqt4-core装不上了~切 :em06
上次由 枫叶饭团 在 2010-11-11 10:29,总共编辑 3 次。
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#2

帖子 jimmin » 2010-11-07 18:13

代码: 全选

sudo apt-get install -f
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#3

帖子 jimmin » 2010-11-07 18:14

代码: 全选

sudo apt-get install libqt4-test libqt4-core
同时安装也行,你一个个安装当然不行! :em06
头像
枫叶饭团
论坛版主
帖子: 14684
注册时间: 2010-06-16 1:05
系统: Mac OS X
来自: Tencent
送出感谢: 1 次
接收感谢: 132 次
联系:

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#4

帖子 枫叶饭团 » 2010-11-07 18:16

代码: 全选

maple@maple-MS-7597:~/下载$ sudo apt-get install libqt4-test libqt4-core
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libqt4-core : 依赖: libqtcore4 (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-network (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-script (= 4:4.7.0-0ubuntu4) 但是它将不会被安装
               依赖: libqt4-xml (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
               依赖: libqt4-dbus (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
 libqt4-test : 依赖: libqtcore4 (= 4:4.7.0-0ubuntu4) 但是 4:4.7.0-0ubuntu4.1 正要被安装
E: 破损的软件包
三个源的包全坏了???已经是第三个源了!
头像
枫叶饭团
论坛版主
帖子: 14684
注册时间: 2010-06-16 1:05
系统: Mac OS X
来自: Tencent
送出感谢: 1 次
接收感谢: 132 次
联系:

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#5

帖子 枫叶饭团 » 2010-11-07 18:19

自己顶下,去考试了。回来再看看有办法没。看来我注定和网络电视无缘~ :em03
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#6

帖子 jimmin » 2010-11-07 18:24

sudo apt-get install -f 你没试吗? :em06
zixue.liu
帖子: 1
注册时间: 2010-11-07 22:32
送出感谢: 0
接收感谢: 0

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#7

帖子 zixue.liu » 2010-11-07 22:35

把VirtualBOX卸载了,就可以了,呵呵。libqt4-core和libqt4core有冲突。
头像
枫叶饭团
论坛版主
帖子: 14684
注册时间: 2010-06-16 1:05
系统: Mac OS X
来自: Tencent
送出感谢: 1 次
接收感谢: 132 次
联系:

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#8

帖子 枫叶饭团 » 2010-11-08 8:07

ls,apt-get install -f用了之后就是一个卸载pps,没意义。
我没都没装VB虚拟机.....
头像
南宫惊梦
帖子: 28
注册时间: 2007-06-12 16:36
送出感谢: 0
接收感谢: 0

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#9

帖子 南宫惊梦 » 2010-11-08 10:04

我按照官方说明一次成功。
1 下载deb http://download.ppstream.com/ppstream_1.0.0-1_i386.deb 右键点击转移主文件夹
2 安装mplayer
3 安装 pps
4 没声音 工具/选择/选择音频设备---alsa

===================================================

官方说明:

PPS Linux PC版本使用说明

来自:PPS.TV 发表时间:2010-11-04

软件版本:0.1.1678

* 安装需求:Ubuntu 8.04+, 只能用于x86 Linux个人电脑.
* 软件大小:1.5MB(deb包)

安装说明:

辅助软件:
安装PPS Linux版本前需要先安装以下辅助软件:
* QT库, 4.4.0及以上版本
* libFuse库, 2.7.2及以上版本
* Mplayer, 1.0rc2及以上版本
* MPlayer视频解码器: MPlayer Essential Codec Pack(http://www.mplayerhq.hu/MPlayer/release ... 07.tar.bz2)

推荐使用apt-get方式安装: sudo apt-get install libqt4-core libqt4-dbus libqt4-gui libqt4-network libqt4-webkit libqt4-xml libfuse2 mplayer

安装PPS:
sudo dpkg -i ppstream_1.0.0-1_i386.deb
头像
sjzzym
帖子: 142
注册时间: 2008-04-14 12:34
送出感谢: 0
接收感谢: 1 次

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#10

帖子 sjzzym » 2010-11-08 13:01

两种可能,某些软件包破损,或者是依赖的不到满足(一般是没有依赖的软件包,或者无法自动卸载旧版本软件包)。

首先检查一下源(包括/etc/apt/sources.list 和/etc/apt/sources.list.d中所有源),确保源版本一致。(如果可能,暂时禁用第三方源)
然后 sudo dpkg --configure -a 看是否有破损的软件包,修复或卸载它(如果不影响系统)。
接着,更新源 sudo apt-get update .再用 sudo apt-get install -f 连线修复。

试试吧 :em11
欢迎加入Ubuntu Gtalk群,使用Gtalk群聊,添加scu_ubuntu@im.partych.at为好友即可加入,默认使用/help查看帮助
Gmail中使用/help查看帮助,Pidgin和Empdthy查看帮助或运行命令格式为:/say空格命令,例:/say /help
头像
peakgg
帖子: 1122
注册时间: 2006-10-10 9:40
送出感谢: 1 次
接收感谢: 0
联系:

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#11

帖子 peakgg » 2010-11-08 18:43

应该是pps的版本依赖做的不好,导致安装时需要降级libqt4,可以去他们官网上提意见。否则你降级安装可能会出更多依赖问题。
_maple
帖子: 364
注册时间: 2010-09-26 10:59
送出感谢: 0
接收感谢: 1 次

Re: 敢不敢告诉我为什么我的10.10安装不了PPS

#12

帖子 _maple » 2010-11-08 19:26

PPS Linux PC版本使用说明

软件版本:0.1.1678
* 安装需求:Ubuntu 8.04+, 只能用于x86 Linux个人电脑.
* 软件大小:1.5MB(deb包)

安装说明:

辅助软件:
安装PPS Linux版本前需要先安装以下辅助软件:
* QT库, 4.4.0及以上版本
* libFuse库, 2.7.2及以上版本
* Mplayer, 1.0rc2及以上版本
* MPlayer视频解码器: MPlayer Essential Codec Pack(http://www.mplayerhq.hu/MPlayer/release ... 07.tar.bz2)

推荐使用apt-get方式安装: sudo apt-get install libqt4-core libqt4-dbus libqt4-gui libqt4-network libqt4-webkit libqt4-xml libfuse2 mplayer

安装PPS:
sudo dpkg -i ppstream_1.0.0-1_i386.deb
头像
cwymakyyl
帖子: 23
注册时间: 2010-02-10 23:30
送出感谢: 0
接收感谢: 0

Re: 敢不敢告诉我为什么我的10.10安装不了PPS(已解决)

#13

帖子 cwymakyyl » 2010-12-17 21:22

我是这么弄好的,先在ubuntu软件中心里,输入PPS ,然后出现一个Gmlive,卸载掉这个,然后再照官方的那个安装命令安装就好了
nearest
帖子: 1
注册时间: 2010-12-20 10:34
送出感谢: 0
接收感谢: 0

Re: 敢不敢告诉我为什么我的10.10安装不了PPS(已解决)

#14

帖子 nearest » 2010-12-20 10:35

我用sudo apt-get install -f 就搞定了。
头像
netcger
帖子: 29
注册时间: 2008-07-12 17:13
送出感谢: 0
接收感谢: 0

Re: 敢不敢告诉我为什么我的10.10安装不了PPS(已解决)

#15

帖子 netcger » 2011-02-01 21:18

留名,一会试试。
什么什么!
回复

回到 “影音多媒体”