当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 使用mplayer播放播放avi时遇到的这个问题,如图
帖子发表于 : 2006-11-05 20:52 
头像

注册: 2006-05-02 21:24
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
如图:播放时一点问题都没有,只是每次开始启动mplayer播放时都会提示没有mp3解码器,实际上gstreamer各个解码器都装着的,而且Rhythmbox播放mp3也是没问题的,Totem也没问题,只是mplayer出现这个情况。


附件:
Screenshot.jpg
Screenshot.jpg [ 45.65 KiB | 被浏览 1130 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-05 21:29 
头像

注册: 2005-06-19 23:33
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
安装w32codecs,mplayer不用gstreamer


_________________
Ubuntu Karmic
acer 5595 : core2 duo T7200;2*1024M DDR2-667 ;intel 965pm;ati mobility readon X1600

贫贱不能移,富贵不能淫,威武不能屈


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-06 12:48 
头像

注册: 2006-05-02 21:24
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
w32codecs已经正确安装,如图。


附件:
Screenshot.jpg
Screenshot.jpg [ 61.92 KiB | 被浏览 1095 次 ]

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-07 16:38 

注册: 2006-06-02 1:03
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
同问!
确实安装了gstreamer!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-08 19:48 

注册: 2005-08-16 14:59
帖子: 283
送出感谢: 0 次
接收感谢: 0 次
我的也是这个问题,奇怪了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-08 20:36 

注册: 2005-08-16 14:59
帖子: 283
送出感谢: 0 次
接收感谢: 0 次
偶的Mplayer,放RMVB时有时会乱色,放大屏幕时根本就不会放大图像。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-08 21:55 

注册: 2006-09-28 18:39
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
正常,编译时候的问题,这是mplayer内置的mp3lib被禁用了,但是可以正常播放的
如果编译的时候不禁用这个,而又没有设置音频解码器的话,默认是噪音
rmvb色彩不正常及不能缩放应该是视频设置问题,可参考置顶的媒体设置或mplayer的manpage^_^


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-08 22:57 
头像

注册: 2006-05-02 21:24
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
xcc360 写道:
正常,编译时候的问题,这是mplayer内置的mp3lib被禁用了,但是可以正常播放的
如果编译的时候不禁用这个,而又没有设置音频解码器的话,默认是噪音
rmvb色彩不正常及不能缩放应该是视频设置问题,可参考置顶的媒体设置或mplayer的manpage^_^


这个一打开文件时跳出窗口的这个问题不能解决么?我在audio里的那些设置都弄过,有的是别的提示,然后就没声音,有的是如上面的图那样,但是声音是正常的.不知道如何启用mplayer内置的mp3lib呢?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-09 0:00 

注册: 2006-09-28 18:39
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
这个是要从源码编译来解决的,但是貌似mplayer内置的mp3lib有问题,播放avi或mp3只会暴音,因此可能在编译mplayer的时候就把内置的mp3lib给禁用了,这样只是多了一个提示,并不影响播放;相反,如果你要取消这个提示,必须从源码进行编译安装,但是启用内置的mp3lib并不能解决任何问题,这个提示没有了,但是默认的设置播放avi和mp3只会暴音

我觉得没必要这么在意一个提示吧?又不是用不了,而且编译的话需要一定的耐性,置顶的媒体设置挺好的,为什么大家不好好看呢?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-09 0:06 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
w32codecs的安装路径可能不对的。你查查。我以前贴过的,修改一个链接路径。就是那个解码器的路径。


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-11-14 0:00 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
不用那么麻烦,在mplayer里面右键-》preferences-》codecs&demuxter-》audio codec family里面选ffmpeg/libavcodec audio decoders就没有这个提示了的。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-11-15 14:40 

注册: 2006-09-18 14:07
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
按楼上的方法,终于把这个问题解决了.
谢谢.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译