当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 多个播放器播放avi文件意外退出,rmvb无法播放
帖子发表于 : 2006-11-14 12:33 

注册: 2006-10-07 22:19
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
一次意外的灾难性事故,不得不重装系统(6.06),改装的都装上、系统升级之后,意外的发现avi文件无法播放,w32codecs之类的插件都装了,用totem播放的时候播放几秒钟totem就退出,换了mplayer、vlc都是同样的情况,在终端运行totem和mplayer播放avi得到如下错误信息
totem的:

代码:
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 61 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


mplayer的

代码:
MPlayer 2:0.99+1.0pre7try2+cvs20060117-0ubuntu8 (C) 2000-2006 MPlayer Team
CPU: Advanced Micro Devices Sempron/Athlon MP/XP Thoroughbred; Duron Applebred (Family: 6, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.


91 audio & 204 video codecs
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing 1.avi.
AVI file format detected.
VIDEO:  [tscc]  1024x768  32bpp  10.000 fps  157.5 kbps (19.2 kbyte/s)
==========================================================================
Opening audio decoder: [msgsm] native GSM/MSGSM audio decoder
AUDIO: 22050 Hz, 1 ch, s16le, 35.8 kbit/10.15% (ratio: 4478->44100)
Selected audio codec: [msgsm] afm: msgsm (MS GSM)
==========================================================================
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffcamtasia] vfm: ffmpeg (TechSmith Camtasia Screen Codec (native))
==========================================================================
Building audio filter chain for 22050Hz/1ch/s16le -> 0Hz/0ch/??...
alsa-init: 1 soundcard found, using: default
alsa: 22050 Hz/1 channels/2 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 22050Hz 1ch s16le (2 bytes per sample)
Building audio filter chain for 22050Hz/1ch/s16le -> 22050Hz/1ch/s16le...
Starting playback...
VDec: vo config request - 1024 x 768 (preferred colorspace: BGRA)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using BGRA as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.

SwScaler: BICUBIC scaler, from BGRA to Planar YV12 using MMX2
VO: [xv] 1024x768 => 1024x768 Planar YV12
alsa-space: xrun of at least 35.361 msecs. resetting stream
X11 error: BadAlloc (insufficient resources for operation)


MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
alsa-uninit: pcm closed


另外rmvb也无法播放,totem提示没有插件,可是插件都装了,后来我干脆装了个realplay,将codes目录下的文件cp到/usr/local/win下,但totem还是提示找不到插件


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-14 18:06 

注册: 2006-10-07 22:19
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
发现有的rmvb能播放,有的不能,不能播放的是音频(无视频),但是avi没解决


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-25 14:47 
头像

注册: 2006-07-10 16:38
帖子: 176
送出感谢: 0 次
接收感谢: 1
我用mplayer播放rmvb时只有音频没有视频.........


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-25 15:50 

注册: 2006-08-15 20:35
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
可能是avi文件的分辨率比较高导致的,我以前也遇到这个问题,记得设置一个播放器的命令行参数可以解决这个问题。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-29 18:44 

注册: 2006-10-07 22:19
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
wenshu 写道:
可能是avi文件的分辨率比较高导致的,我以前也遇到这个问题,记得设置一个播放器的命令行参数可以解决这个问题。

可能是这个原因,我換了块显卡,好了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-12-06 11:59 

注册: 2006-12-01 12:52
帖子: 25
地址: 中国大陆
送出感谢: 0 次
接收感谢: 0 次
我按照wiki上面的方法做的,全可以的,应该没有问题的,你再看看wiki啊!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-06-23 21:45 

注册: 2006-12-09 13:40
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
我在7.04遇到同样问题。。。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-07 9:44 

注册: 2006-10-10 13:01
帖子: 231
送出感谢: 0 次
接收感谢: 0 次
在7.04下播放有的avi格式文件有视频没声音。


_________________
努力不一定成功,但放弃注定要失败!
授人与鱼,不如授人与渔!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译