编译mplayer需要支持openGL,找了好多,都没找到支持OPEN GL的开发包~~

Totem,mplayer,sopcast,realplayer,bmp
回复
sczlin
帖子: 97
注册时间: 2006-04-06 11:23
送出感谢: 0
接收感谢: 0

编译mplayer需要支持openGL,找了好多,都没找到支持OPEN GL的开发包~~

#1

帖子 sczlin » 2006-11-20 14:24

编译mplayer需要支持openGL,找了好多,都没找到支持OPEN GL的开发包~~

最近打开了显卡的OPEN GL 加速,mplayer需要支持open gl 才能输出图像,找了好多的软件包,都没找到支持open gl 的开发包,郁闷,,,,,,,,,,,,,,,谁知道啊~~~~
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-11-20 14:41

上次wine也是需要这个。所以最好别编译。也可以到gentoo网站去找。
● 鸣学
sczlin
帖子: 97
注册时间: 2006-04-06 11:23
送出感谢: 0
接收感谢: 0

#3

帖子 sczlin » 2006-11-20 16:03

eexpress 写了:上次wine也是需要这个。所以最好别编译。也可以到gentoo网站去找。
以前就有OPEN GL支持的,现在不知道是哪个包文件了
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#4

帖子 jarlyyn » 2006-11-20 23:47

我编译wine的时候用的这个



安装libgl
(这个取决于你的发行版本,反正是opengl的lib文件,提供opengl的支持的)

sudo apt-get install libartsc0 libartsc0-dev libgl1-mesa-dev


可以试下
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2006-11-21 9:25

sudo apt-get build-dep mplayer 试试呢?
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
ttand
帖子: 1743
注册时间: 2005-08-22 14:05
来自: 离开北京
送出感谢: 1 次
接收感谢: 3 次

#6

帖子 ttand » 2006-11-23 12:36

大概
显卡驱动有关
nvidia 就需要 那个显卡 开发包
如果安装官方 *.run 就不需要那个包了

或者是 xorg 套件里面的什么包

以上全凭直觉 不要见怪
错过好多好贴,没占到广告位后悔啊
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

Re: 编译mplayer需要支持openGL,找了好多,都没找到支持OPEN GL的开发包~~

#7

帖子 huangjiahua » 2010-01-17 20:16

没啥事就别自己编译了,

大不了加 ppa 或 media 源安装 svn 版 mplayer。

实在要自己编译,
就先执行下 sudo apt-get build-dep mplayer
跃过无数的时间断层,只为了在
回复

回到 “影音多媒体”