9.10 的totem不能运行了。

Totem,mplayer,sopcast,realplayer,bmp
回复
引火虫
帖子: 750
注册时间: 2006-08-28 9:08
来自: 安徽/安庆
送出感谢: 0
接收感谢: 0
联系:

9.10 的totem不能运行了。

#1

帖子 引火虫 » 2011-03-09 11:53

估计和这几天升级有关,
终端中的错误:

代码: 全选

~$ totem
libdc1394 error: Failed to initialize libdc1394

(totem:6740): GLib-GObject-CRITICAL **: g_param_spec_internal: assertion `(name[0] >= 'A' && name[0] <= 'Z') || (name[0] >= 'a' && name[0] <= 'z')' failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstfrei0r.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
重新扫描寄存器 , child terminated by signal 时出错
请运行 “totem --help”查看完整的命令行选项列表。
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 9.10 的totem不能运行了。

#2

帖子 lainme » 2011-03-09 13:50

开一下升级了哪些程序,从搜索的结果看可能是gstreamer0.10-plugins-bad的问题(libdc-1394-22也有问题,但不知道和totem能不能运行有多大关系)

如果升级了gstreamer0.10-plugins-bad,先通过新立得降级下来
引火虫
帖子: 750
注册时间: 2006-08-28 9:08
来自: 安徽/安庆
送出感谢: 0
接收感谢: 0
联系:

Re: 9.10 的totem不能运行了。

#3

帖子 引火虫 » 2011-03-10 10:24

lainme 写了:开一下升级了哪些程序,从搜索的结果看可能是gstreamer0.10-plugins-bad的问题(libdc-1394-22也有问题,但不知道和totem能不能运行有多大关系)

如果升级了gstreamer0.10-plugins-bad,先通过新立得降级下来
降了也不行,总是提示libdc-1394-22错误,
我估计是libdc-1394-22的问题,
因为gstreamer0.10-plugins-bad依赖libdc-1394-22,
而totem又依赖gstreamer0.10-plugins-bad,
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 9.10 的totem不能运行了。

#4

帖子 lainme » 2011-03-11 12:30

不知道降libdc-1394-22行不...

launchpad上有些临时的修复方法: https://bugs.launchpad.net/ubuntu/+sour ... bug/462453

根据上面一个方法,可以试试

代码: 全选

echo "raw1394" | sudo tee -a /etc/modules
echo 'KERNEL=="raw1394", GROUP="disk"' | sudo tee -a /etc/udev/rules.d/50-raw1394.rules
回复

回到 “影音多媒体”