再谈MPLAYER问题

Totem,mplayer,sopcast,realplayer,bmp
回复
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

再谈MPLAYER问题

#1

帖子 linhanwen » 2006-11-24 9:36

在终端里运行Mplayer:


linhanwen@ubuntu:~$ gmplayer
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) (Family: 6, Model: 8, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
编译用了针对 x86 CPU 的扩展指令集: MMX MMX2 3DNow 3DNowEx SSE
Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".
Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.

请问一下,这是怎么回事啊??
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-11-24 10:21

直接运行mplayer
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

#3

帖子 linhanwen » 2006-11-24 12:25

就是不行啊,
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-11-24 12:41

看提示是要你做一个字体链接到~/.mplayer/subfont.ttf,那么你就随便弄一个中文字体咯。
ln -s /字体目录/字体.ttf ~/mplayer/subfont.ttf
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

#5

帖子 linhanwen » 2006-11-24 14:02

字体的目录在哪的,我找不到啊!!
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2006-11-24 14:05

一般在/usr/share/fonts/truetype/自己看吧,也可以自己添加。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

#7

帖子 linhanwen » 2006-11-24 14:21

现在可以启动了,却出现了乱码了,

晕死了,真多问题!!!
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 zhuqin_83 » 2006-11-24 14:31

你有没有看过wiki的快速设置指南?
安装一下解码器之类的。另外是不是把mplayer的fonts装上?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

#9

帖子 linhanwen » 2006-11-24 15:39

我有看啊,

一步一步来做的,不过,就不知道 为什么会这样

乱码啊,很乱啊,看了就心烦啊
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

#10

帖子 linhanwen » 2006-11-24 15:54

出现有错误还是这个问题:

Xlib: extension "XFree86-VidModeExtension" missing on display ":1.0".

请问这是什么原因呢???
linhanwen
帖子: 51
注册时间: 2006-11-13 23:13
送出感谢: 0
接收感谢: 0

#11

帖子 linhanwen » 2006-11-24 18:23

实在无法理解啊!!!

已经装了N次啦
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#12

帖子 aBiNg » 2006-11-24 19:33

字体的问题,可以参考这个post

提示一下:
终端命令行出错信息已经很详细了,为何舍近求远? :roll:
回复

回到 “影音多媒体”