当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 由mplayer和安装引出的 ubuntu的一个要改善的问题!!!
帖子发表于 : 2006-11-29 8:44 

注册: 2006-11-22 11:43
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
我 是一个新手 在安装东西的时候都是搜一堆文章来乱搞一通!!
在我找源的时候我找到了很多个!!我一时不知用哪个好!
我就选了两个放在我的sources.list里!cn99 和我原来和有的!
这样一来就有问题了:

ye@ye-desktop:~$ sudo apt-get install mplayer-386
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer-386: 依赖: libjack0.80.0-0 (>= 0.99.0) 但是它将不会被安装
E: 无法安装的软件包
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer-386: 依赖: libjack0.80.0-0 (>= 0.99.0) 但是它将不会被安装
E: 无法安装的软件包


[b]依赖但又不安装!!{{{libjack0.80.0-0 (>= 0.99.0) }}}但是它将不会被安装这样一来就连旧的东西都安不上!!了!!
!!!!!!这直接原因应该是源的不同步吧!!!!
!!!!!!根本的原因还是UBUNTU在安装方面的问题吧!!
在这方面应该不关安全性的问题吧!为什么给的权限这么低!假如我喜欢用原来旧的软件,但是我的电脑里下了一个小部分的新的!!是不是我还要满电脑的把那一小部分找出来在把源封死啊!!才能装旧的软件啊!!
[/b]


急!!!急!!!急!!!请大家帮帮我啊!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-29 8:47 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
apt-get 不会自动安装依赖,需要使用
apt-get -f install 来自动安装依赖,

你可以使用 aptitude install 来安装软件,这个可以自动安装依赖。


页首
 用户资料  
 
3 楼 
 文章标题 : 还不是一样!!!!!!!
帖子发表于 : 2006-11-29 9:07 

注册: 2006-11-22 11:43
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
ye@ye-desktop:~$ sudo apt-get -f install mplayer-386
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer-386: 依赖: libjack0.80.0-0 (>= 0.99.0) 但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-29 9:42 

注册: 2006-11-22 11:43
帖子: 77
送出感谢: 0 次
接收感谢: 0 次
[quote="oneleaf"]apt-get 不会自动安装依赖,需要使用
apt-get -f install 来自动安装依赖,

你可以使用 aptitude install 来安装软件,这个可以自动安装依赖。[/quote

谢谢老大 aptitude install还真有用!!功能蛮强的!!
请问一下aptitude install他的原理和意思是什么!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译