当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题][讨论]gstreamer0.8和0.10我安装不了
帖子发表于 : 2006-12-21 19:01 

注册: 2006-09-23 20:25
帖子: 17
地址: chengdu sichuan
送出感谢: 0 次
接收感谢: 0 次
引用:
首先安装多媒体编码器
sudo apt-get install gstreamer0.8-plugins
接着
sudo apt-get install gstreamer0.8-lame gstreamer0.8-ffmpeg w32codecs libdivx4linux install lame sox ffmpeg mjpegtools vorbis-tools
在系统询问是否继续(y/n)时,一律输入y,回车。
再在终端输入
gst-register-0.8
回车。

(2)安装gstreamer的解码器,gstreamer是gnome主推的多媒体平台。然后我们安装xine的解码器 libxine-extracodecs ,xine是另外一个多媒体平台,功能非常强大。我们还把系统自带的totem卸载,改为使用xine后端的totem,这样才可以播放rmvb等视频。顺便安装上播放器mplayer。

sudo apt-get install gstreamer0.10-*
sudo apt-get install libxine-extracodecs totem-xine mplayer-686 ffmpeg lame faad sox mjpegtools libxine-main1

这个是我从这个论坛里看到的,具体是哪儿我也忘了 呵呵。要请教大家的地方就是
问题1
引用:
sudo apt-get install gstreamer0.8-lame gstreamer0.8-ffmpeg w32codecs libdivx4linux install lame sox ffmpeg mjpegtools vorbis-tools

这个命令是一口气输入完还是什么?是什么意思呢?
我猜测的是 是在安装一堆解码的插件吧。但是具体都是什么用处的呢?好像是有mpeg的 divx的 其他的就不知所云了。
另一个提问的原因就是我按照说明使用这个语句的时候失败了。所以我想麻烦大家告诉我具体如何实现这个语句。把我要的软件安装好

问题2

引用:
sudo apt-get install gstreamer0.10-*

文章随后又教我们下载这个软件的 0.10的版本。是因为要下0.10之前,就必须有0.8的版本么?我觉得不是这样的吧。不过更令我崩溃的是,那个随后的长长 的语句我又弄砸了 .....所以,麻烦大家指点了


_________________
机器配置
lenovo天逸100A
CPU:1.73GHz
Memory:768Mb
Harddisk:60Gb
OS:Ubuntu 6.06
Level=new comer in linux


最后由 capgish 编辑于 2006-12-22 7:52,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-22 5:48 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
ctrl c 拷贝后,用ctrl+shift+v粘贴到终端好了,确实是一口气的。
不是比需要0.8的,0.10的版本明显新阿,只要装0.10的就够了。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-22 7:54 

注册: 2006-09-23 20:25
帖子: 17
地址: chengdu sichuan
送出感谢: 0 次
接收感谢: 0 次
如何卸载0.8版本的呢 对系统有影响么 我想安全地卸载,不想一下子让它把其他软件都要用到的关联文件都删除了 我该怎么办?

按照楼上的方法,我总是找不到软件包
引用:
错误 http://ubuntu.cn99.com dapper-security/main libxine-main1 1.1.1+ubuntu2-7.5 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 5_i386.deb 404 Not Found
无法更正缺少的软件包。
E: 放弃安装。


_________________
机器配置
lenovo天逸100A
CPU:1.73GHz
Memory:768Mb
Harddisk:60Gb
OS:Ubuntu 6.06
Level=new comer in linux


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-22 9:02 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
你换个源.cn99的最近有点问题.

不知道你在那里看的文档.感觉是拼凑起来的.有些部分比如0.10部分是我写的.

我强烈建议你直接在本站的wiki上面搜索快速设置指南.按照上面进行设置.就基本没有问题.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-22 14:01 

注册: 2006-09-23 20:25
帖子: 17
地址: chengdu sichuan
送出感谢: 0 次
接收感谢: 0 次
感谢楼上的提示
我切换到了
引用:
cn.archive.ubuntu.com

速度慢了点,但是还是可以的。呵呵

但是播放不了RVMB和RM的视频的 ……
有办法解决么?谢谢
另外就是这个东西的教学帖子有没有呢???


_________________
机器配置
lenovo天逸100A
CPU:1.73GHz
Memory:768Mb
Harddisk:60Gb
OS:Ubuntu 6.06
Level=new comer in linux


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-12-22 14:18 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
下面的链接里面看你对应的版本.按照上面的步骤一步步做下去.


http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 7%E5%8D%97


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-12-22 14:24 

注册: 2006-09-23 20:25
帖子: 17
地址: chengdu sichuan
送出感谢: 0 次
接收感谢: 0 次
谢谢了 这个很早我就看了的 我的是6.06的 ubuntu 按照我上述帖子上的内容已经成功安装了mplayer 但是问题就是rm rmvb(希望我没拼错) 那些格式的要不就是放不了要不就是只有声音。
提示的是
引用:
cannot find codec matching selected -vo and video format 0x30345652


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译