当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Amarok无法播放mp3????
帖子发表于 : 2007-01-04 22:27 

注册: 2006-12-04 21:45
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
我用的是KUbuntu6.1装的是Amorak1.4.3 现在装当我要播放放Mp3的时候他说少libxine-extracodecs,只能装上这个才能放。接下我就装libxine-extracodecs,但是却出现libxine-extracodecs依赖libxine-main1: 冲突: libxine1,而我删除libxine1时却是连Amarok一起删掉的,那要我怎么办呀????


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-04 22:30 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
请问,你是用apt-get来安装这些包的吗?


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-04 22:41 

注册: 2006-12-04 21:45
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
是的,都是这样装的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-04 22:43 

注册: 2006-12-04 21:45
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
lhd@lhd-desktop:/etc/apt$ sudo apt-get install libxine-extracodecs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libxine-extracodecs: 依赖: libxine-main1 但是它将不会被安装
E: 无法安装的软件包
lhd@lhd-desktop:/etc/apt$ sudo apt-get install libxine-main1
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
kaffeine-xine kaffeine amarok-xine amarok libxine1
使用 'apt-get autoremove' 来删除它们。
推荐安装的软件包:
libxine-extracodecs
下列软件包将被【卸载】:
amarok amarok-xine kaffeine kaffeine-xine libxine1
下列【新】软件包将被安装:
libxine-main1
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 5 个软件包,有 8 个软件未被升级。
需要下载 0B/2934kB 的软件包。
解压缩后将会空出 39.0MB 的空间。
您希望继续执行吗?[Y/n]
你们看看吧,装libxine-extracodecs就会把Amoark给删了。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-04 22:55 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
32bit or 64bit?
还有,源用的哪个?


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-04 23:18 

注册: 2006-04-11 22:23
帖子: 159
送出感谢: 0 次
接收感谢: 0 次
试试装了libxine-extracodecs ,再重新安装amoark


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-04 23:21 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
估计混用了不同版本的源


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-01-05 20:17 

注册: 2006-12-04 21:45
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
我系统装好后没有加过什么源就是这样的,是32Bit的系统,后来加了个cn99的源也是一样

我试过装了libxine-extracodecs ,再重新安装amoark,但是在装Amoark时会把libxine-extracodecs自动删除的,然后自动装上Libxine1
下面是我sources的内容,beryl的源是我为了装3D后来加上的
deb http://cn.archive.ubuntu.com/ubuntu/ edgy main restricted
deb-src http://cn.archive.ubuntu.com/ubuntu/ edgy main restricted

deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multi
verse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted nuiverse mult
iverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe mul
tiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse

deb http://beryl-mirror.lupine.me.uk dapper main
deb-src http://beryl-mirror.lupine.me.uk dapper main
deb http://ubuntu.beryl-project.org/ dapper main aiglx

## Major bug fix updates produced after the final release of the
## distribution.
deb http://cn.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
deb-src http://cn.archive.ubuntu.com/ubuntu/ edgy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://cn.archive.ubuntu.com/ubuntu/ edgy universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://cn.archive.ubuntu.com/ubuntu/ edgy-backports main restricted univer se multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ edgy-backports main restricted un iverse multiverse

deb http://security.ubuntu.com/ubuntu edgy-security main restricted
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted
# deb http://security.ubuntu.com/ubuntu edgy-security universe
# deb-src http://security.ubuntu.com/ubuntu edgy-security universe


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-01-08 22:04 

注册: 2006-12-04 21:45
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
怎么没人帮我了呀,难道这问题没有能搞定了吗????


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-01-08 22:11 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
你没有看到你的源里面又有dapper,又有edgy?混用源肯定会出问题阿.


请把你的dapper全部替换成edgy,然后 sudo apt-get update一下,再安装软件 .


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-01-09 19:59 

注册: 2006-12-04 21:45
帖子: 190
送出感谢: 0 次
接收感谢: 0 次
这样呀,搞定了,呵呵!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译