源代码安装audacious无法正常播放音乐,搜索后仍然不能解决

Totem,mplayer,sopcast,realplayer,bmp
回复
蜗牛也是_牛
帖子: 5
注册时间: 2012-10-21 20:58
系统: ubuntu11.10
送出感谢: 0
接收感谢: 0

源代码安装audacious无法正常播放音乐,搜索后仍然不能解决

#1

帖子 蜗牛也是_牛 » 2013-04-05 16:40

系统ubuntu10.04LTS,apt安装audacious版本有点老了,想安装更新版本的audacious.
从http://audacious-media-player.org/上下载3.2.4源码包与插件包.
然后先安装源码包,再安装插件包.
正常安装,但是不能正常播放音乐,提示无法为***.mp3找到解码器.

网上搜索解决方案:
http://www.linuxdiyf.com/viewarticle.php?id=119045
其中提到
无法播放mp3是因为有一个插件没有装libmad,因为在编译audacious-plugins时,没有检查到libmad的库文件,所以就不会产生mp3解码文件......所以请安装libmad后,在重新编译一次audacious-plugins
然后apt-cache search libmad ,然后安装了以下四个东东

xmms2-plugin-mad - XMMS2 - libmad based mp3 decoder
libsox-fmt-mp3 - SoX MP3 format library
libmad0-dev - MPEG audio decoder development library
libmad0 - MPEG audio decoder library
重新编译,安装audacious-plugins.问题没有解决.
然后重试http://www.linuxdiyf.com/viewarticle.php?id=11 ... 编译安装Libmad.
在此处下载http://www.linuxfromscratch.org/blfs/view/svn/ ... org/252869[/img]没有出错提示,或者说我看不出来,不知道怎么解决了.希望大家帮助啊,谢谢了
蜗牛也是_牛
帖子: 5
注册时间: 2012-10-21 20:58
系统: ubuntu11.10
送出感谢: 0
接收感谢: 0

Re: 源代码安装audacious无法正常播放音乐,搜索后仍然不能解决

#2

帖子 蜗牛也是_牛 » 2013-04-05 16:56

make出错图
http://imagebin.org/252869
makefile出错,将Makefile的 -force-mem去掉后,能正常make了
头像
YeLee
论坛版主
帖子: 26408
注册时间: 2008-08-13 8:48
系统: Fundu i64
来自: 东海硇州,一双管钥。
送出感谢: 25 次
接收感谢: 307 次
联系:

Re: 源代码安装audacious无法正常播放音乐,搜索后仍然不能解决

#3

帖子 YeLee » 2013-04-05 17:40

发现我什么都看不出来就对了,不过,不能播放除了没有库的问题外,输出设备的影响也很大。 :em20 :em20 :em20
另,关于手动编译失败什么libmad的问题,倒可以直接安装源里的那个版本,那你不是搜索到了么?干嘛又不装了?
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关
回复

回到 “影音多媒体”