[分享]今天编译了Mplayer,支持slider进退了

Totem,mplayer,sopcast,realplayer,bmp
回复
Hesperus
帖子: 119
注册时间: 2006-03-09 23:18
送出感谢: 0
接收感谢: 1 次

[分享]今天编译了Mplayer,支持slider进退了

#1

帖子 Hesperus » 2007-04-05 12:20

官方源里的mplayer一直都有些小毛病,只能是将就着用,前几天升级到feisty,xine有问题了,放rm,rmvb没有声音,找了很久没找到解决方案,网上找到的大多是用realplayer的方案。
但是mplayer又不能用slider进退,用快键快进rm又有声音不同步的问题,于是svn了mplayer编译。

问题全部解决。可以放心的apt-get remove totem了,xine放rm,rmvb没有声音的问题,没办法,网上大部分都是rmvb。
刚刚又试了下,纠正一下,还是不能drag rmvb 但是可以 drag avi。
好像国外有朋友解决这个问题。

我用checkinstall做了deb包。如果你不想编译,刚刚好也是feisty,就下载吧。

安装前先
sudo apt-get remove mplayer mencoder
上传到ftp上了,注意deb里面没有skin,附一个skin
ftp://ftp.mplayerhq.hu/MPlayer/skins/OS ... .3.tar.bz2
sudo tar -jxvf OSX-Brushed-2.3.tar.bz2 /usr/share/mplayer/skins/ & ln -s /usr/share/mplayer/skins/{OSX-Brushed,default}
或着
放在~/.mplayer/skins下
再或着你就直接sudo apt-get install mplayer-skin

装字体,我用的yahei,换成你们的就行
sudo ln -s /usr/share/fonts/vista/msyh.ttf .mplayer/subfont.ttf

ftp://ubuntuftp@ftp.ubuntu.org.cn/multi ... 6zh_CN.deb
ftp的密码和使用方法论坛里有,找一下吧。

一个简单的方法,直接下载ftp://ubuntuftp@ftp.ubuntu.org.cn/multimedia/mplayer.tar.bz2
sudo mv /usr/bin/mplayer,mplayer_org
sudo tar -jxvf mplayer.tar.bz2 /usr/bin/
hzhr
帖子: 16
注册时间: 2006-05-05 2:22
送出感谢: 0
接收感谢: 0

#2

帖子 hzhr » 2007-04-08 0:45

xine播放rm、rmvb没有声音,是xineplug_decode_ff.so做的怪,估计禁用ffmpeg对RealAudio Cooker的支持就可以了,我懒得编译,没有去重编译xine,直接去掉 xineplug_decode_ff.so,当然放其他格式可能有点问题了。
Hesperus
帖子: 119
注册时间: 2006-03-09 23:18
送出感谢: 0
接收感谢: 1 次

#3

帖子 Hesperus » 2007-04-08 17:35

hzhr 写了:xine播放rm、rmvb没有声音,是xineplug_decode_ff.so做的怪,估计禁用ffmpeg对RealAudio Cooker的支持就可以了,我懒得编译,没有去重编译xine,直接去掉 xineplug_decode_ff.so,当然放其他格式可能有点问题了。

xine没有声音的问题我已经解决了
修改配置文件,
#engine.decoder_priorities.realadec:0
engine.decoder_priorities.realadec:1

totem-xine .gnome2/totem_config
其它xine前端 .xine/config

我把totem-xine删了
totem唯一好用的还是drag,不过,我用的是e17,一开totem,老是自动运行gnome-settings-daemon,窗体和我的e17不符了。
头像
bwchaos
帖子: 416
注册时间: 2006-10-19 14:08
来自: 西夏
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 bwchaos » 2007-04-09 10:51

avi本来就可以拖放
Hesperus
帖子: 119
注册时间: 2006-03-09 23:18
送出感谢: 0
接收感谢: 1 次

#5

帖子 Hesperus » 2007-04-10 15:55

恩,不过我说的是滚动条,rmvb的在rc的版本中是不能拖的,只能快键进退。

另外,不知道rc版的能不能加载sub的字幕。
头像
bwchaos
帖子: 416
注册时间: 2006-10-19 14:08
来自: 西夏
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 bwchaos » 2007-04-17 22:33

可以
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#7

帖子 依寻依然 » 2007-04-20 18:30

可惜阿,系统要我更新,更新了还是不能进退……
Hesperus
帖子: 119
注册时间: 2006-03-09 23:18
送出感谢: 0
接收感谢: 1 次

#8

帖子 Hesperus » 2007-04-20 20:57

更新后,再把mplayer覆盖了就行了。
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#9

帖子 依寻依然 » 2007-04-20 22:26

我的mplayer一直不能全屏,今天找到/etc/mplayer/mplayer.conf,把zoom前面的#去掉就能全屏了。
用你的方法,确实可以拖动了,可惜我的mplayer又不能全屏咯,zoom前面有没有#都不行了 :?
Hesperus
帖子: 119
注册时间: 2006-03-09 23:18
送出感谢: 0
接收感谢: 1 次

#10

帖子 Hesperus » 2007-04-24 18:41

你没有使用gmplayer ?用gmplayer吧,方便。

ln -s /usr/bin/mplayer -gui /usr/bin/gmplayer
zzyzzy123
帖子: 2
注册时间: 2007-03-26 10:01
送出感谢: 0
接收感谢: 0

#11

帖子 zzyzzy123 » 2007-04-25 13:37

Totem 播放 rmvb 没有声音,这里给出了解决方法:
编辑 ~/.xine/catalog.cache 文件
找到
[/usr/lib/xine/plugins/1.1.4/xineplug_decode_real_audio.so]
把 decoder_priority 增加到 10
回复

回到 “影音多媒体”