当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gstreamer0.10 安装问题
帖子发表于 : 2007-04-27 21:17 

注册: 2006-12-16 16:48
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install gstreamer0.10-* 出现问题:
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
libsdl1.2debian: 依赖: libsdl1.2debian-alsa (= 1.2.9-0.0ubuntu2) 但是它将不会被安装 或
libsdl1.2debian-all (= 1.2.9-0.0ubuntu2) 但是它将不会被安装 或
libsdl1.2debian-esd (= 1.2.9-0.0ubuntu2) 但是它将不会被安装 或
libsdl1.2debian-arts (= 1.2.9-0.0ubuntu2) 但是它将不会被安装 或
libsdl1.2debian-oss (= 1.2.9-0.0ubuntu2) 但是它将不会被安装 或
libsdl1.2debian-nas (= 1.2.9-0.0ubuntu2) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-27 21:31 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
用synaptic比较省事吧


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-27 21:56 

注册: 2006-12-16 16:48
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
用synaptic安装提示
/var/cache/apt/archives/libsdl1.2debian-all_1.2.9-0.0ubuntu2_i386.deb: 正试图覆盖“/usr/lib/libSDL-1.2.so.0”,它属于软件包 sdl

两个不同软件包,怎么会冲突,导致libsdll.2debian无法安装


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-27 22:20 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
那应该是因为deb包里有libSDL吧


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-27 22:35 

注册: 2006-12-16 16:48
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
明白了,我装的是旧版本的SDL,ubuntu需要装debian新版本SDL,需要卸载一个


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-27 22:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
用没有牛力的aptitude吧。会有不同的方案给你选择的。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译