当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Mplayer 不能播放 显示Error opening/initializing the selected vide
帖子发表于 : 2007-04-27 23:36 

注册: 2007-02-27 17:40
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
用Mplayer播放什么都显示如下

Error opening/initializing the selected video_out (-vo) device

不知道该怎么办


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-28 12:24 

注册: 2006-04-06 23:04
帖子: 16
地址: fdu
送出感谢: 0 次
接收感谢: 0 次
我的也是这样。原来没装ati radeon 9550 官方驱动的时候,一切正常,但是装了之后,mplayer, 电影播放机,都用不成了。不过也有个解决办法,就是直接在shell里输命令 mplayer ***.avi 我这样又可以用了。但是这样只有一个电影窗口,没法拖动滑块快进或快退。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-28 12:36 
头像

注册: 2007-02-11 13:27
帖子: 887
送出感谢: 0 次
接收感谢: 0 次
看在播放器界面上点右键——参数设置——视频
里面有个驱动什么的选项
一个一个换着试,


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-05 21:49 
头像

注册: 2006-09-12 19:44
帖子: 654
地址: whu
送出感谢: 0 次
接收感谢: 0 次
只须右键preferences->video->Available drivers中选择xv就OK了~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-08 13:47 
头像

注册: 2006-12-07 6:38
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
wyg1258 写道:
只须右键preferences->video->Available drivers中选择xv就OK了~

这样设置后桌面显示(下图)


附件:
Screenshot.png
Screenshot.png [ 127.83 KiB | 被浏览 1592 次 ]

页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-05-10 13:13 

注册: 2007-05-09 15:23
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
解决问题
.Mplayer播放时提示错误:Error opening/initializing the selected video_out (-vo) device
Preferences-Video 选择 “xv X11/Xv”
Preferences-Codecs&demuxer 选择 “FFmpeg/libavcodec audio decoders”
Mplayer中文字幕设置
Preferences-Font 里面点击 ”Browse” 选择一个中文字体,Encodeing 选择 Unicode
Preferences-Subtitle&OSD 里面的Encoding选择:Simplified Chinese Charset(cp936)
Preferences-Font-Text scale 这里调整字幕大小(我调整为 3.8 )


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-10 13:38 

注册: 2007-05-06 21:03
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
可以在Preferences-Video 选择 有“OpenGL”的试试,我的情况和LZ一样


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-11 3:08 

注册: 2007-03-14 13:28
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
will_kon 写道:
可以在Preferences-Video 选择 有“OpenGL”的试试,我的情况和LZ一样

:D 同Will Kon,选了第一个OpenGL的选项之后马上一切正常了~


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-05-12 19:31 

注册: 2007-05-11 21:46
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
configure driver
那键不能点
没法换


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-16 12:22 
头像

注册: 2007-04-13 15:08
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
wyg1258 写道:
只须右键preferences->video->Available drivers中选择xv就OK了~


真是高手!我的可以了!谢谢啊!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-05-16 17:42 

注册: 2007-05-14 13:44
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的mplayer可以播放了,只是一个问题是,用Gmplayer启动后,点进Preferences里面设定之后可以临时播放。下次再用的时候,又恢复到了之前的设定,这个说明我的设定没有被保存,那么请问各位大大,如何才能实现在gmplayer下面保存设定。PS:我的mpalyer是通过apt-get安装的,同时安装的Kmplayer就可以正常保存设定


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Mplayer 不能播放 显示Error opening/initializing the selected vide
帖子发表于 : 2009-04-11 23:29 

注册: 2009-03-29 11:39
帖子: 19
系统: ubuntu 12.04 64bt
送出感谢: 0 次
接收感谢: 0 次
pereferences->video->x11 x11(xlmage/shm)
我的是这样搞定的


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Mplayer 不能播放 显示Error opening/initializing the selected vide
帖子发表于 : 2009-04-12 7:40 

注册: 2008-11-06 7:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
本人多次安装ubuntu8.10及fedora10.有时使用mplayer报错信息: could not open required directshow codec drvc.dll。有时重装系统后mplayer又很正常。
搜索本论坛等,多建议(如下):

# find /usr/lib -name drvc*
/usr/lib/codecs/drvc.so
# ldd /usr/lib/codecs/drvc.so
libstdc++.so.5 => not found
这样可以看出, libstdc++.so.5需要安装
# apt-get install libstdc++5


但有一部分兄弟按照步骤做了,仍不解决。我也是,google,baidu,yahoo找不到解决方法。摸索了好久,终于今早解决。高兴分享。
原来是自己下载来的codecs的drvc.dll的问题。(太旧?但为何有时重装系统,编译mplayer,用同样codecs却行?)
到http://www.dlldll.com/drvc.dll_download.html下载。
(想发主题,发不成功)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译