当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]MPlayer安装问题
帖子发表于 : 2007-05-04 20:25 

注册: 2006-12-23 10:51
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
配置gui(./congure --enable-gui)时出现这个错误:
Error: X11 support required for GUI compilation.
我的显卡是SiS的
请大家帮忙看看


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-04 23:37 
头像

注册: 2006-09-02 20:42
帖子: 579
地址: 东海明珠
送出感谢: 1
接收感谢: 2
源里面就有,干嘛还要自己编译?


_________________
Life is like a box of chocolates, you never know what you're going to get.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-04 23:53 

注册: 2006-08-21 23:20
帖子: 22
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
如果抱有这种想法的话,每次都不了了之,很难有长进。
atp虽然方便,但自己编译可以学到更多!软件也高度自定义。
底层的东西用atp还差不错,要知道高手连内核都自己编译!
我猜是gui的库没装全,与显卡无关吧?
“X11 support required for GUI compilation” 应该是这个意思,
建议用atp 找找gtk,glib方面的东西。
我只知道在fedora中装mplayer需要gtk+-1.2.10, gtk+-1.2.10-devel, glib-1.2.10, glib-1.2.10-devel
用yum就能解多。不知道ubuntu是否类似,这只是一个线索。但即使是不同发行版,gnome,x11应该是统一的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-05 0:17 

注册: 2006-08-21 23:20
帖子: 22
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
http://blog.csdn.net/cooloocool/archive ... 57098.aspx

找到一段话:
GUI需要GTK 1.2.x(它不是GTK的,但是面板是的)。skin被保存为PNG格式,因此你需要安装gtk,libpng(和他们的devel包,一般是gtk-dev和libpng-dev)。你必须在运行./configure时使用--enable-gui来编译它的代码。然后,你可以用下列方法之一打开GUI方式
1.在你的config文件中添加gui=yes
2.ln -s $PREFIX/bin/mplayer $PREFIX/bin/gmplayer,然后运行gmplayer。
目前由于技术原因,目前你不能在命令行下使用-gui选项。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-05 8:29 

注册: 2006-12-23 10:51
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
嗯,的确是gtk库的原因,现在成功了,谢谢大家!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译