当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : totem-xine 的中文字幕处理。 totem-xine 的中文字幕处理。 请教totem-xine字幕问题
帖子发表于 : 2005-11-22 12:47 

注册: 2005-10-30 21:02
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我参照本版精华“totem-xine 的中文字幕处理http://forum.ubuntu.org.cn/viewtopic.php?t=2760&start=0&postdays=0&postorder=asc&highlight=totem”设置totem,当进行到“编译出 xine-fontconv ”时,输入“ sudo gcc -o /usr/local/bin/xine-fontconv xine-fontconv.c `freetype-config --cflags --libs` ”,得到结果为

bash: freetype-config: command not found
xine-fontconv.c:43:18: error: zlib.h: 没有那个文件或目录
xine-fontconv.c:47:22: error: ft2build.h: 没有那个文件或目录
xine-fontconv.c:48:10: error: #include expects "FILENAME" or <FILENAME>
xine-fontconv.c:49:10: error: #include expects "FILENAME" or <FILENAME>
xine-fontconv.c:112: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘gzwrite_i16’ 中:
xine-fontconv.c:113: 错误:‘fp’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:113: 错误:(即使在一个函数内多次出现,每个未声明的标识符在其
xine-fontconv.c:113: 错误:所在的函数内只报告一次。)
xine-fontconv.c:113: 错误:‘number’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:234: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘create_bitmap’ 中:
xine-fontconv.c:235: 错误:‘FT_Bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:235: 错误:‘bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:249: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘destroy_bitmap’ 中:
xine-fontconv.c:250: 错误:‘bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:262: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘add_border_bitmap’ 中:
xine-fontconv.c:268: 错误:‘src’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:272: 错误:‘left’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:273: 错误:‘dst’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:276: 错误:‘top’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:304: 错误:syntax error before ‘*’ token
xine-fontconv.c: 在函数 ‘add_final_bitmap’ 中:
xine-fontconv.c:310: 错误:‘src’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:314: 错误:‘left’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:315: 错误:‘dst’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:318: 错误:‘top’ 未声明 (在此函数内第一次使用)
xine-fontconv.c: 在顶层:
xine-fontconv.c:339: 错误:syntax error before ‘face’
xine-fontconv.c: 在函数 ‘render_font’ 中:
xine-fontconv.c:343: 错误:‘FT_Bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:343: 错误:‘out_bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:344: 错误:‘gzFile’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:344: 错误:‘fp’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:348: 错误:‘FT_Glyph’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:348: 错误:syntax error before ‘glyph’
xine-fontconv.c:349: 错误:‘FT_BitmapGlyph’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:350: 错误:‘FT_Vector’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:366: 错误:‘fontname’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:366: 错误:‘size’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:389: 错误:‘face’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:398: 错误:‘thickness’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:408: 错误:‘unicodes’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:419: 错误:‘FT_LOAD_DEFAULT’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:458: 错误:‘glyph’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:466: 错误:‘origin’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:470: 错误:‘ft_render_mode_normal’ 未声明 (在此函数内第一次使用)xine-fontconv.c:478: 错误:‘glyph_bitmap’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:478: 错误:syntax error before ‘glyph’
xine-fontconv.c: 在函数 ‘main’ 中:
xine-fontconv.c:533: 错误:‘FT_Library’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:533: 错误:syntax error before ‘library’
xine-fontconv.c:534: 错误:‘FT_Face’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:559: 错误:‘library’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:568: 错误:‘face’ 未声明 (在此函数内第一次使用)
xine-fontconv.c:573: 错误:‘ft_encoding_unicode’ 未声明 (在此函数内第一次使用)
请问这是什么原因造成的?该如何解决?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-22 17:56 

注册: 2005-11-20 11:54
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
原因我也不知道,不过这里有一个现成的可以用
http://www.linuxsir.org/bbs/showthread.php?t=208402


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-22 21:33 

注册: 2005-10-30 21:02
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
谢谢!不过下了后该怎样用?小弟菜,请多多指教。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-22 21:39 

注册: 2005-10-30 21:02
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
小弟的机子里也没有zh_CN/TrueType/SIMSUN.TTF这个文件,请问该到哪去装zh_CN/TrueType/SIMSUN.TTF?谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-23 21:15 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
哈哈,我也遇到和楼主一样的问题,还没有解决呢!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-24 9:07 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
不一定要用simsun的,用别的中文字体就好了,不过建议还是使用mplayer来播放DVD,可以非常完美的支持中文字体,只需要一个命令,把字体链接到他的配置目录就行了.

下面是我的blog上关于mplayer字幕字体显示问题的文章,你可以参考一下.
http://spaces.msn.com/karronqiu/blog/cn ... #permalink
http://spaces.msn.com/karronqiu/blog/cn ... #permalink

下面这个是我关于totem-xine的字幕字体显示的文章,你也可以看看
http://spaces.msn.com/karronqiu/blog/cn ... #permalink


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-05-21 18:37 
头像

注册: 2005-10-27 19:41
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
最简单的方法就是去下个编译好的xine-fcontconv,并放到/usr/local/bin/的目录下就好了。
没有的字体可以自己去下,或者从windows的fonts里cp过来。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-22 12:00 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
RGVR250 写道:
最简单的方法就是去下个编译好的xine-fcontconv,并放到/usr/local/bin/的目录下就好了。
没有的字体可以自己去下,或者从windows的fonts里cp过来。


放到目录下以后怎么用?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-05-22 21:44 
头像

注册: 2006-04-12 18:54
帖子: 4671
送出感谢: 0 次
接收感谢: 7
704不用怎么设置直接可以用的吧


_________________
荃创想


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译