[问题]阴沟翻船啦!(已经解决)

Totem,mplayer,sopcast,realplayer,bmp
回复
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

[问题]阴沟翻船啦!(已经解决)

#1

帖子 yechf » 2007-07-05 21:19

一直以来,用linux播放遇到的音频视频文件都没有问题。
我小孩子喜欢看猫和老鼠,在win下,把碟片插入dvd,用媒体播放器没有问题。可是在ubuntu下,难住了,以为安装了所有codecs就没有问题。唉!
附件
Screenshot-1.png
上次由 yechf 在 2007-07-16 8:17,总共编辑 2 次。
头像
czybear
帖子: 54
注册时间: 2007-06-12 17:22
送出感谢: 0
接收感谢: 0

#2

帖子 czybear » 2007-07-05 21:34

装个KMPlayer试试呢?
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

#3

帖子 yechf » 2007-07-05 21:40

楼上,跟壳有什么关系呢?
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

#4

帖子 yechf » 2007-07-05 22:25

补充一下。

wlp@ubuntu:~$ mplayer /media/VideoCD/mpegav/avseq02.dat
MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.00GHz (Family: 15, Model: 2, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /media/VideoCD/mpegav/avseq02.dat.
Seek failed


Exiting... (End of file)
wlp@ubuntu:~$
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 zhuqin_83 » 2007-07-06 7:46

看wiki的快速指南,dvd要外装一个解码器。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

我已经安装了这些东西啦。还是不行。

#6

帖子 yechf » 2007-07-06 20:56

wlp@ubuntu:~$ sudo apt-get install audacious audacious-plugins audacious-plugins-extra libdvdcss2 libdvdnav4 libdvdplay0 libdvdread3 w32codecs libxine-extracodecs gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
audacious 已经是最新的版本了。
audacious-plugins 已经是最新的版本了。
audacious-plugins-extra 已经是最新的版本了。
libdvdcss2 已经是最新的版本了。
libdvdnav4 已经是最新的版本了。
libdvdplay0 已经是最新的版本了。
libdvdread3 已经是最新的版本了。
w32codecs 已经是最新的版本了。
libxine-extracodecs 已经是最新的版本了。
gstreamer0.10-pitfdll 已经是最新的版本了。
gstreamer0.10-ffmpeg 已经是最新的版本了。
gstreamer0.10-plugins-bad 已经是最新的版本了。
gstreamer0.10-plugins-bad-multiverse 已经是最新的版本了。
gstreamer0.10-plugins-ugly 已经是最新的版本了。
gstreamer0.10-plugins-ugly-multiverse 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
wlp@ubuntu:~$
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

#7

帖子 yechf » 2007-07-07 10:56

zhuqin_83 写了:看wiki的快速指南,dvd要外装一个解码器。


有谁可以告诉我,是哪个解码器?
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

#8

帖子 yechf » 2007-07-08 23:07

受不了了,怎么播放不了dat文件?
附件
Screenshot.png
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

我知道了。

#9

帖子 yechf » 2007-07-16 8:16

头像
james_xl
帖子: 107
注册时间: 2006-09-17 17:31
送出感谢: 0
接收感谢: 0

#10

帖子 james_xl » 2007-07-16 21:31

需要装libdvdcss2,然后就可以直接播放DVD了,而且好像源里的这个库不行,要用最新的,试试我的附件
附件
libdvdcss2_1.2.9-2medibuntu2+build1_i386.deb
(35.13 KiB) 下载 29 次
头像
yechf
帖子: 305
注册时间: 2006-04-27 12:18
来自: 浙江德清武康
送出感谢: 3 次
接收感谢: 0

#11

帖子 yechf » 2007-07-17 9:30

楼上的东西不行啊。
totem,kaffeine,gxine,kmplayer都不行,选择播放vcd时,有的甚至会崩溃。
但是smplayer可以。
mplayer vcd://3这样是可以的。
回复

回到 “影音多媒体”