当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : RMVB有声音,无图像,为什么呢?
帖子发表于 : 2007-07-12 13:26 
头像

注册: 2007-05-17 16:15
帖子: 143
送出感谢: 0 次
接收感谢: 0 次
如图,7.04的ubuntu
使用totem播放
先说要找解码器
图片
接着添加删除里面又只有一个gstreamer
图片
点了确定以后开始播放rmvb,只有声音,图像就是放歌时候的显示特效
按照快速设置指南设置的
安装多媒体解码器

sudo apt-get install audacious audacious-plugins audacious-plugins-extra libdvdcss2 libdvdnav4 libdvdplay0 libdvdread3 w32codecs libxine-extracodecs gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

安装mplayer播放器

sudo apt-get install mplayer-fonts mplayer mplayer-skins mozilla-mplayer

做了上面这些,mplayer直接显示那个fatal error
图片

到底怎么回事呢?一直以来放影片就没舒服过


附件:
Screenshot-Fatal error!.png
Screenshot-Fatal error!.png [ 6.25 KiB | 被浏览 2190 次 ]
Screenshot-添加-删除程序.png
Screenshot-添加-删除程序.png [ 24.46 KiB | 被浏览 3432 次 ]

Screenshot-gnome-codec-install.png
Screenshot-gnome-codec-install.png [ 11.3 KiB | 被浏览 2175 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-12 13:36 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
sudo apt-get install libxine-extracodecs totem-xine ffmpeg lame faad sox mjpegtools libxine-main1 w32codecs


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-12 13:43 
头像

注册: 2007-05-17 16:15
帖子: 143
送出感谢: 0 次
接收感谢: 0 次
谢了,可以播放了。
不知道为什么这一段没有加入快速设置指南?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-12 13:48 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
可能是版权问题,这个是解码器一般都是有版权的,官方的快速设置指南不会加的,在论坛里面找还好过


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-21 22:18 

注册: 2007-07-19 15:44
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
:D 根据此法以解决我的问题,哈哈,谢谢啦


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-23 16:33 
头像

注册: 2007-06-27 15:19
帖子: 32
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
我安装时碰到了
dpkg:关于含有 totem-xine 的 totem-xine_2.18.1-0ubuntu3_i386.deb:
totem-xine conflicts with totem-gstreamer
totem-gstreamer (版本为 2.18.1-0ubuntu3)现在 已安装完毕。
dpkg:处理 totem-xine_2.18.1-0ubuntu3_i386.deb (--install)时出错:
软件包相互冲突 - 将不安装 totem-xine

该怎么办?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-23 19:41 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
你可以删掉 totem-gstreamer
sudo apt-get remove totem-gstreamer
我的安装都是自动删掉的,不知道你的是什么回事


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-24 16:49 
头像

注册: 2007-06-27 15:19
帖子: 32
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
使用自带的播放器放mp3,只响下一就把程序给退出了,又是咋回事呢?还狂多乱码


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-24 17:43 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
重新安装一下audacious,用源里面的,乱码问题你google一下论坛


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-25 14:19 
头像

注册: 2007-06-27 15:19
帖子: 32
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
我说的自带播放器是Rhythmbox


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-07-26 19:11 
头像

注册: 2007-07-01 21:54
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
sudo apt-get install libxine-extracodecs totem-xine ffmpeg lame faad sox mjpegtools libxine-main1 w32codecs


我安上面执行,出错:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
现在没有可用的软件包 w32codecs,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 w32codecs 还没有可供安装的候选者


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-07-27 9:17 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
回ls,你的源里面没有w32codecs这个包,你要么加有这个包的源,要么上网下一个,我用的cn99,rootguide都有的,要么你的源没有加有ubuntu-cn这一行


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-29 0:16 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
leeaman 写道:
sudo apt-get install libxine-extracodecs totem-xine ffmpeg lame faad sox mjpegtools libxine-main1 w32codecs


谢谢2楼的朋友!现在遇到的问题是,有了图像却没有声音了


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-07-29 0:23 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
relaxssl 写道:
leeaman 写道:
sudo apt-get install libxine-extracodecs totem-xine ffmpeg lame faad sox mjpegtools libxine-main1 w32codecs


谢谢2楼的朋友!现在遇到的问题是,有了图像却没有声音了


ubuntu 7.04 rmvb没有声音,点下我的签名档。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-07-29 9:21 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
relaxssl 写道:
leeaman 写道:
sudo apt-get install libxine-extracodecs totem-xine ffmpeg lame faad sox mjpegtools libxine-main1 w32codecs


谢谢2楼的朋友!现在遇到的问题是,有了图像却没有声音了

请看一下那个下面的图片,看贴不认真


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译