当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]新手不懂,问个解码器的问题 rm,rmvb
帖子发表于 : 2007-07-15 12:35 

注册: 2007-06-11 18:38
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
大家好,本人一直在用WINDOWS,也知道没有解码器播放器就放不了电影,尤其是rm,rmvb,一定得有real公司的解码器,不过,一般WIN下的播放器中带解码器,所以,基本上是装播放器,有些播放器在缺解码器时会自动上网查找自动安装。在UBUNTU下,现在还不是很清楚,不过好象是一样的。
我是电脑是amd64的CPU,我装的也是AMD64的UBUNTU,记得第一次放MP3时,说要搜索解码器,问是否让搜,默认是不让,我点了让,然后输密码,装,完了,MP3就可以放了。avi格式的也是,也能正常播放了。
可是,有我双击RM 和 RMVB的文件时,我也点了同意搜,同意装,可是会报一个错误出来,然后那个rm的没有图象,有声音,那个rmvb就什么也出不来,无法播放。
错误: RM:没有报错误,只是没有图象只有声音,下次打开还是让搜解码器(MP3是不用的),然后还是没有图象。
RMVB:在安装解码器时(后):报一个错误窗口:发生了一个错误 The playback of this movie requires the following decoders which are not installed: RealVideo 4.0解码器 RealAudio解码器,点了确定后,不动了。

我查看了/usr/lib64/win32文件夹,里面有atrc.so,cook.so,drvc.so,sipr.so 和 essential-adm64-20061203这个文件夹。

我也不清楚是不是已经装了需要的解码器,也不清楚为什么一直报错误,怎么装解码器,求求高手帮帮我吧。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [问题]新手不懂,问个解码器的问题 rm,rmvb
帖子发表于 : 2007-07-15 14:17 

注册: 2007-06-29 14:47
帖子: 25
地址: 成都
送出感谢: 0 次
接收感谢: 0 次
你好,具体的我也不清楚哪个是对应的解码器。但,我直接按照以下步骤完成,用ubuntu7.04自带的movie player能正常播放rm、rmvb等

第一步:安装mp3媒体文件格式的解码器和w32codecs
代码:
sudo apt-get install gstreamer0.10-fluendo-mp3

代码:
sudo apt-get install w32codecs


第二步:安装媒体播放机和gstreamer的解码器
代码:
sudo apt-get install mplayer

代码:
sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad  gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse


第三步: 安装xine及解码器
代码:
sudo apt-get install libxine-extracodecs totem-xine ffmpeg lame faad sox mjpegtools libxine-main1


解决声音过小问题:
代码:
sudo gedit ~/.xine/catalog.cache

找到[/usr/lib/xine/plugins/1.1.4/xineplug_decode_real_audio.so]
把 decoder_priority 增加到 10


weigq811202 写道:
大家好,本人一直在用WINDOWS,也知道没有解码器播放器就放不了电影,尤其是rm,rmvb,一定得有real公司的解码器,不过,一般WIN下的播放器中带解码器,所以,基本上是装播放器,有些播放器在缺解码器时会自动上网查找自动安装。在UBUNTU下,现在还不是很清楚,不过好象是一样的。
我是电脑是amd64的CPU,我装的也是AMD64的UBUNTU,记得第一次放MP3时,说要搜索解码器,问是否让搜,默认是不让,我点了让,然后输密码,装,完了,MP3就可以放了。avi格式的也是,也能正常播放了。
可是,有我双击RM 和 RMVB的文件时,我也点了同意搜,同意装,可是会报一个错误出来,然后那个rm的没有图象,有声音,那个rmvb就什么也出不来,无法播放。
错误: RM:没有报错误,只是没有图象只有声音,下次打开还是让搜解码器(MP3是不用的),然后还是没有图象。
RMVB:在安装解码器时(后):报一个错误窗口:发生了一个错误 The playback of this movie requires the following decoders which are not installed: RealVideo 4.0解码器 RealAudio解码器,点了确定后,不动了。

我查看了/usr/lib64/win32文件夹,里面有atrc.so,cook.so,drvc.so,sipr.so 和 essential-adm64-20061203这个文件夹。

我也不清楚是不是已经装了需要的解码器,也不清楚为什么一直报错误,怎么装解码器,求求高手帮帮我吧。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-15 14:42 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
64位的系统设置起来稍微不一样. 网上一般的方法都是32位的系统的. 我个人建议使用32位系统, 会少很多麻烦.

另外呢, 可以看看 wiki.ubuntu.org.cn 里面的快速设置指南.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-15 16:52 

注册: 2007-01-12 13:26
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
你装 w32codecs(可能要网上找deb包,源里不一定有) totem-xine(这个源里有) 应该就可以了
totem默认的gstreamer 貌似不支持rm


页首
 用户资料  
 
5 楼 
 文章标题 : 谢谢大家的帮忙,很开心
帖子发表于 : 2007-07-16 15:20 

注册: 2007-06-11 18:38
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
谢谢大家的帮忙,我回家了试试。听说32位的和64位的不一样了。不清楚怎么弄。

刚刚收到ubuntu的安装光盘了!!喜,所以上来看看,原来大家已经回了这么多了。多谢大家关心,如果有什么问题我还会上来问的。


页首
 用户资料  
 
6 楼 
 文章标题 : 很好用,感谢
帖子发表于 : 2007-07-22 17:56 

注册: 2006-10-25 15:48
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我的xine在播放RMVB时有图像没有声音,按照下面修改后,ok了!多谢!

------------------------------------
解决声音过小问题:
代码:
sudo gedit ~/.xine/catalog.cache

找到[/usr/lib/xine/plugins/1.1.4/xineplug_decode_real_audio.so]
把 decoder_priority 增加到 10
:D :D :D :D :D


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-23 22:13 
头像

注册: 2006-12-12 0:00
帖子: 17
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package w32codecs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package w32codecs has no installation candidate

what does these phrases mean? Besides SCIM is not available while typing in this blank, why?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-21 10:50 

注册: 2007-08-12 15:06
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
全部搞定,谢谢大家


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-18 17:33 

注册: 2007-12-18 15:02
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
呵呵 ,我搞定了 ........都可以看了......


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-01-29 9:30 

注册: 2008-01-12 1:05
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
还是装个realplayer吧 那个很好用的


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-02-07 16:59 

注册: 2008-01-25 15:11
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
在 代码时出现:
sudo apt-get install w32codecs
--------------------
现在没有可用的软件包 w32codecs,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 w32codecs 还没有可供安装的候选者


我是新手,球助



:shock:


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-02-07 16:59 

注册: 2008-01-25 15:11
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
在 代码时出现:
sudo apt-get install w32codecs
--------------------
现在没有可用的软件包 w32codecs,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 w32codecs 还没有可供安装的候选者


我是新手,球助


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-02-12 11:54 
头像

注册: 2006-01-18 12:55
帖子: 1347
地址: 也许真的没有人理解
送出感谢: 0 次
接收感谢: 1
64位装w64codec就行了,都不知道么……


_________________
MacBook Pro 15" User
Cocoa Programmer


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-02 7:42 
头像

注册: 2008-03-07 12:19
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
jordge 写道:
你装 w32codecs(可能要网上找deb包,源里不一定有) totem-xine(这个源里有) 应该就可以了
totem默认的gstreamer 貌似不支持rm


w32codecs不支持64位系统!已经试过了~!

:cry: :cry: :cry: :cry:


页首
 用户资料  
 
15 楼 
 文章标题 : 我的怎么还没解决啊
帖子发表于 : 2008-04-03 1:02 

注册: 2008-03-16 11:25
帖子: 6
送出感谢: 0 次
接收感谢: 0 次


E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

我的还是不能播 rm.rvbm 格式的

请问这是为什么啊
weigq811202 写道:
大家好,本人一直在用WINDOWS,也知道没有解码器播放器就放不了电影,尤其是rm,rmvb,一定得有real公司的解码器,不过,一般WIN下的播放器中带解码器,所以,基本上是装播放器,有些播放器在缺解码器时会自动上网查找自动安装。在UBUNTU下,现在还不是很清楚,不过好象是一样的。
我是电脑是amd64的CPU,我装的也是AMD64的UBUNTU,记得第一次放MP3时,说要搜索解码器,问是否让搜,默认是不让,我点了让,然后输密码,装,完了,MP3就可以放了。avi格式的也是,也能正常播放了。
可是,有我双击RM 和 RMVB的文件时,我也点了同意搜,同意装,可是会报一个错误出来,然后那个rm的没有图象,有声音,那个rmvb就什么也出不来,无法播放。
错误: RM:没有报错误,只是没有图象只有声音,下次打开还是让搜解码器(MP3是不用的),然后还是没有图象。
RMVB:在安装解码器时(后):报一个错误窗口:发生了一个错误 The playback of this movie requires the following decoders which are not installed: RealVideo 4.0解码器 RealAudio解码器,点了确定后,不动了。

我查看了/usr/lib64/win32文件夹,里面有atrc.so,cook.so,drvc.so,sipr.so 和 essential-adm64-20061203这个文件夹。

我也不清楚是不是已经装了需要的解码器,也不清楚为什么一直报错误,怎么装解码器,求求高手帮帮我吧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译