totem 播放任何视频,有声音没图像

Totem,mplayer,sopcast,realplayer,bmp
回复
tocer
帖子: 24
注册时间: 2007-04-24 9:02
送出感谢: 0
接收感谢: 0

totem 播放任何视频,有声音没图像

#1

帖子 tocer » 2007-07-25 11:20

7。04刚安装的时候正常,后来装了一些软件,等用的时候,发现有声音没图像,重装了totem 也不成。后来运行gstreamer-properties,发现把视频输出设为xwindow(无xv)就可以了,设为xwindow(X11/XShm/Xv),就没有图像,测试也通不过。用 xvinfo 命令查看,本显卡 ati9200se支持xv。搞了很长时间,一直搞不定。请高手帮忙看看。谢谢
头像
lxyscience
帖子: 251
注册时间: 2007-07-11 17:19
送出感谢: 0
接收感谢: 0

#2

帖子 lxyscience » 2007-07-25 15:41

下面的全装一遍,不信它没有声音和图像!
sudo apt-get install audacious audacious-plugins audacious-plugins-extra libdvdcss2 libdvdnav4 libdvdplay0 libdvdread3 w32codecs libxine-extracodecs gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

sudo apt-get install gstreamer0.8-plugins
sudo apt-get install gstreamer0.8-lame
sudo apt-get install gstreamer0.8-ffmpeg
sudo apt-get install w32codecs
sudo apt-get install libdivx4linux
sudo apt-get install lame
sudo apt-get install sox
sudo apt-get install ffmpeg
sudo apt-get install mjpegtools
sudo apt-get install vorbis-tools
gst-register-0.8
tocer
帖子: 24
注册时间: 2007-04-24 9:02
送出感谢: 0
接收感谢: 0

#3

帖子 tocer » 2007-07-25 22:27

我去试试看,先谢谢了
tocer
帖子: 24
注册时间: 2007-04-24 9:02
送出感谢: 0
接收感谢: 0

#4

帖子 tocer » 2007-07-27 11:16

出现错误:
现在没有可用的软件包 libdvdcss2,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 libdvdcss2 还没有可供安装的候选者

另外,能不能告诉我,到底什么原因早成了这个现象。以后再出问题,我也能自己解决。谢谢了
wangsen
帖子: 346
注册时间: 2006-11-04 22:16
送出感谢: 0
接收感谢: 0

#5

帖子 wangsen » 2007-07-29 21:38

源的问题 换个好点的源。我以前在学校用教育网的源经常碰到这个问题。在家用CN99源就没有问题。
wjjleopard
帖子: 27
注册时间: 2007-06-25 2:13
送出感谢: 0
接收感谢: 0

#6

帖子 wjjleopard » 2007-08-10 22:13

这些包我全装了,图像也还是没有
后来把他们全部删除了,只装了w32codecs,再就是把xine改了下,就好了
回复

回到 “影音多媒体”