当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]mplayer 中文字幕显示不正常
帖子发表于 : 2007-08-06 22:51 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
按照置顶和精华贴的方法,装了mplayer配置了中文字幕,可是显示一直有问题,如图。
请教各位如何解决? 谢谢!!!


附件:
Screenshot-MPlayer - Video-1.png
Screenshot-MPlayer - Video-1.png [ 172.02 KiB | 被浏览 955 次 ]

Screenshot-MPlayer - Video.png
Screenshot-MPlayer - Video.png [ 231.86 KiB | 被浏览 926 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-07 16:37 

注册: 2007-08-05 18:43
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我今天下午刚刚解决了这个问题,方法如下:

先找个字体考到你的本家文件下,可以从windows那边考一个simsun.ttc,然后修改配置文件,配置文件在

1、~/.mplayer/config文件中:
font=/homer/~/simsun.ttc
subcp=cp936
2、修改~/.mplayer/gui.conf文件中:
sub_auto_load = "yes"
sub_unicode = "yes"
sub_pos = "99"
sub_overlap = "no"
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/homer/~/simsun.ttc"
font_encoding = "unicode"

字幕的大小可以通过font_text_scale 调整,3是比较合适的。
其中simsun.ttc是从windows中拷贝的宋体文件名,用其他的中文字体也可以


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-07 16:45 

注册: 2005-10-28 17:40
帖子: 172
送出感谢: 0 次
接收感谢: 0 次
最新的svn版本里有font和subfont两个参数了。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-07 17:21 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
问题解决了,2楼说的第二步和我做的一样。只是第一步,我没有把字体copy过去,只是做了一个链接到了一个字体文件。无法显示正确字幕的问题是由于那个字体文件的权限问题,改了权限就好了。谢谢各位回复。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-07 17:30 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
还有个问题,如何能把字幕调到屏幕最下端。把sub_pos 设到100只能把字幕调到图像的最下端。看片的时候一般上下两端都是黑框,如果能把字幕放到黑框里最好了,这样可以不影响观看。我试过sub_pos = "110“ 到”120“不起作用。谁知道怎么解决么?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-15 15:41 

注册: 2007-01-13 20:15
帖子: 153
送出感谢: 0 次
接收感谢: 0 次
pferd 写道:
还有个问题,如何能把字幕调到屏幕最下端。把sub_pos 设到100只能把字幕调到图像的最下端。看片的时候一般上下两端都是黑框,如果能把字幕放到黑框里最好了,这样可以不影响观看。我试过sub_pos = "110“ 到”120“不起作用。谁知道怎么解决么?

编辑~/.mplayer/config文件,加入下面的:

代码:
vf=expand=:::::4/3:2 #如果是16:9的影片,字幕可以放在下面的黑框中


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-15 19:21 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
cdacl 写道:
pferd 写道:

代码:
vf=expand=:::::4/3:2 #如果是16:9的影片,字幕可以放在下面的黑框中

谢谢,好使 !


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-09 21:46 

注册: 2008-06-06 16:11
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
晕啊,怎么我按照2楼设置,还是解决不了?
我用的字体是/usr/share/fonts/truetype/wqy/wqy-zenhei.ttf


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-09 21:46 

注册: 2008-06-06 16:11
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
linhao315 写道:
晕啊,怎么我按照2楼设置,还是解决不了?
我用的字体是/usr/share/fonts/truetype/wqy/wqy-zenhei.ttf


我用的是Ubuntu8.04


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译