mplayer播放视频的时候总是一闪一闪,有什么解决办法呢?

Totem,mplayer,sopcast,realplayer,bmp
回复
头像
akaleus
帖子: 60
注册时间: 2005-11-10 10:13
送出感谢: 0
接收感谢: 0
联系:

mplayer播放视频的时候总是一闪一闪,有什么解决办法呢?

#1

帖子 akaleus » 2007-08-10 23:05

选XV输出的时候会一闪一闪,非常不爽.
选X11输出倒是一切正常,但是貌似X11(XImage/Shm)输出只能看小窗口,无法硬件全屏缩放.
其他一些输出模式都可以用,但是cpu占用率都有点高(播放普通XivD电影时占20%),
由于是笔记本,cpu占用率的高低直接影响了电池待机时间的


不知道各位有没有遇到过这种问题.

XV一直都最好用的输出模式了,系统资源占用相当地.不过貌似有些问题.开了xgl就不能用xv做输出.


P.S.用totem播放也一直都会闪屏幕.

机器,IBM T43, ati的显卡,
硬件驱动完全正常.
应该没什么问题吧,
zanne
帖子: 69
注册时间: 2007-10-04 0:22
送出感谢: 0
接收感谢: 0

#2

帖子 zanne » 2007-10-27 1:23

我也一样,这个问题非常讨厌,包括最新的 ati 8.42 ,无需xgl,还是这个样子,只能x11
头像
command
帖子: 306
注册时间: 2007-10-14 0:50
来自: GUCAS
送出感谢: 0
接收感谢: 1 次

#3

帖子 command » 2008-01-12 20:28

我的和lz的情况完全一样,没办法解决。
ildg
帖子: 438
注册时间: 2007-11-26 13:38
送出感谢: 0
接收感谢: 0

Re: mplayer播放视频的时候总是一闪一闪,有什么解决办法呢?

#4

帖子 ildg » 2008-01-13 10:08

akaleus 写了:选XV输出的时候会一闪一闪,非常不爽.
选X11输出倒是一切正常,但是貌似X11(XImage/Shm)输出只能看小窗口,无法硬件全屏缩放.
其他一些输出模式都可以用,但是cpu占用率都有点高(播放普通XivD电影时占20%),
由于是笔记本,cpu占用率的高低直接影响了电池待机时间的


不知道各位有没有遇到过这种问题.

XV一直都最好用的输出模式了,系统资源占用相当地.不过貌似有些问题.开了xgl就不能用xv做输出.


P.S.用totem播放也一直都会闪屏幕.

机器,IBM T43, ati的显卡,
硬件驱动完全正常.
应该没什么问题吧,


最新的ati驱动里面本来就有这个问题,
根据官方描述(https://a248.e.akamai.net/f/674/9206/0/ ... tml#183417):

# Diagonal tearing may be noticed when playing a video file using a video player that utilizes the XVideo extension
# Video playback may look blocky when playing a video file using a video player that utilizes the XVideo extension
# Video Playback may display wrong colors and additional shadow images when cropping or expanding a video file using a video player that utilizes the XVideo extension

它上面说的用xv时可能碰到的三个问题我都存在:
播放视频时图像延对角线方向撕裂;
播放不流畅;
颜色失真(我这里播放rm、rmvb的时候颜色失真)。

我的本本用的是ati x1300 64兆的显卡,
ati8.34.8的驱动播放时没有这些问题,
从8.34.8以后开始这些问题就出现了。
我现在用的是比较旧的linux,因为8.34.8的驱动不能装在新的内核上。。。

对ati已经失望了,
虽然几乎也是每个月出一个新版本,
但是每次的新版本几乎都没有任何新的东西可言,
连曾经没有的问题现在居然都出现了,
无话可说了。
weaker
帖子: 50
注册时间: 2007-05-06 21:34
送出感谢: 0
接收感谢: 0

#5

帖子 weaker » 2008-03-11 10:10

我刚刚换了ati 2600xt ,楼主的问题也出现了,也是选x11解决,但是像系统自带的播放器那样没有选项的怎么办呢? ati驱动真烂阿,埃,不过显卡还是不错的。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2008-03-11 11:09

都不看我的帖子的么?8.3之后要改xorg.conf,关闭过时的video overlay,启动新的texturevideo。
compiz下开启xv会闪烁,mplayer需要打补丁才可以。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
weaker
帖子: 50
注册时间: 2007-05-06 21:34
送出感谢: 0
接收感谢: 0

#7

帖子 weaker » 2008-03-11 12:16

我使用compiz fusion ,在smplayer用x11,可以全屏,感觉没问题,不管mplayer了,它x11不能全屏。
楼上的高手,用了你的方法是否可以使totem-xine也不闪,是的话我就试一下。
头像
IdeaLee
帖子: 90
注册时间: 2006-01-29 9:29
送出感谢: 0
接收感谢: 0

#8

帖子 IdeaLee » 2008-03-28 0:48

Mplayer 的 vo 用 x11 时是可以放大的,只是需要自己修改配置文件,在 ~/.mplayer/config 中加上一行:
zoom=yes

就可以了。
在现实面前,当然是理想错了……
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 zhuqin_83 » 2008-03-28 1:58

x11是最垃圾的方式,除非你的显卡不支持xv才不得不用。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
biogerm
帖子: 104
注册时间: 2007-10-22 4:40
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 biogerm » 2008-05-02 10:10

zhuqin_83 写了:都不看我的帖子的么?8.3之后要改xorg.conf,关闭过时的video overlay,启动新的texturevideo。
compiz下开启xv会闪烁,mplayer需要打补丁才可以。



texturevideo是什么??替代video overlay吗?为什么我搜了论坛搜texturevideo关键字只有一条结果还是这个帖子。。。。
ubuntu taster =D
头像
yang_hui1986527
帖子: 888
注册时间: 2006-03-04 23:10
来自: 江西高安
送出感谢: 0
接收感谢: 2 次
联系:

#11

帖子 yang_hui1986527 » 2008-05-03 12:35

QQ:273247606
EMAIL:yanghui1986527@gmail.com
gethoot
帖子: 6
注册时间: 2008-07-15 0:11
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 gethoot » 2008-07-15 0:13

ati的显卡共有的问题,玩Linux最好就不要用ATI的显卡,真的很麻烦的,主要还是驱动的问题。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#13

帖子 zhuqin_83 » 2008-07-15 0:25

ati的驱动目前看来已经不错了,尤其是开源驱动,做什么都很好。随着amd文档的逐步开放,最新的显卡也会在第一时间得到支持,xf86-video-ati-git已经开始支持R700了。反观nvidia,到现在还没有开源的意思,可以预见到未来linux平台下两者的受欢迎程度。目光短浅的总是会被淘汰的。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
Rainkero
帖子: 72
注册时间: 2006-06-23 0:50
来自: 重庆
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 Rainkero » 2008-07-25 11:38

不知道什么时候Ati的新驱动才能解决这个问题,总不能一直用V11吧
回复

回到 “影音多媒体”