当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]集成显卡重装驱动后mplayer出问题!!!
帖子发表于 : 2007-08-20 23:20 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
我的本本是INTEL的G950集成显卡,升级驱动后有了想要的1280*800分辨率,但是看不了电影了,不管用什么播放器都是一闪而过自动关闭程序,怎么办啊,大家帮下,在线等答案!!!
谢谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-21 0:21 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
终端里面打开播放器,看看有什么出错信息


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-21 12:22 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
nobrain 写道:
终端里面打开播放器,看看有什么出错信息

我执行后如下提示:
richard@richard-laptop:/media/sda7/电影$ mplayer /media/sda7/电影/1.rmvb
MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) M CPU 430 @ 1.73GHz (Family: 6, Model: 14, Stepping: 12)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /media/sda7/电影/1.rmvb.
REAL file format detected.
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
Stream mimetype: logical-fileinfo
VIDEO: [RV40] 528x300 24bpp 29.000 fps 0.0 kbps ( 0.0 kbyte/s)
Clip info:
name: Oodishon.(Audition).-.Takashi.Miike.(eng.sub)
author: ������԰��HelloBoy�����
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [realvid] RealVideo decoder
Selected video codec: [rv3040] vfm: realvid (Linux RealPlayer 10 RV30/40 decoder)
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 96.5 kbit/6.84% (ratio: 12058->176400)
Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 528 x 300 (preferred colorspace: Planar I420)
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is 1.76:1 - prescaling to correct movie aspect.
VO: [xv] 528x300 => 528x300 Planar I420
X11 error: BadAlloc (insufficient resources for operation)?,?% 0 0


MPlayer interrupted by signal 6 in module: vo_check_events
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
它说三种可能是吧?第一,MPLAYER CODE中的bug,第二显卡驱动问题,第三GCC 版本问题是吧。
望高手指点一二


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-21 12:25 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
在线等答案~~~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-21 14:40 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
:em87


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-21 16:14 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
mplayer -vo help
选一个 video output driver
比方说 x11
mplayer -vo x11 your_video_clip
没问题就写到mplayer的配置文件里面去。


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-21 17:38 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
nobrain 写道:
mplayer -vo help
选一个 video output driver
比方说 x11
mplayer -vo x11 your_video_clip
没问题就写到mplayer的配置文件里面去。


我在终端下执行上面那条语句,mplayer可以打开,能够播放,但是我按网上其他帖子的说法在~/.mplayer/config中加入
vo=x11后还是不能执行啊,怎么回事啊,谢谢


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-21 17:46 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
打开Mplayer在首选项里把VIDEO选成X11可以播了,但不能全屏播放, :em06
真是旧的不去新的不来啊 :em04


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-08-21 17:47 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
很奇怪,因为这两个步骤作用是相同的.
还有,你把gmplayer和mplayer混淆了?
gmplayer在首选项里改就可以了,还有gl你也可以试试.


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-08-21 17:59 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
ct 写道:
很奇怪,因为这两个步骤作用是相同的.
还有,你把gmplayer和mplayer混淆了?
gmplayer在首选项里改就可以了,还有gl你也可以试试.

我没装gmplayer啊,mplayer不是也有首选项吗?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-08-21 18:11 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
mplayer指的是命令行版本的播放器,自带的图形前端就是gmplayer


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-08-21 23:10 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
iamgreat 写道:
打开Mplayer在首选项里把VIDEO选成X11可以播了,但不能全屏播放, :em06
真是旧的不去新的不来啊 :em04

mplayer的配置文件里,加上 zoom=yes


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-08-22 0:08 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
ct 写道:
mplayer指的是命令行版本的播放器,自带的图形前端就是gmplayer

谢谢,长了知识,呵呵


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-08-22 0:24 
头像

注册: 2007-08-07 13:42
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
nobrain 写道:
iamgreat 写道:
打开Mplayer在首选项里把VIDEO选成X11可以播了,但不能全屏播放, :em06
真是旧的不去新的不来啊 :em04

mplayer的配置文件里,加上 zoom=yes


加上以后可以全屏看了,但是现在明显画面有卡的感觉,看起来很不舒服 :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译