当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [报到]刚刚来的新人,关于MPLAYER想问一下各位高手。
帖子发表于 : 2007-09-09 1:37 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
才装上的UBUNTU系统,试了一下,影音文件大部分不能放,
搜索了半天,说是用MPLAYER+W32CODESC
我都装上了,可是MPLAYER好像什么视频文件都打不开啊(不止是RMVB,一些AVI什么的,自带的播放器都可以打开的用MPLAYER也不行),全部报一个错,

error opeining/initializing the selected video_out(-vo) device

本版的那个帖子也看了,照做了,好像还是不行,
请问还有什么原因啊?

另外,音频文件的文件信息都是乱码来着的。
PS,还要多学习,有可能本版里边有解答,我没有细看,如果有的话,请给个链接,如果没有的话,还烦请给个解答,
谢谢,


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-09 10:32 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
自己搞定一部分,
把X11改成了OPENGL
可以放AVI等一些格式,
但RMVB还是放不了,
继续等待。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-09 12:03 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
放WMV的时候有时候会报错,但还是可以播放,
放RMVB的时候开始会报很多错,
之后可以放出声音,视频没有。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-09 12:03 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
坛子里边没有人帮忙吗??


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-09-09 12:10 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
不对,RMVB是连声音都没有。。。 :cry:
直接报四个错,点完了就把MPLAYER关掉了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-09-09 12:36 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
不会是装的7.10吧,注意你的w32codecs版本,最好用源里面的


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-09-09 13:37 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
终于有人了
7.10是什么?? :D
另外,W32CODECS在源里边能下到么,
我是到MPLAYER的网站 上下的,
下下来的东西叫
essential-20061022.tar.bz2
解压到
usr/lib/win32下面去了
这个WIN32目录原来没有,
是我自己建的,不知道是这个的问题吗?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-09-09 13:43 

注册: 2007-06-06 14:24
帖子: 196
送出感谢: 0 次
接收感谢: 0 次
自己搜索吧,要学的东西多着呢,这种问题,最好不好发帖问


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-09-09 13:49 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
一点点的解决,
已经可以播放了,
原来解压到WIN32下,它自己建 了一个叫ESSENTIAL...的文件夹,把东西都放那个里边了,
拷出来就没事了。
继续下一个问题
现在可以播RMVB文件了,但是一个是进度条不能拖,
一个是好像非常卡?
看最终幻想里边的动作戏,全部是一卡一卡的/?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-09-09 13:55 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
回八楼的,我不是一不会就跑上来问的,
很多问题也是自己一点一点在解决,
碰到搜不到的上来问问,
论坛本来就是交流的地方,我现在刚刚入门 ,所以把它当学习的地方
希望baidu,google帮不到的地方有人可以帮到我,
你可以认为我的问题很弱智,也可以不回答...
谁也不是一开始就会的,


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-09-09 15:01 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
moonstrike 写道:
自己搞定一部分,
把X11改成了OPENGL
可以放AVI等一些格式,
但RMVB还是放不了,
继续等待。

X11/opengl改成X11/xv看看,比较喜欢你的名字moonstrike


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-09-09 17:46 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
呵呵,谢谢楼上的了,
我是看了本版 的一个贴子
用 mplaer播放 rmvb电影
然后去改这个格式的,先是改成X11/XV是放不了的,
后来一个一个的试,改成OPENGL的时候可以出现一个都是格子的模糊的图像
改成OPENGL MULTIPL..... 的时候可以出现正常的图像,
应该是显卡的原因吧。。
现在基本上都可以播放了,
不过真的是蛮卡的,特别是RMVB格式的最为明显,
其它的,比如WMV的,NOMAL的时候还好,FULL SCREEN的时候非常的卡,我试了试用UBUNTU自带的播放器,比MPLAYER流畅。。。。
不知道你们有此种现像没有。
___________________________________________________________
名字取自泰兰德。语风的
prepare to be moonstrunk
然后自己生造的。。呵呵,先笑。。。
:oops:


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-09-09 17:56 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
我的是用那个opengl非常卡,xv就没有问题,nv5200


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-09-09 18:01 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
刚刚改的时候漏掉了一个,
X11(XIMAGE/SHM)
改成这个的时候好像不卡了,不过点FULL SCREEN的时候只是播放器变大了,图像还是那么一点点???一半的时候图像也是那么大,好像怎么搞图像大小都不变的。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-09-09 18:02 

注册: 2007-09-09 1:23
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我是NV8500的显卡。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译