totem-xine启动后自动关闭问题(可能是硬件不支持而无法解决)

Totem,mplayer,sopcast,realplayer,bmp
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

totem-xine启动后自动关闭问题(可能是硬件不支持而无法解决)

#1

帖子 arky » 2005-12-17 17:51

我想播放RMVB。
我已经sudo apt-get install beep-media-player totem-xine w32codecs gstreamer0.8-plugins了。提示如下:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
beep-media-player 已经是最新的版本了。
totem-xine 已经是最新的版本了。
w32codecs 已经是最新的版本了。
gstreamer0.8-plugins 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件未被升级。
但totem-xine启动后自动关闭!
请问如何解决?
上次由 arky 在 2005-12-19 20:23,总共编辑 1 次。
头像
oneleaf
论坛管理员
帖子: 10236
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#2

帖子 oneleaf » 2005-12-17 19:04

终端启动一下,看看错误提示。
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#3

帖子 arky » 2005-12-17 19:34

终端启动提示:
~$ totem

(totem:8239): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(totem:8239): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 80 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
然后TOTEM启动,闪了一下就不见了。
头像
oneleaf
论坛管理员
帖子: 10236
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#4

帖子 oneleaf » 2005-12-17 19:38

看看sudo下试试

或者尝试删除:

sudo rm -rf .gnome .nautilus .gnome2
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#5

帖子 arky » 2005-12-17 19:45

$ sudo rm -rf .gnome .nautilus .gnome2
Password:
~$ totem

(totem:8413): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(totem:8413): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 80 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)


还是一闪不见了。
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#6

帖子 arky » 2005-12-17 19:47

~$ sudo totem

(totem:8476): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(totem:8476): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

** (totem:8476): WARNING **: Failed to connect to the D-BUS daemon: No reply within specified time
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 80 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
也是一闪不见
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#7

帖子 arky » 2005-12-17 19:54

请问:gstreamer0.8-plugins是什么东东
头像
oneleaf
论坛管理员
帖子: 10236
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#8

帖子 oneleaf » 2005-12-17 21:42

找了一下,没有什么好主意。彻底删除后重新安装试试。
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#9

帖子 arky » 2005-12-18 13:53

我在新立得彻底删除TOTEM-XINE后,再在新立得重装TOTEM-XINE。
过程还算顺利,只是结果仍然同上,TOTEM启动后自动关闭。

这会否和硬件有关,我的U是K6-2,慢了点。

不过音频没问题的。

再想想办法,就算重装我也是愿意的。
头像
oneleaf
论坛管理员
帖子: 10236
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#10

帖子 oneleaf » 2005-12-18 20:55

arky 写了:我在新立得彻底删除TOTEM-XINE后,再在新立得重装TOTEM-XINE。
过程还算顺利,只是结果仍然同上,TOTEM启动后自动关闭。

这会否和硬件有关,我的U是K6-2,慢了点。

不过音频没问题的。

再想想办法,就算重装我也是愿意的。
把scim全部删除看看?
bobyang
帖子: 120
注册时间: 2005-11-26 19:01
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 bobyang » 2005-12-19 3:13

装一个realplayer播放不好吗?
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#12

帖子 arky » 2005-12-19 10:20

也是一个方法,可以试一下,不过TOTEM没解决始终不爽啊
arky
帖子: 18
注册时间: 2005-12-13 15:55
送出感谢: 0
接收感谢: 0

#13

帖子 arky » 2005-12-19 10:24

把scim全部删除看看?[/quote]


我的是FCITX,如果需要的话我把它删除试试看
头像
oneleaf
论坛管理员
帖子: 10236
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#14

帖子 oneleaf » 2005-12-19 10:54

arky 写了:我的是FCITX,如果需要的话我把它删除试试看
那就不用了,真是奇怪的问题。 去: http://www.ubuntuforums.org/ 问问?
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 Beetle » 2005-12-19 16:47

我也有这种情况的!
后来发现我这种情况只是在不插网线的情况下会出现,于是我把网卡禁用了,结果能放了,不知道是为什么?LZ试一下
回复

回到 “影音多媒体”