当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装mplayer遇到问题了。!帮帮忙,在论坛搜不到!
帖子发表于 : 2007-10-04 12:10 

注册: 2006-09-10 11:48
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
安装mplayer 我按照wiki的说明,http://wiki.ubuntu.org.cn/%E5%AE%89%E8%A3%85MPlayer
在替换的那行 我本来就是vo=xv 所以没有替换,不过打开avi格式的时候。提示“Error opening/initializing the selected video_out(-vo) device”这是一个问题,下面是我要装解码的时候,遇到另一个问题。
由于没有找到能 $ sudo apt-get install w32codecs 的源,所以我自己去下载了一个
我下载了amd64的解码,因为我用的是7.04的64位版本。

引用:
Put the files contained in this archive in a directory where MPlayer will find
them. The default directory is /usr/local/lib/codecs/ ($prefix/lib/codecs/) if
you are compiling from source, but you can change that value by passing the
'--with-codecsdir' option to './configure'.

If you use a prebuilt MPlayer package it will most likely be /usr/lib/codecs,
see the documentation of your package for details.

In the past /usr/local/lib/win32 or /usr/lib/win32 was the default directory,
some packages as well as a few other Unix players like xine and avifile still
use it, refer to their documentation for further details.

它说目录是这么装,我就用了新的目录。没放在win32里面。不过这个时候,希望totem能播放rmvb,但还是不能。

我要处理的是:
1。mplayer的错误处理。
2。totem的codecs解码这么放能用吗?暂时不能用的。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-04 12:38 

注册: 2006-09-10 11:48
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
哦。第一个问题,后来在baidu找到。
引用:
没有办法播放视频。其实解决的方法很简单: 打开MPLAYER。 右击 选择“preferences"->"Video"选项卡->在"Availabe Drivers"中选择“X11

不过现在的问题是如何播放rmvb呢?我想两个播放器,至少有一个能播放才行阿。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-04 12:43 

注册: 2006-01-10 19:09
帖子: 1334
送出感谢: 0 次
接收感谢: 0 次
你还是那样子就能放rmvb了呀

mplayer -vo x11 a.rmvb

不过64位的我就不知道 w32codecs里面有没有 rm的解码了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-04 13:05 

注册: 2006-09-10 11:48
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
mplayer播放rmvb的时候,只有声音。
不过totem 播放就
引用:
The playback of this movie requires the following decoders which are not installed:

RealAudio 解码器
RealVideo 4.0 解码器

我参考了一下http://forum.ubuntu.org.cn/viewtopic.php?t=53077&postdays=0&postorder=asc&start=0
还是没能解决。希望再帮忙!!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-04 13:20 

注册: 2006-09-10 11:48
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
是不是我自己下载的tgz安装时候不对?
我是解压了,cp到它说的默认目录./usr/local/lib/codecs/
现在就是mplayer播放rmvb没有图像,只有声音.而totem就是提示上面的那个错误.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-05 12:34 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
kingf 写道:
哦。第一个问题,后来在baidu找到。
引用:
没有办法播放视频。其实解决的方法很简单: 打开MPLAYER。 右击 选择“preferences"->"Video"选项卡->在"Availabe Drivers"中选择“X11

不过现在的问题是如何播放rmvb呢?我想两个播放器,至少有一个能播放才行阿。


太棒了,我成功了,搞了一天了,哎!谢谢了!!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-05 12:40 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
可还是有疑问啊!~ 播放时声音和图象不是同步的啊!怎么办呢?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-05 13:09 

注册: 2006-09-10 11:48
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
Crazier 写道:
可还是有疑问啊!~ 播放时声音和图象不是同步的啊!怎么办呢?


我自己播放,没有不同步的。就是不能播放rmvb。兄弟能指导一下吗?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-09 9:05 
头像

注册: 2007-05-26 11:50
帖子: 156
送出感谢: 0 次
接收感谢: 0 次
按照那段E文来看并没有说自己定义的目录totem能找到把,不是说要参考它自己的文档么?
很可能是你这个位置totem找不到。


_________________
---------------------------------------------------------------------
我终身奋斗的最低革命纲领:农妇__山泉__有点儿田


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-14 22:28 

注册: 2006-09-10 11:48
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
后来,我重新装w32codecs的时候,把它放到win32文件夹,就好了。
不明白为什么它说的默认地址就是不行呢?
算了。能用就先不管了。
暂时还是totem没有能播放rmvb


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译