当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]mplayer字幕播放问题
帖子发表于 : 2007-10-22 9:39 

注册: 2007-06-06 15:26
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
mplayer视频播放正常,但不能自动载入字幕,尝试手动载入,结果弹出一个对话框,内容为gnome_screensaver_control(),请问如何解决?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-22 9:58 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
更具体点。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-22 10:09 

注册: 2007-06-06 15:26
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
我的系统是ubuntu7.10,播放的是一个mkv文件,在相同文件夹内有一个同名srt字幕。播放视频正常,就是不会自动加载字幕。于是通过 右键--> 打开--> 载入字幕 的方式手动加载,一旦加载,视频播放立刻自动停止,且弹出一个error(错误)框,上面显示gnome_screensaver_control()


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-22 10:16 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
mkv文件,也使用srt字幕?
那不知道了。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-22 10:29 

注册: 2007-06-06 15:26
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
但我播放avi文件载入srt字幕也出同样的错。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-22 10:31 
头像

注册: 2007-06-02 14:56
帖子: 547
送出感谢: 0 次
接收感谢: 0 次
mkv的字幕不是内嵌的吗。可能和mplayer的设置有关系,是不是启用“禁止屏保”了?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-22 18:15 

注册: 2007-06-06 15:26
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
十分感谢楼上的提示,不过我不知道如何禁用“禁止屏保”,所以我在./.mplayer/gui.conf中将stopxscreensaver 改为 "no",果然不弹出这个框了。但是这样有可能播放时出现屏保。
还有一个问题:字幕不能自动加载,每次都要手动加载,怎样解决?(我没有勾选disable subtitle autoloading)


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-30 10:38 

注册: 2007-10-29 17:10
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我也出現相同的訊息
也依照您的方法解決了...多謝囉...
不過似乎不是很多人出現這個情況...為什麼會這樣呢???呵


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-30 14:21 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
感谢提示

也是这毛病,解决了

谢谢

:D


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-31 21:36 

注册: 2006-06-26 17:14
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
楼上的,怎么解决阿?我是英文界面,看中文都是乱码 ,请问怎么设置?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-01 0:27 

注册: 2006-09-23 8:39
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
为何不用smplayer


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-01 1:17 
头像

注册: 2005-05-30 12:16
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
Helium3 写道:
为何不用smplayer


试了一下,确实不错,而且有中文界面


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-16 23:09 
头像

注册: 2007-05-13 19:52
帖子: 94
地址: Soochow, China
送出感谢: 0 次
接收感谢: 0 次
我的也有相同的问题.手动加载字幕立刻退出....都没看清是什么错误....


_________________
静下心,你能做到一切.

UBUNTU 8.04
AMD 速龙 3000+
DDR II 512*2


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-11-17 9:34 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
不知诸位兄弟字体设置了没有。

$ln -s ~/.fonts/name_of_font ~/.mplayer/subfont.ttf

乱码的话,是编码问题。字幕成一条线的话,也可能是字体问题。


页首
 用户资料  
 
15 楼 
 文章标题 : 我也遇到了
帖子发表于 : 2007-11-25 17:48 

注册: 2007-11-25 17:46
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
跟楼主一模一样,郁闷阿


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译