realplay 播放rmvb 比mplayer 还卡[已解决]

Totem,mplayer,sopcast,realplayer,bmp
回复
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

realplay 播放rmvb 比mplayer 还卡[已解决]

#1

帖子 INUYASHA » 2007-10-29 15:44

realplay 播放rmvb 比mplayer 还卡
而且卡的惨不忍睹的说

而且和mplayer(smplayer)一样有闪烁的现象(全屏时更明显)

似乎播放影片的闪烁现象于播放器没关系

现在认为是驱动的问题

我的显卡是intel 915的

mplayer的video 选x11 其他要么不输出视频信号
要么就卡的要死

求大家帮帮忙的说
上次由 INUYASHA 在 2007-11-04 1:06,总共编辑 1 次。
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#2

帖子 glade » 2007-10-29 15:57

以前的方法是
安装alsa-oss
然后再用 aoss realplay命令启动就不卡了
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#3

帖子 INUYASHA » 2007-10-29 16:28

glade 写了:以前的方法是
安装alsa-oss
然后再用 aoss realplay命令启动就不卡了
的确 不卡了

但是 全屏是闪烁现象很严重的说(mplayer 稍好一点)

屏幕好像从上往下刷的一样 一帧一帧 不好形容的说
也不好截图的说

总觉得是video的驱动问题

另:
在安装gxin是提示
video_out_xv: No adaptors found.
You can improve performance by installing an X11
Driver that supports the Xv protocol extension.
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#4

帖子 glade » 2007-10-29 22:43

输出可以选择openGL
众人拾柴火焰高,齐心灌水漫金山
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#5

帖子 INUYASHA » 2007-10-29 23:35

glade 写了:输出可以选择openGL
mplayer里没这选现的说
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#6

帖子 glade » 2007-10-29 23:44

没有吗,就是那个gl X11 openGL.....
众人拾柴火焰高,齐心灌水漫金山
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#7

帖子 INUYASHA » 2007-10-30 22:18

郁闷试了所有的视频输出设备
除了x11 外其他更不行

但是用x11 屏幕还是闪烁

郁闷中.......................
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#8

帖子 glade » 2007-11-01 10:30

开了3D了吗?关闭一下看看
众人拾柴火焰高,齐心灌水漫金山
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#9

帖子 INUYASHA » 2007-11-01 16:58

glade 写了:开了3D了吗?关闭一下看看
不懂的说 没玩过3d 不知哪里设置?
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#10

帖子 jarryson » 2007-11-01 19:18

ati的显卡驱动是这样的。貌似要怎么弄一下,才能支持xv输出。不知道nv的如何。反正ati开源驱动这点一点问题都没有。

x11好像全靠cpu解码的。xv才用到显卡。。
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#11

帖子 INUYASHA » 2007-11-01 23:53

jarryson 写了:x11好像全靠cpu解码的。xv才用到显卡。。
怪不得图像处理成这样的说

不过我是Inetl的集成显卡的

不知又如何处理呢
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#12

帖子 INUYASHA » 2007-11-02 15:53

我的显卡:集成Intel GMA900芯片
显示器:LCD 14.1宽屏

/ect/X11/xorg.conf文件内容

代码: 全选

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizEdgeScroll"	"0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"stylus"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"eraser"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"cursor"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"vesa"
	BusID		"PCI:0:2:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-96
	VertRefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Modes		"1920x1440"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

# Uncomment if you have a wacom tablet
#	InputDevice     "stylus"	"SendCoreEvents"
#	InputDevice     "cursor"	"SendCoreEvents"
#	InputDevice     "eraser"	"SendCoreEvents"
	InputDevice	"Synaptics Touchpad"
EndSection

# 打开xorg.conf中的混色开关
Section "Extensions"
    Option  "Composite"  "Enable"
EndSection
头像
INUYASHA
帖子: 366
注册时间: 2007-03-16 15:42
送出感谢: 0
接收感谢: 0

#13

帖子 INUYASHA » 2007-11-04 1:05

meet26
帖子: 32
注册时间: 2007-11-03 8:30
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 meet26 » 2007-11-04 13:36

我装了kmplayer mplayer smplayer 等软件 可以是rmvb格式的视频还是不能放么,为什么呢?请问该装什么软件呢?到哪里安装? 我上面的软件是在“应用程序-添加删除-Sound&video里面安装的
starboys
帖子: 132
注册时间: 2007-06-30 20:33
送出感谢: 0
接收感谢: 0

#15

帖子 starboys » 2007-11-04 13:50

meet26 写了:我装了kmplayer mplayer smplayer 等软件 可以是rmvb格式的视频还是不能放么,为什么呢?请问该装什么软件呢?到哪里安装? 我上面的软件是在“应用程序-添加删除-Sound&video里面安装的
装解码器w32codecs,地址论坛上有。这个好像涉及到版权的问题所以源里现在一般都没有。地址在这个帖子里:
viewtopic.php?t=82646
回复

回到 “影音多媒体”