当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 下载了audacious1.4.4.tar.gz无法安装,救命啊
帖子发表于 : 2007-12-19 12:03 

注册: 2007-09-17 0:03
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
下载了audacious1.4.4.tar.gz无法安装,./configure时提示缺少gtk+ libglade libmcs libmowgli
分别下了这四个包,安装gtk+时又无法安装,需要glib atk pango cairo四个包,分别下载后又无法安装,不是make有问题就是make install有问题,搞一天了,还是搞不定,快崩溃了,高手帮帮忙啊
还是有什么deb包可以直接安装呢
我原来是1.2.2版本,无法和歌词插件兼容,所以才要升级的
我是7.04ubuntu


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 下载了audacious1.4.4.tar.gz无法安装,救命啊
帖子发表于 : 2007-12-19 18:33 

注册: 2005-10-22 11:16
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
jlwoo 写道:
下载了audacious1.4.4.tar.gz无法安装,./configure时提示缺少gtk+ libglade libmcs libmowgli
分别下了这四个包,安装gtk+时又无法安装,需要glib atk pango cairo四个包,分别下载后又无法安装,不是make有问题就是make install有问题,搞一天了,还是搞不定,快崩溃了,高手帮帮忙啊
还是有什么deb包可以直接安装呢
我原来是1.2.2版本,无法和歌词插件兼容,所以才要升级的
我是7.04ubuntu


你只要在新立得里面安装对应的dev包即可。比如libglade,就安装libglade-dev即可。其他的大同小异。实在找不到dev包了再下载源代码编译安装。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-21 0:48 
头像

注册: 2007-04-15 18:46
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
引用:
有人推荐audacious,说可以支持cue播放ape,试了一下,还凑合,记录其中一些过程如下。

访问http://audacious-media-player.org/index.php?title=Downloads
下载audacious-1.4.0.tgz和audacious-plugins-1.4.0.tgz,一个是主程序,一个是官方的插件(解码器)。

下载http://www.netswarm.net/misc/audacious-mac-0.3.10.tar.gz,顾名思义是mac for audacious的插件,有了它才能搞定ape。

下载mac-3.99-u4-b5.tar.gz,有了这个才能顺利安装audacious-mac-0.3.10。

根据audacious主页上的提示和链接,先分别安装libglade、libmcs、libmowgli。
其中libmowgli我是下载源码后编译安装的,地址是http://distfiles.atheme.org/libmowgli-0.5.0.tgz
而libglade和libmcs则是直接通过源。
sudo apt-get install libglade2-dev
sudo apt-get install libmcs-dev

后来发现还需要dbus-glib,通过源搜索了一下,决定安装libdbus-glib-1-dev。
sudo apt-get install libdbus-glib-1-dev

准备工作结束后开始编译安装audacious-1.4.0、audacious-plugins-1.4.0、mac-3.99-u4-b5、audacious-mac-0.3.10,过程基本顺利。

安装结束后在控制台中执行audacious,结果提示libmowgli.so.1.0.0: cannot open shared object file: No such file or directory。
whereis了一下,发现libmowgli.so.1.0.0安静的躺在/usr/local/lib/下,又是路径问题。
把libmowgli.so.1.0.0复制一份到/usr/lib/下,此问题解决。

再次运行audacious,却又蹦出来个提示窗口,大意是没有x下可用的skin,这个容易。
首先在/usr/local/share/audacious/下面手工建立Skins目录,在它下面再建一个Default目录。

audacious的主页上提示它兼容winamp 2.x和XMMS的皮肤。
随即访问http://www.xmms.org/skins.php下一个顺眼的,将该zip包中的内容解压到刚才建好的目录,即/usr/local/share/audacious/Skins/Default/中。

至此结束,运行audacious顺利出现界面,通过cue播放ape正常。

以前从网站上copy下来的,忘了是来自哪里了。

这个方法还适用64位的pc。

如果你害怕缺什么包的话就sudo apt-get build-dep audacious.1.3.2, build-dep 会自动安装audacious缺少的包的。

如果是32位的可以考虑从源安装libmac*,而不用安装mac-3.99-u4-b5,这个比较难找到。

如果终端中执行audacious,还提示缺少什么文件,按照上面同样的方法处理就可以了。

本人在7.10 64bit下测试过,以前在32bit的系统下也是这样做的。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 下载了audacious1.4.4.tar.gz无法安装,救命啊
帖子发表于 : 2010-02-18 22:30 

注册: 2009-05-29 11:40
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
mark


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译