[问题]更新出现问题,求助。(已解决)

系统安装、升级讨论
回复
ethnicity
帖子: 8
注册时间: 2008-04-25 20:15
送出感谢: 0
接收感谢: 0
联系:

[问题]更新出现问题,求助。(已解决)

#1

帖子 ethnicity » 2008-05-03 19:54

今天更新发生错误~终端显示:
samphire@samphire-laptop:~$ sudo apt-get install -f
[sudo] password for samphire:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。
有 6 个软件包没有被完全安装或卸载。
操作完成后,会消耗掉 0B 的额外磁盘空间。
正在设置 linux-image-2.6.24-17-generic (2.6.24-17.31) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.24-17-generic
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ...
No GRUB directory found. To create a template run 'mkdir /boot/grub' first. To install grub, install it manually or try the 'grub-install' command. ### Warning, grub-install is used to change your MBR. ###

User postinst hook script [/sbin/update-grub] exited with value 1
dpkg:处理 linux-image-2.6.24-17-generic (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 linux-ubuntu-modules-2.6.24-17-generic 的配置工作不能继续:
linux-ubuntu-modules-2.6.24-17-generic 依赖于 linux-image-2.6.24-17-generic;然而:
软件包 linux-image-2.6.24-17-generic 还没有被配置。
dpkg:处理 linux-ubuntu-modules-2.6.24-17-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-image-generic 的配置工作不能继续:
linux-image-generic 依赖于 linux-image-2.6.24-17-generic;然而:
软件包 linux-image-2.6.24-17-generic 还没有被配置。
linux-image-generic 依赖于 linux-ubuntu-modules-2.6.24-17-generic;然而:
软件包 linux-ubuntu-modules-2.6.24-17-generic 还没有被配置。
dpkg:处理 linux-image-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-2.6.24-17-generic 的配置工作不能继续:
linux-restricted-modules-2.6.24-17-generic 依赖于 linux-image-2.6.24-17-generic;然而:
软件包 linux-image-2.6.24-17-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-2.6.24-17-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-generic 的配置工作不能继续:
linux-restricted-modules-generic 依赖于 linux-restricted-modules-2.6.24-17-generic;然而:
软件包 linux-restricted-modules-2.6.24-17-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-generic 的配置工作不能继续:
linux-generic 依赖于 linux-image-generic (= 2.6.24.17.19);然而:
软件包 linux-image-generic 还没有被配置。
linux-generic 依赖于 linux-restricted-modules-generic (= 2.6.24.17.19);然而:
软件包 linux-restricted-modules-generic 还没有被配置。
dpkg:处理 linux-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
linux-image-2.6.24-17-generic
linux-ubuntu-modules-2.6.24-17-generic
linux-image-generic
linux-restricted-modules-2.6.24-17-generic
linux-restricted-modules-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

本人接触UBUNTU没几天,不知道怎么解决,请高手指点迷津。
上次由 ethnicity 在 2008-05-04 16:19,总共编辑 1 次。
头像
SecretZero
帖子: 1670
注册时间: 2007-08-30 5:39
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SecretZero » 2008-05-03 19:55

可怜,重大更新还是要考虑下,

那个更新包只有65k,怎么可能完整?
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344
ethnicity
帖子: 8
注册时间: 2008-04-25 20:15
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ethnicity » 2008-05-04 12:59

请问现在我该怎么解决呢? 无论安装啥现在都显示无法完全更新或升级,就是上面那几个包出的问题。
ethnicity
帖子: 8
注册时间: 2008-04-25 20:15
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 ethnicity » 2008-05-04 16:18

解决了~ sudo mkdir /boot/grub
再 sudo apt-get install -f
回复

回到 “系统安装和升级”