当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 想问问大家,怎么解决源更新后有些软件安装不了.
帖子发表于 : 2008-05-05 8:56 

注册: 2008-04-27 11:52
帖子: 7
地址: 厦门
送出感谢: 0 次
接收感谢: 0 次
水平太菜,之前在旧的机子上装了UBUNTU7.10,并在上面建立起了uclinux的编译环境,还有skyeye模拟器.
不过那台机子实在老化严重,动不动重启.所以51买了台新的主机.
现在的问题是机子太新,所以驱动支持不好.于是装上虚拟机在windows下安装了ubuntu 7.10;
装完后安装skyeye,直接用apt-get命令安装成功;
然后下载skyeye,源码包最新版,make NO_DBCT=1后提示没有bfd库;
于是输入
sudo apt-get install binutils-dev
出现提示,大概意思这个库已经被废弃;汗。。。
于是装上ubuntu8.04,同样如上操作,一切都安装正常;
binutils-dev也装上了。但编译时出错;更汗。。。。
难道ubuntu8.04前后兼容性这么差吗??
之前我在那台旧的机子上一切安装都很正常。


说了这么多无非就是一个问题.源更新了但我还要想以前的一些软件.因为我装linux目的就是为了学习嵌入式linux开发.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-05 9:00 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
看一下你的源的版本和当前系统版本是不是一样的。。估计是版本错误了。


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-05 9:10 

注册: 2008-04-27 11:52
帖子: 7
地址: 厦门
送出感谢: 0 次
接收感谢: 0 次
是吗.起初我也是这么认为.所以我才又装了8.04最新版本.
所以装完8.04就可以正常安装binutils-dev了..当然编译出错应该是另外的问题了.
而7.10呢.我用命令
sudo apt-get update更新过了.还是不行..郁闷..


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-05 9:51 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
jijuxie321 写道:
是吗.起初我也是这么认为.所以我才又装了8.04最新版本.
所以装完8.04就可以正常安装binutils-dev了..当然编译出错应该是另外的问题了.
而7.10呢.我用命令
sudo apt-get update更新过了.还是不行..郁闷..


认真看2楼的回复
引用:
看一下你的源的版本和当前系统版本是不是一样的。。估计是版本错误了。


检查你的源和系统的版本是否一致!这和装新旧版本没关系,和apt-get update也没直接关系


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-05 9:56 

注册: 2008-04-27 11:52
帖子: 7
地址: 厦门
送出感谢: 0 次
接收感谢: 0 次
谢谢晚上回去看一下..
解决了的话回来告诉大家一声..


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译