当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]软件包Auto安装问题,请高手指点
帖子发表于 : 2008-05-13 21:34 

注册: 2008-05-13 20:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
软件包AUTO安装求助
各位朋友大家您好!我现在做分岔方面的分析,需要安装分岔分析软件包AUTO,可一直都没有安装成功过。我把我的安装方法唠叨一下,肯请朋友们指出问题所在或者把你安装成功的过程详细介绍一下,拜托了。我用的是Ubuntu 8.04,Auto文件放 /home/gaoxj3000 下
进入终端,依次执行下面命令
gunzip auto07p-0.5.tar.gz
tar xvfo auto07p-0.5.tar
ca auto/07p
./configure 配置最后出现
*******************************************************************************
It was requested that the plotting utility PLAUT04 be compiled but the proper libraries(Coin3D and SoQt or SoXt or Open Inventor and Open Inventor Xt and perhaps Motif libraries libXm) could not be found. The compilation of PLAUT04 is disabled. AUTO has been configured with support for OpenMp.
********************************************************************************
紧接着编译:make.
完后执行 bin目录下的 auto:
老提示/home/gaoxj3000/auto/07p/bin:auto: /python/interactiveBindings.py:No such file or directory.

图形界面 Plaut04 无法编译,命令行模式无法运行,具体可看 auto/07p/doc/auto.pdf 文档,网上资料也有一些
请 Ubuntu高手试安装一下,指出小弟错误原因,帮我度此难关。万分感谢!!!!!!!!!!!!!
软件参看 http://indy.cs.concordia.ca/auto/ 及下载


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-13 22:49 
头像

注册: 2006-10-26 9:24
帖子: 345
地址: 中国-广西-南宁
系统: Ubuntu 16.04 LTS
送出感谢: 2
接收感谢: 0 次
It was requested that the plotting utility PLAUT04 be compiled but the proper libraries(Coin3D and SoQt or SoXt or Open Inventor and Open Inventor Xt and perhaps Motif libraries libXm) could not be found.


有包未装,编译条件未满足,后面再怎么make都不可能装得上的

建议看一下安装说明,看看需要那几个编译包......


_________________
Ubuntu 16.04 LTS使用中......

主板:XW4600
CPU:X3230
内存:2G x 4 = 8G
硬盘:16G SSD(/boot & /) + 80G HD(/Var & /tmp & swap) + 250G HD(/home) +500G HD(/media/Data)
显示器:EIZO L675


页首
 用户资料  
 
3 楼 
 文章标题 : 回复2楼
帖子发表于 : 2008-05-16 20:24 

注册: 2008-05-13 20:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
请问2楼是哪些包未安装呢?我个人认为提示应该是图形包未装,但命令行窗口应该可以通过编译呀,那为什么make后运行又提示无法找到interactiveBindings.py文件呢(实际上该文件确实存在),如果是高手的话,请下载那个软件(只有3M多)配置编译一下试试,我都快急死了,就当大家帮帮我这个成都的灾区人民!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-16 22:56 

注册: 2008-05-16 22:10
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
为什么不用sudo apt-get install auto

如果软件名不对,可以sudo apt-cache search auto后看信息确认名字

没有详细研究过,只是图形安装用过几次后觉的不好用,就彻底不用了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [问题]软件包Auto安装问题,请高手指点
帖子发表于 : 2013-06-28 23:31 

注册: 2012-11-14 20:31
帖子: 55
系统: Debian7.1
送出感谢: 0 次
接收感谢: 0 次
代码:
but the proper libraries(Coin3D and SoQt or SoXt or Open Inventor and Open Inventor Xt and perhaps Motif libraries libXm) could not be found

这个软件的库没有安装啊..


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [问题]软件包Auto安装问题,请高手指点
帖子发表于 : 2013-08-25 10:30 

注册: 2008-09-12 12:32
帖子: 261
送出感谢: 2
接收感谢: 13
sudo apt-get install libmotif-dev


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译