[问题]Ubuntu无法认出SATA硬盘

系统安装、升级讨论
回复
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

[问题]Ubuntu无法认出SATA硬盘

#1

帖子 achelust » 2008-05-17 18:32

我的配置:
CPU Intel Core 2 E6300
Memory DDR2 1G *2
GPU NV 7600GT
DISK Seagate SATA 320G
Mother Board Foxconn P965

分区情况:C 30G; D 267G.

以前装上过 Ubuntu,那时候是7.?,后来种种原因直接删除了整个分区,把它划到了D,用的是PM。
之后又装过几次。但是后来不知道怎么了,再想装的时侯就再也没认出过硬盘,就是分区的那一步没法看到硬盘,整个硬盘都看不到,用PM分出Linux分区也看不到,新刻的Ubuntu 8?和寄来的7? 64bit都没法认,在系统下找硬盘,反正怎么看,都没法看到有一个硬盘存在。看过一些帖子,大多数没法解决问题,不然就是要用DOS,我觉得那个有点风险,不知道还有什么解决办法没,硬盘上有一百多G的资料。。。
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

#2

帖子 hcym » 2008-05-17 18:47

P965

不应该

看不懂,和我的配置几乎一模一样,我都进了传说中的X86_64

7900GS,华硕的P965,Seagate SATA的盘用了N块


别是PM惹的祸,或者BIOS设置

:roll:
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

#3

帖子 achelust » 2008-05-17 19:04

似乎是主板问题,我这主板的控制芯片好像都要安装驱动
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

#4

帖子 hcym » 2008-05-17 19:42

965安装啥驱动


从7.....开始到8.04打了几十个滚了

P5B , P5B-E

alternate,server,desktop
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

#5

帖子 achelust » 2008-05-17 19:54

也许我说错了,我曾经装过这个linux发行版,我用openSUSE的时候可以非常方便的认到硬盘,直接安装起来,可是换到Ubuntu就是认不到,请问有人了解openSUSE和ubuntu的不一样吗,为什么它们一个可以一个不可以。不过我不喜欢openSUSE,它运行得非常缓慢。
wzdjp789
帖子: 89
注册时间: 2008-03-25 8:16
送出感谢: 0
接收感谢: 0

#6

帖子 wzdjp789 » 2008-05-17 20:27

我认为可以先用live cd进系统看看,如果live cd能运行的话,查看一下系统硬件。
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

#7

帖子 achelust » 2008-05-17 20:41

live cd可以使用,查看过那些信息,但是没有硬盘的信息。
mech
帖子: 466
注册时间: 2007-09-06 16:07
送出感谢: 0
接收感谢: 0

#8

帖子 mech » 2008-05-18 9:29

1.估计是PM的问题,有条件的话先把你的数据备份到另外的地方,重新分区、格式化
2.也可能是sata的支持问题,把cmos里的有关sata的项目调整看看行不行
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

#9

帖子 achelust » 2008-07-11 8:48

不幸的是,这块主板中的SATA相关设置我都看了,SATA MODE无法设置IDE模式,就没有什么别的SATA相关设置了。
我准备按照上面说的那么做,我买块新硬盘试试,毕竟我真的不想用windows了。 :evil:
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

#10

帖子 achelust » 2008-07-11 8:53

hcym 写了:P965

不应该

看不懂,和我的配置几乎一模一样,我都进了传说中的X86_64

7900GS,华硕的P965,Seagate SATA的盘用了N块


别是PM惹的祸,或者BIOS设置

:roll:
PM那款软件的确不怎么样,如果用Windows还说得过去,但是我肯定他把我的分区表弄乱了。
因为我曾经把分区调整过,原来的四个分区调整成三个,又把三个弄成了两个,而且这样干了还重新分配过大小,但是奇怪的是,我真的没法说,如果分区表乱,至少也认盘把,为什么Ubuntu不管是7还是8都不认呢?
如果有人PM过硬盘不见了告诉我一声,那我就能肯定是PM的问题了。
achelust
帖子: 8
注册时间: 2008-05-17 18:16
送出感谢: 0
接收感谢: 0

#11

帖子 achelust » 2008-07-21 11:20

回复

回到 “系统安装和升级”