更新出现 包的依赖问题?希望大家给看看!

系统安装、升级讨论
回复
ycg860102
帖子: 3
注册时间: 2008-05-29 11:39
送出感谢: 0
接收感谢: 0

更新出现 包的依赖问题?希望大家给看看!

#1

帖子 ycg860102 » 2008-05-29 12:10

各位来帮我看看这个问题吧!
在使用sudo apt-get upgrade 后出现的问题:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
libhtml-parser-perl: 依赖: perlapi-5.10.0 但却无法安装它
libperl5.10: 依赖: perl-base (= 5.10.0-10) 但是 5.8.8-12 已经安装了
perl: 依赖: perl-base (= 5.10.0-10) 但是 5.8.8-12 已经安装了
E: 不能满足依赖关系。不妨试一下 -f 选项。

在使用了sudo apt-get -f install 后出现的问题!
ycg@ycg-desktop:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
libhtml-parser-perl: 依赖: perlapi-5.10.0 但却无法安装它
libperl5.10: 依赖: perl-base (= 5.10.0-10) 但是 5.8.8-12 已经安装了
perl: 依赖: perl-base (= 5.10.0-10) 但是 5.8.8-12 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系

有知道这个问题的解决方法的吗?希望能够不吝赐教,现在什么软件都装不上了,希望各位帮我看看!
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2008-05-29 12:19

ycg860102
帖子: 3
注册时间: 2008-05-29 11:39
送出感谢: 0
接收感谢: 0

#3

帖子 ycg860102 » 2008-05-29 17:54

我把源换成和我的ubuntu版本一样也出现这样的问题!有没有办法解决阿?
急等回复阿!现在什么软件都装不上了!
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 dbzhang800 » 2008-05-29 17:58

ycg860102 写了:我把源换成和我的ubuntu版本一样也出现这样的问题!有没有办法解决阿?
急等回复阿!现在什么软件都装不上了!
1. 你确定 http://wiki.ubuntu.org.cn/Qref/Source 中的步骤你都做了?
2. 你确定 出错消息和上面的一样?
ycg860102
帖子: 3
注册时间: 2008-05-29 11:39
送出感谢: 0
接收感谢: 0

#5

帖子 ycg860102 » 2008-05-29 21:22

我确定!我就是照着http://wiki.ubuntu.org.cn/Qref/Source上说的,
我把源改为Ubuntu.cn99.com更新服务器(江苏省常州市电信,推荐电信用户使用): 上的地址
更新完以后还是出现上面的问题!

现在真的很苦恼!
回复

回到 “系统安装和升级”