[问题]求助!!更新出问题 [已解决]

系统安装、升级讨论
回复
wanjiaye
帖子: 5
注册时间: 2007-11-15 11:14
送出感谢: 0
接收感谢: 0

[问题]求助!!更新出问题 [已解决]

#1

帖子 wanjiaye » 2008-06-06 14:18

刚才更新安装的时候出现如下问题:
dpkg: 语法分析错误,在“/var/lib/dpkg/available”文件的第“39842”行附近 软件包“gfortran”:
在字段“Suggests”的值的前面发现了 EOF(缺少最后结尾的换行符)
E: Sub-process /usr/bin/dpkg returned an error code (2)
有软件包无法安装。试图恢复到上一版本:

请问这个怎么解决啊?谢谢
上次由 wanjiaye 在 2008-06-06 17:21,总共编辑 1 次。
头像
zhexuezhuzi
帖子: 884
注册时间: 2008-01-23 14:02
来自: 吉林大学
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]求助!!更新出问题

#2

帖子 zhexuezhuzi » 2008-06-06 14:55

wanjiaye 写了:刚才更新安装的时候出现如下问题:
dpkg: 语法分析错误,在“/var/lib/dpkg/available”文件的第“39842”行附近 软件包“gfortran”:
在字段“Suggests”的值的前面发现了 EOF(缺少最后结尾的换行符)
E: Sub-process /usr/bin/dpkg returned an error code (2)
有软件包无法安装。试图恢复到上一版本:

请问这个怎么解决啊?谢谢

不懂,帮你顶一下,免得沉了
wanjiaye
帖子: 5
注册时间: 2007-11-15 11:14
送出感谢: 0
接收感谢: 0

#3

帖子 wanjiaye » 2008-06-06 15:06

谢谢你,兄弟
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

#4

帖子 Ur@nus » 2008-06-06 15:42

问题倒是写的很清楚-----------gfortran的源代码有语法错误,改正这个错误我就不太懂了,可以在新立德将其彻底删除, 然后
sudo apt-get update
apt-cache search gfortran来重装一遍试试
如果还不行建议用intel的fortran,编译器替换gfortran.
wanjiaye
帖子: 5
注册时间: 2007-11-15 11:14
送出感谢: 0
接收感谢: 0

#5

帖子 wanjiaye » 2008-06-06 15:52

Ur@nus 写了:问题倒是写的很清楚-----------gfortran的源代码有语法错误,改正这个错误我就不太懂了,可以在新立德将其彻底删除, 然后
sudo apt-get update
apt-cache search gfortran来重装一遍试试
如果还不行建议用intel的fortran,编译器替换gfortran.
谢谢!但在新立德里面好像还删不掉gfortran,请问有其它办法删不?
wanjiaye
帖子: 5
注册时间: 2007-11-15 11:14
送出感谢: 0
接收感谢: 0

#6

帖子 wanjiaye » 2008-06-06 16:51

嗯,终于解决了,方法如下:
sudo dpkg --clear-avail
sudo apt-get update
头像
zhexuezhuzi
帖子: 884
注册时间: 2008-01-23 14:02
来自: 吉林大学
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 zhexuezhuzi » 2008-06-06 21:49

wanjiaye 写了:嗯,终于解决了,方法如下:
sudo dpkg --clear-avail
sudo apt-get update
能解释一下吗?比如你是怎么找到的,原理是什么??
sherd0407
帖子: 6
注册时间: 2009-01-23 17:31
送出感谢: 0
接收感谢: 0

Re: [问题]求助!!更新出问题 [已解决]

#8

帖子 sherd0407 » 2009-01-30 10:15

我就是碰到了这个问题,现在看到楼主的帖子,试了一下,现在正在更新,希望是可以解决问题!
回复

回到 “系统安装和升级”