[问题]升级出现问题,请各位帮助,谢谢

系统安装、升级讨论
7s777
帖子: 5
注册时间: 2007-07-24 1:32
送出感谢: 0
接收感谢: 0

[问题]升级出现问题,请各位帮助,谢谢

#1

帖子 7s777 » 2008-06-20 20:40

请问,这个新德立升级,有一个
“版本 2.6.24-19.34:

[Amit Kucheria]

* Revert "Update lpia configs to move modules into the kernel"
* LPIA: More conservative culling of LPIA config
- LP: #240938

升级出现错误,出现这个警告“E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.34_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份“
[/img]
请问上面的问题如何解决,下面有图片,希望各位大侠帮忙解决一下,谢谢。 Embarassed
:oops:
附件
Screenshot-变更已实施.png
bluemare
帖子: 52
注册时间: 2008-05-22 9:52
送出感谢: 0
接收感谢: 0

#2

帖子 bluemare » 2008-06-22 10:00

同问
sudo apt-get -f install能修复么?
7s777
帖子: 5
注册时间: 2007-07-24 1:32
送出感谢: 0
接收感谢: 0

#3

帖子 7s777 » 2008-06-22 10:15

:oops:试了一下,还是不行,希望各位大大帮助一下
秋水龙吟
帖子: 57
注册时间: 2007-12-06 23:03
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 秋水龙吟 » 2008-06-22 18:42

帮顶,同病相怜,一样的问题,高手们,人呢?帮忙啊!
头像
ellon
帖子: 358
注册时间: 2007-11-28 5:39
送出感谢: 0
接收感谢: 0

Re: [问题]升级出现问题,请各位帮助,谢谢

#5

帖子 ellon » 2008-06-24 12:19

7s777 写了:请问,这个新德立升级,有一个
“版本 2.6.24-19.34:

[Amit Kucheria]

* Revert "Update lpia configs to move modules into the kernel"
* LPIA: More conservative culling of LPIA config
- LP: #240938

升级出现错误,出现这个警告“E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.34_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份“
[/img]
请问上面的问题如何解决,下面有图片,希望各位大侠帮忙解决一下,谢谢。 Embarassed
:oops:
sudo apt-get clean清理一次,
再試試"源"那裡轉用主server,或者有效~
我升級到linux-image-2.6.24-19-generic_2.6.24-19.34沒問題,可能server問題?

還有,是不是boot的空間不足了?
gzjoekeny
帖子: 34
注册时间: 2008-05-08 14:37
送出感谢: 0
接收感谢: 0

#6

帖子 gzjoekeny » 2008-06-24 13:36

照做后出现以下提示:


E: 无法获得锁 /var/cache/apt/archives/lock - open (11 资源临时不可用)
E: 无法对下载目录加锁
头像
ellon
帖子: 358
注册时间: 2007-11-28 5:39
送出感谢: 0
接收感谢: 0

#7

帖子 ellon » 2008-06-24 15:23

gzjoekeny 写了:照做后出现以下提示:


E: 无法获得锁 /var/cache/apt/archives/lock - open (11 资源临时不可用)
E: 无法对下载目录加锁
強制解鎖可以嗎?
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock
gzjoekeny
帖子: 34
注册时间: 2008-05-08 14:37
送出感谢: 0
接收感谢: 0

#8

帖子 gzjoekeny » 2008-06-24 17:21

报告,不行.执行后没反应.然后再次升级出现同样错误
7s777
帖子: 5
注册时间: 2007-07-24 1:32
送出感谢: 0
接收感谢: 0

#9

帖子 7s777 » 2008-06-25 11:47

:( 各位大大,还是不行,上面的方法都使用过了,还是那个上面的信息,无法安装?请求帮助。谢谢
go2
帖子: 153
注册时间: 2008-05-17 4:14
送出感谢: 0
接收感谢: 0

#10

帖子 go2 » 2008-06-25 16:24

是否/boot为单独分区,而且小了
xj272844
帖子: 7
注册时间: 2007-12-04 12:42
送出感谢: 0
接收感谢: 0

#11

帖子 xj272844 » 2008-06-25 20:11

強制解鎖 我的问题解决
程序安装中。。。。。
cr500
sd192m
440bx
pci s3 1m
wd30g
mini win2k+puppy linux(xfce4+jwm+icewm)

----------做一个徘徊在Na~~Nc之间的人,嘿嘿!------------
bluemare
帖子: 52
注册时间: 2008-05-22 9:52
送出感谢: 0
接收感谢: 0

#12

帖子 bluemare » 2008-07-21 8:36

E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.36_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份
头像
chgc521
帖子: 204
注册时间: 2008-04-28 18:00
来自: 台州
送出感谢: 0
接收感谢: 0

#13

帖子 chgc521 » 2008-07-21 18:18

sudo rm -fv /boot/initrd.img-2.6.24*.bak
sudo rm -fv /boot/vmlinuz-2.6.24-19-generic
sudo rm -fv /boot/initrd.img-2.6.24-19-generic
sudo rm -fv /boot/config-2.6.24-19-generic
sudo rm -fv /boot//abi-2.6.24-19-generic
sudo rm -fv /boot/System.map-2.6.24-19-generic
即可!
然后就能正确更新
swearl
帖子: 1
注册时间: 2007-03-12 23:41
送出感谢: 0
接收感谢: 0

#14

帖子 swearl » 2008-07-25 22:19

13楼的有效~~谢谢~~~
bluemare
帖子: 52
注册时间: 2008-05-22 9:52
送出感谢: 0
接收感谢: 0

#15

帖子 bluemare » 2008-08-04 21:21

13楼正解,赞!~!
回复

回到 “系统安装和升级”